ringbuffer overflows

  • So, nun habe ich endlich mal die Zeit gefunden, ein anderes Ausgabeplugin zu testen.

    softhddrm & vaapidevice habe ich nicht zum Laufen bekommen, aber das normale softhddevice ging.


    Auch nach über 1h Laufzeit habe ich damit keine ring buffer overflows, auch diese kleinen Tonaussetzer sind damit nicht vorhanden.


    Damit muss der Fehler also irgendwie im softhdvaapi liegen.

  • Ähm, ist aus den yavdr-ppa für focal installiert, wie bekomme ich das raus, ob libplacebo reinkompiliert ist? Am ehesten kann das seahawk1986 beantworten.

    Aber wahrscheinlich ist es ohne libplacebo, denn scaler konnte ich unter softhdvaapi keine einstellen.


    Es gab weder dupped noch dropped frames. Das Log schweigt sich komplett aus, zu den kleinen Tonaussetzern und bis zun den buffer overflow Meldungen gibt es keine Auffälligkeiten im Log.

  • Die dupped und dropped frames siehst du im Status. Den erreichst du über das Hauptmenü. Und wenn du in den Konfigs schaust dann ist unter Video für jede Auflösung ein extra Punkt. Und da sieht man ob man scaler eintragen kann. Wenn das geht ist libplacebo drin.

  • Richtig. In der Konfig dort ist nichts einzustellen.

    Wegen der Frames muss ich heute abend evtl. nochmal schauen - Status/Hauptmenu ist mir bisher nicht im VDR-Menü untergekommen.

  • Status/Hauptmenu ist mir bisher nicht im VDR-Menü untergekommen.

    Ich glaube, er meint: Menü - System - Gerätestatus

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Nein tut er nicht. Das Plugin devstatus hat damit nichts zu tun.


    jojo61

    ich habe mal softhdvaapi wieder aktiviert. hatte in den settings im hauptmenü anzeigen deaktiviert. ich schaue dann im laufe des abends nochmal nach.

    auf die schnelle konnte ich auf das erste hd nach ein paar minuten 251 verdoppelte frames gesehen. ich lass später mal länger laufen.

  • jojo61

    Habe es nun mal eine ganze Weile auf Das Erste HD laufen lassen (bis nun wieder die ring buffer overflows auftraten).

    Bei ca. 100000 Frames gab 0 verloren, 2200 verdoppelt & 400 übersprungen.

  • Da ist wohl etwas gewaltig schief beim timing. Entweder kommt das Plugin nicht nach mit den Videoframes oder dein Ton läuft zu schnell.

    Nutzt du ALSA direkt oder geht der Ton über pulseaudio ?


    Läuft neben dem VDR noch etwas anderes auf dem Rechner ?


    Wenn es nicht besser wird dann nutze halt das softhddevice. Irgendwie scheint mein plugin nicht bei allen gleich gut zu funktionieren.

  • Ich nutze Pulseaudio. Auf dem NUC läuft nur der VDR.

    Betriftt eigenartigerweise ja nur bestimmte Sender (die Öffentlichen in HD). Und bis vor ein paar Tagen, bevor ich diesen Thread gestartet habe, gab es das Problem auch nicht.


    Ich würde schon irgendwie gerne Dein Plugin benutzen, weil es ansonsten besser läuft und vor allem gepflegt ist und rein auf vaapi-Ausgabe zugeschnitten ist. OSD mit skindesigner ist damit auch flüssiger als mit dem normalen softhddevice.

    Ich schau mal, ob ich von pulseaudio auf alse umgestellt bekomme.

  • OSD mit skindesigner ist damit auch flüssiger als mit dem normalen softhddevice.

    Da hilft wahrscheinlich ein Umstieg auf softhddevice-openglosd bzw. softhddevice-openglosd-ffmpeg2.8.

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Es geht hier um Ausgabe mit Intel-GPU und vaapi.

    Das gibt es mit openglosd nicht, da das für nvidia und vdpau ist.

    The post was edited 1 time, last by ofenheizer ().

  • :wand sorry, mein Fehler

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD