ringbuffer overflows

  • Hallo,


    seit gestern habe ich das Problem auf meinem Client, das nach einer Weile

    Code
    1. Feb 27 14:22:38 VDR vdr: [2521] ERROR: 245 ring buffer overflows (267524 bytes dropped)
    2. Feb 27 14:22:47 VDR vdr: [2521] ERROR: 117 ring buffer overflows (131224 bytes dropped)
    3. Feb 27 14:22:54 VDR vdr: [2521] ERROR: 70 ring buffer overflows (77080 bytes dropped)
    4. Feb 27 14:23:00 VDR vdr: [2521] ERROR: 17 ring buffer overflows (17296 bytes dropped)

    im Log auftauchen und Bild und Ton gestört sind. Schalte ich um, geht das wieder eine Weile. Aufgefallen bisher auf ARD HD, ZDF HD und RBB HD.


    Auf meinem Server habe ich das Problem nicht, nur auf dem Client.


    Wo kann das Problem liegen? Bis gestern keinerlei Probleme in diese Richtung.


    Server und Client laufen unter focal und sind mittel satip versorgt. Updatestand ist aktuell. Der Server ist headless und stellt über minisatip auch den satip-Server.

    Der Client ist ein NUC8i3BEH und läuft unter softhdvaapi, welches quasi der einzige unterschied ist.


    Wie kann man dem auf die Schliche kommen?


    Gruss.

    Markus

  • Gibt es da eventuell im Log etwas mehr Kontext und die Einträge herum?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Gibt es da eventuell im Log etwas mehr Kontext und die Einträge herum?

    nein, nix weiter. fängt plötzlich mit den overflow-Meldungen an.


    Welches Ausgabe-Plugin?

    wie oben schon beschrieben, softhdvaapi. war aber schon von anfang an das ausgabedevice.

  • Wurde ja nie etwas verändert. Würde dann ja sicherlich auch Aufnahmen betreffen.

    Eben im Pluugin-Setup nachgesehen, ist nicht auf 60Hz eingestellt.


    Die Fehler treten ja auch erst nach ein gewissen Zeit auf und nicht sofort.

  • Nach dem Kauf eines neuen Fernsehers hatte ich das Problem auch - Bild und Ton liefen auseinander und es begann zu ruckeln ("video/audio difference too big"). Lt. nvidia-Settings war alles auf "auto", und am Fernseher wurde der HDMI-Anschluß als "PC" erkannt und schien 60 Hz zu liefern. Obwohl die Modeline 50Hz sagte ...

    Erst ein Umstellen mittels nvidia-settings auf 50Hz brachte die (Er)Lösung.

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, ubuntu-focal, softhddevice
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-440)
    System SSD btrfs, snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.1 mit Frodo-vdr-epg-daemon, Kernel 5.4.0-20

    vdradmin-am, vdrmanager (Smartphone als FB), gerbera-mysql+LiveTV

  • Der Fernseher ist knapp 8 jahre alt und die Settings dort sind noch immer dieselben, wie seit Jahren, als es mit nvidia & vdpau losging. Alle Bildverbesserer sind deaktiviert.

    Gestern liess ich den VDR mehr als eine halbe Stunde auf SAT1 (SD) laufen, da trat kein Fehler auf. Zuvor am Abend auf rbb HD, nach ca. 20 min wieder die ring buffer overflows.


    Was kann ich noch testen?

  • Du kannst VDR patchen, um herauszufinden, welcher ringbuffer überläuft. Und den dann größer machen.


    Vermutlich holt softhdvaapi die Daten nicht schnell genug ab. Du kannst also ein anderes Ausgabeplugin testen.


    ~ Markus

    VDR1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Xubuntu 18.04, VDR 2.4x
    VDR2: ASUS P4B533, Celeron 2.4G, FF 1.5, Ubuntu 10.10, VDR 1.6 (SS2 Rev 2.6B)
    VDR Server: sheeva-plug

  • OK. Das mit dem anderen Ausgabeplugin werde ich mal versuchen.

    Patchen ist nicht so meins, da ich alles aus den yavdr-Quellen installiere.

    Wundert mich eben nur, dass es bis vorgestern lief - das letzte Update vom softhdvaapi aber schon vom 20.2. war.

  • Diese overflow Medung wird von void cRingBuffer::ReportOverflow(int Bytes) erzeugt.

    Im VDR wird diese Funktion nur in void cRecorder::Receive(const uchar *Data, int Length)verwendet, also bei einer Aufnahme.

    Sonst finde ich es nur in device.c des iptv-plugin bei void cIptvDevice::WriteData(uchar *bufferP, int lengthP).

    Helmut

  • Diese overflow Medung wird von void cRingBuffer::ReportOverflow(int Bytes) erzeugt.

    Im VDR wird diese Funktion nur in void cRecorder::Receive(const uchar *Data, int Length)verwendet, also bei einer Aufnahme.

    Sonst finde ich es nur in device.c des iptv-plugin bei void cIptvDevice::WriteData(uchar *bufferP, int lengthP).

    Helmut

    Aufnahmen macht der Client keine, alles auf dem Server. IPTV-Plugin benutze ich nicht.

  • So, eben noch mal einen Test auf ZDF HD gemacht.

    Nach ca. 20 min Laufzeit beginnen die Meldungen. CPU-Auslastung bleibt dabei in dem oben erwähnten Bereich. Irgendwann bleibt das Bild stehen und der Ton läuft weiter.


    EDIT1:

    1h auf Sky Cinema HD ==> keine ring buffer overflows


    EDIT2:

    1h auf SAT1 SD ==> keine ring buffer overflows

    The post was edited 2 times, last by ofenheizer ().

  • Schaue gerade rbb HD. Dabei fällt mir auf, dass es leichte Tonstörungen gibt (kurze Aussetzer).

    Das Log schweigt sich dazu aus. Evtl. irgendein Problem mit pulseaudio??

  • Evtl. irgendein Problem mit pulseaudio??

    Du kannst ja mal versuchsweise pulseaudio deaktivieren (https://wiki.archlinux.org/ind…ning_of_PulseAudio_server) und den Ton direkt über alsa ausgeben lassen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Muss mal am Wochenende schauen.

    Ich werde erstmal ein anderes Ausgabeplugin testen.


    Mich wundert es nur, dass es nur bestimmte Sender betrifft - ist ja aber schon mal eine Gemeinsamkeit.

    The post was edited 1 time, last by ofenheizer ().

  • Gibt es irgendwo eine history?

    apt loggt alles in /var/log/apt/history.log* Dateien.

    Mich wundert es nur, dass es nur bestimmte Sender betrifft - ist ja aber schon mal eine Gemeinsamkeit.

    Nutzen die betroffenen Sender einen besonderen Audiocodec?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Da ich heute nicht dazu kam, mal das Ausgabeplugin zu wechseln, nur kurz zum Audiocodec.

    Bei das Erste HD, ZDF HD zeigt mir femon zum Adudio an: MPEG-1 Layer II 256kbit/s 48000 Hz. Sat1 SD hat 192 kbit/s, bei Sky Cinema HD ist es AC-3 mit 384 kbit/s und 48000 Hz.

    Also keine keine großen Unterschiede.

    Aber die kleinen Tonfehler sind mir jetzt auch auf das Erste HD aufgefallen.