[Gelöst] WinTV dualHD - Moduloption um nur einen Tuner zu nutzen?

  • ich benutze ihn für DVB-T2 und habe keine Probleme.

    Das heißt, dass das Problem der sich gegenseitig beeinflussenden Tuner nur bei DVB-C existiert? Ich befürchte schon dass das ein Hardware Problem ist und der Stick somit für VDR im DVB-C Betrieb unbrauchbar ist.


  • ich benutze ihn für DVB-T2 und habe keine Probleme.

    ist der Stick bei Dir das einzige DVB-T device, oder gibt es noch ein anderes device, auf dem evtl. die EPG-Aktualisierung stattfindet?

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Ich bin mir nicht sicher, ob wir alle vom gleichen Problem reden. Bei mir treten die Störungen nämlich gefühlt nur unter bestimmten Bedingungen auf:

    * Direkt nach einem Schnitt des Bildes ("Kamerawechsel")

    * Offenbar nur bei HD Sendern (hab kein HD+ und keine Probleme auf den "privaten")

    * Besonders problematisch: Altes 4:3 SD Material von schlechter Qualität (scheinbar jedoch nur auf HD Sendern!). Dabei besonders bei durchlaufenden Abspannen. Je schlechter die Bildqualität des alten Materials, desto mehr Störungen sind es gefühlt.


    Dass das o.g. (vor allem der Bildschnitt) zufällig mit Transponderwechseln auf dem anderen Tuner zusammenhängt kann ich mir eigentlich nicht vorstellen.

    Vielleicht sollten wir mal unsere eingesetzten Kernelversionen vergleichen, ich setze aktuell Ubuntu 18.04 LTS ein mit Kernel-Version

    5.0.5-050005-generic.


    Viele Grüße

    Stephan

  • Das ist mein einziges DVB-T Device, EPG-Aktualisierung ist, glaube ich, abgeschaltet, muss ich mal schaun.


    vdr-User-# 755 to_h264 chk_r vdr-transcode

  • ...Da ich die Hardware bereits habe, schiele aber schon auf Sundtek...


    Hatte vorher auch (mehrere) Sundtek Adapter. Die Dinger sind von der Empfangsqualität super, aber zumindest bei mir haben die nach wenigen Jahren den Geist aufgegeben, was meiner Meinung nach für eine nicht besonders hohe Qualität der verwendeten Bauteile spricht. Zudem finde ich die für Single-Tuner Sticks ziemlich teuer. Und dual-Tuner bauen die ja leider nicht.

    Hatte sehr auf Sat->IP gehofft und mal mit der 4-Tuner Variante der Octopus NET getestet. Aber auch das war nicht das gelbe vom Ei: Zu lange Umschaltzeiten und immer mal wieder Aussetzer. Suche schon lange nach dem Königsweg, aber hab ihn bislang nicht gefunden...


    Viele Grüße

    Stephan

  • Kann man eigentlich sehen welche Firmware die Windows Software verwendet?


  • Könnte es sich bei den Bildproblemen, gerade speziell bei den USB-Tunern die hier ja scheinbar gerade zur Diskussion stehen, nicht auch um ein generelles Problem des USB-Buses handeln? (Bandbreite bzw. Latenz?)


    Die Klötzchenbildung bei Szenenwechsel deutet für mich eigentlich schon in Richtung Bandbreitenproblem im Transportstream. Gerade im Augenblick des Szenenwechsels treten ja die höchsten Bitraten (naja, eigentlich Symbolraten :o) ) auf. Wenn dann der USB-Port von Haus aus nicht gerade der schnellste ist, es sich um HD- Format handelt dann könnte der Engpass in der Bandbreite da doch evtl. auch auf dem USB-Bus auftreten, oder nicht?


    Und der USB-Port wird ja prinzipiell immer nur im polling-Mode betrieben, d. h. der sendet garantiert keine Interrupts wenn gerade Daten auf Abholung warten...


    Und: Ja, es kann auch Probleme geben, wenn zu viele Teilnehmer bzw. Receiver gleichzeitig neue Transponder tunen möchten, das äußert sich bei mir aber vollkommen anders, nämlich in hartem aufhängen des Multi-Switches. Dafür genügen aber nicht nur einstellige Tunerzahlen... ;) Auch das kann aber in anderen Konfigurationen natürlich ganz anders aussehen. Je nach Marke und Qualität der einzelnen verwendeten Komponenten.

  • Ich würde auch eher auf ein USB-Problem tippen, bei meinem vdr3 läuft der Stick nur an einem USB 3 Anschluss problemlos.


    vdr-User-# 755 to_h264 chk_r vdr-transcode

  • Ich habe die beiden Sticks auch an USB3 Ports hängen. Trotzdem Bildstörungen wenn der VDR für EPG oder Kanalsuche "zappt". Schalte ich beides aus, ist der Stream deutlich besser, aber auch nicht fehlerfrei. Die Klötzchen beim Wechsel des kompletten Bildinhaltes und bei schnellen Kameraschwenks bleiben trotzdem noch.


    Man kann also schonmal von zwei verschiedenen Problemen ausgehen.


    Edit: Deshalb bekommt man die Dualtuner auch für 45€ hinterher geschmissen.


  • OK, bleibt für mich als eventuelle Fehlerquelle noch ein bei USB-Geräten ebenfalls beliebtes Thema - die Stromversorgung. Hast du schon mal versucht, die Sticks über jeweils ein kurzes Verbindungskabel an einem aktiven USB-Hub zu betreiben? Ideal wäre natürlich ein USB3-Hub mit eigenem Netzteil, aber prinzipiell sollte eigentlich auch ein guter aktiver USB-2.0 Hub mit wirklich guten USB-Kabeln seinen Dient tun.


    Vielleicht ist ja die Stromversorgung aus dem Computerport etwas "schwächlich"? Gerade viele Notebooks oder auch SOCs glänzen da nicht gerade mit allzu hohen Reserven. Nachdem sehr viele der USB-Sticks im Dauerbetrieb auch ordentlich warm werden ist leicht nachvollziehbar, dass die Dinger auch relativ viel Strom ziehen.

  • Hallo,


    Hatte vorher auch (mehrere) Sundtek Adapter. Die Dinger sind von der Empfangsqualität super, aber zumindest bei mir haben die nach wenigen Jahren den Geist aufgegeben, was meiner Meinung nach für eine nicht besonders hohe Qualität der verwendeten Bauteile spricht. Zudem finde ich die für Single-Tuner Sticks ziemlich teuer. Und dual-Tuner bauen die ja leider nicht.

    auch Sundtek bietet einen Dual-Tuner USB-Stick an.

    Siehe -> https://www.namatek.com.tw/ind…uct&path=61&product_id=53


    P.S

    Für Ubuntu gibt es einen Kernel der alle Hauppauge Patches mitbringt.

    ...auch ein Firmware Paket ist dabei.

    Siehe -> https://launchpad.net/~b-rad/+…shed&field.series_filter=

    Damit konnte auch der 2te Tuner unter Ubuntu Trusty genutzt werden.

    Kernel gibt es für Ubuntu Eoan,Disco,Bionic & Xenial


    Gruss

    Wolfgang

  • auch Sundtek bietet einen Dual-Tuner USB-Stick an.

    Siehe -> https://www.namatek.com.tw/ind…uct&path=61&product_id=53

    Der kann aber kein DVB-C und auch kein DVB-T2.


    Und was die Ubuntu Geschichte angeht, es geht nicht darum den 2. Tuner nutzbar zu machen. Seid Kernel 4.17 geht der sowieso. Es gibt halt Probleme im Betrieb des 2. Tuners.


  • Mal was anderes, bezüglich USB Bandbreite. Eigentlich KANN das doch gar kein Problem sein. Zumindest wenn man Wikipedia glauben kann. Im Artikel zu DVB-C gibt es eine Tabelle mit den Bitraten eines DVB-C Kanals (in MBit/s). Bei 8 MHz Bandbreite, einer Symbolrate von 6900 und 256-QAM sind das ~50 MBit/s. Das ist quasi das was ein Transponder in dieser (bei mir überwiegenden) Konfiguration liefern kann. Das ganze x2, denn wir haben ja einen Dualtuner der uns zwei Transponder gleichzeitig liefert. Und soweit ich glaube zu wissen, wird auch immer der komplette Transponder vom Stick über den USB Bus geschaufelt, da er keinen Hardware PID Filter besitzt. Ich habe sogar zwei dieser Sticks. Macht zusammen ~200 MBit/s die über den USB2 Bus laufen. Macht 25 MB/s. Eine USB2 HDD kann ca 35 MB/s lesen/schreiben. Das sollte doch an dieser Stelle nicht klemmen können?


    Edit: Ausserdem laufen die isochron, reservieren sich also eine garantierte Bandbreite auf dem Bus.


  • Mal was anderes, bezüglich USB Bandbreite. Eigentlich KANN das doch gar kein Problem sein.

    Kann es auch nicht, zumindest nicht was die Bandbreite angeht: Lt. den technischen Spezifikationen ( https://www.hauppauge.de/site/…s/data_dualhd.html#tabs-2 ) verfügt der Stick lediglich über einen USB 2.0 Anschluss. Die potentiell höhere Geschwindigkeit von USB 3.0 kann er folglich gar nicht nutzen. Schließe ich ihn an einen USB 3.0 Anschluss an, wird er folglich auch nur als Gerät am USB 2.0 Bus angezeigt. Zur verdeutlichung ein Ausschnitt aus lsusb -t . An den beiden USB 3.0 Ports hängt aktuell eine USB 3.0 Festplatte und ein WinTV HD Adapter:


    /: Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M

    |__ Port 2: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 5000M

    /: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 480M

    |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=em28xx, 480M


    PS: Ich habe das vorhin mal von meinen USB 2.0 Ports auf die USB 3.0 Ports umgesteckt. Gefühlt habe ich seitdem eher mehr Artefakte als vorher - allerdings mittendrin und nicht wie vorher nur beim kompletten Bildwechsel.

  • Hm....finde ich etwas dubios, dass es den in diesem Taiwanesischen Shop gibt NICHT aber im Sundtek Shop selber. Auch wenn im "About" auf der Seite steht:

    "We have started in 2014 as a component distributor for Sundtek Germany. In 2018 we also started to license the hardware designs from Sundtek Germany and sell worldwide"


    Hat den mal jemand dort gekauft?

  • Hi,

    User Sundtek hat den Link hier gepostet.

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • OK, bleibt für mich als eventuelle Fehlerquelle noch ein bei USB-Geräten ebenfalls beliebtes Thema - die Stromversorgung. Hast du schon mal versucht, die Sticks über jeweils ein kurzes Verbindungskabel an einem aktiven USB-Hub zu betreiben? Ideal wäre natürlich ein USB3-Hub mit eigenem Netzteil, aber prinzipiell sollte eigentlich auch ein guter aktiver USB-2.0 Hub mit wirklich guten USB-Kabeln seinen Dient tun.


    Vielleicht ist ja die Stromversorgung aus dem Computerport etwas "schwächlich"? Gerade viele Notebooks oder auch SOCs glänzen da nicht gerade mit allzu hohen Reserven. Nachdem sehr viele der USB-Sticks im Dauerbetrieb auch ordentlich warm werden ist leicht nachvollziehbar, dass die Dinger auch relativ viel Strom ziehen.

    Ich hab die Sticks an nem normalen ATX Board, keinem Raspberry mit schwachem Netzteil o.ä. . Dennoch würde das erklären, warum es mit einem Tuner besser läuft als mit zweien -> Doppelte Leistungsaufnahme -> evtl. zu wenig mA für beide Tuner. Muss mal schauen ob ich irgendwo einen USB Hub habe mit Netzteil um die Theorie verifizieren oder falsifizieren zu können. Komme allerdings vermutlich frühestens ende nächster Woche an nen USB Hub, wenn also jemand vorher schon testen könnte, der einen greifbarer hat wäre das super :-)