Übernahme epgsearchdone.data zu epgd

  • Hallo,


    wollte mittels dem Script epgsearchdone.pl meine Daten aus der epgsearchdone.data zu epgd importieren.

    Bekomme aber eine Fehlermeldung:

    Code
    1. ./epgsearchdone.pl epgsearchdone.data loaddone
    2. install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (you may need to install the DBD::mysql module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.30.0 /usr/local/share/perl/5.30.0 /usr/lib/x86_64-linux-gnu/perl5/5.30 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.30 /usr/share/perl/5.30 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at (eval 8) line 3.
    3. Perhaps the DBD::mysql perl module hasn't been fully installed,
    4. or perhaps the capitalisation of 'mysql' isn't right.
    5. Available drivers: DBM, ExampleP, File, Gofer, Mem, Proxy, Sponge.
    6. at ./epgsearchdone.pl line 16.

    Ist das Script nicht mehr aktuell?


    Gruss.

    Markus

  • Ich denke da fehlt dir nur das Paket libdbd-mysql-perl

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Damit läuft es zumindest schonmal los, aber es hagelt Fehlermeldungen:

    Code
    1. DBD::mysql::st execute failed: Incorrect string value: '\xC3HILLA...' for column `epg2vdr`.`timersdone`.`complongdescription` at row 1 at ./epgsearchdone.pl line 62, < FILE> line 41908.

    Hat aber scheinbar geklappt, denn die Auftragshistorie im epghttp ist nun gefüllt.