Debian 10, XFCE4 WM, softhdvaapi startet im Fenster und verliert Focus...

  • Guten Tag meine Herren,


    also vaapidevice und softhdvaapi grundsätzlich beide arbeiten unter Debian 10 auf meinem J4105-ITX HTPC, und ich versuche die Konfiguration des Systems etwas zu finalisieren.

    Und ich bin mal wieder ratlos :-)


    Ich habe einen extra User in Linux eingerichtet, habe ich in dem lightdm autologin konfiguriert, und in den XFCE4 "Startup applications" habe ich ein Script zugefügt, der VDR startet.

    Und das komische Problem bleibt, daß VDR in einem Fenster startet, und wann ich das Fenster clicke, um damit VDR in den Fullscreen Mode zu umschalten, verliert VDR "focus" und will nicht mehr zu der Tastatur reagieren. Wenn ich das Fenster klicke, es umschaltet sich in den "windowed" Mode und reagiert weiter zu der Tastatur. Aber klicke ich nochmal, VDR umschaltet sich in den FullScreen, und das OSD nimmt nur eine Taste aus der Tastatur, dann aufgibt den Focus und reagiert nicht mehr... bis ich das FullScreen "Fenster" nochmal klicke, und so weiter.


    Ich habe sondern den xfce4-panel aus dem XFCE4 gelöscht, sodaß es in dem Bild nicht "blendet" und sodaß es den Focus nicht stehlt... aber das hat nicht geholfen. Die Workspaces sind jetzt ganz leer, es gibt keine anderen Apps / keine Fenster auf den Workspaces, und trotzdem verliert softhdvaapi den Focus.


    Ich dachte daß es in den Docs manche Möglichkeit gibt, den VDR+softhdvaapi direkt im FullScreen mode zu starten. Aber habe ich keine solche Option gefunden...


    Vielen Dank im Voraus für jegliche Einfälle :-)


    Frank

    The post was edited 1 time, last by frr: Zwei kleinen Korrigierungen meiner "Deutsch als Fremdsprache" ().

  • Hi,

    Welcher Windowmanager? Openbox?

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Welcher Windowmanager? Openbox?

    Das ist eine gute Frage :-) Ich habe an dem WM nicht herumgebastelt - also es sollte das Default sein. XFWM4 ?

    ps sagt

    xfwm4 --display :0.0 --sm-client-id 2a7598460-ca8e-4db1-8129-71df09e46bfd

    Den softhdvaapi kann man mit -f direkt im Fullscreenmodus starten.

    Danke :-) Damit startet jetzt mein HTPC direkt in dem "Fernseher mode" = es ist fast perfekt.

    Aber VDR benehmt sich wie beschrieben: ich muss in dieses "fullscreen Fenster" klicken, um es in den "windowed mode" umzuschalten, und erst danach arbeitet die Tastatur (wie in dem remote.conf konfiguriert).


    Hmm... ein kurzer Augenblick in die Konfiguration des WM's und WM Tweaks sagt mir, daß es noch was zum testen gibt. Das muss leider bis Abend warten :-( Gleich jetzt habe ich "compositing" ausgeschaltet, in dem Bild ergibt das keinen Unterschied, vielleicht spart es 0.5% CPU (der WM ist konfiguriert, fullscreen Fenster direkt zu zeigen) und die Tastatur vs. Focus benehmen sich ganz ebenso (wie mit "compositing" eingeschaltet).

  • Hi,

    Openbox ist halt ressourcenschonender als deiner. Kannst du ja mal testen.

    Ein anderes Desktop-Paket (xubuntu-desktop) muss in Ubuntu zumindest installiert sein (nicht ausgewählt, da reicht openbox) , sonst muss man sich beim Boot in X einloggen. Da sind wir gerade bei easyvdr v5 dran unter focal das zu umgehen.

    Vielleicht hilft es dir ja hier auch.

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • SurfaceCleanerZ : danke für den Hinweis... Ubuntu ist meine zweite Wahl in der Schlange - weil es neuere Versionen jeder Software enthaltet. Hoffentlich würde das bedeuten, daß ich weniger DVB-Sachen von Quellen übersetzen müssten. Wenn ich unter Debian verliere, würde ich sicher Ubuntu mal wieder probeiren - und warum denn nicht Xubuntu :-)

  • Hi,

    Das geht auch unter Lubuntu Server.

    Nehmen wir.

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Meine Herren -- diesmal möchte ich einen kleinen aber wichtigen Erfolg melden :-)

    Der Focus ist endlich in Ordnung.

    Die Option in den XFCE4 Einstellungen heisst "Activate focus stealing prevention". Erreichbar unter Window Manager Tweaks -> Focus.


    Es gibt da eine andere geheimnisvolle Option die lautet "Honor standard ICCCM focus hint". Die hat keinen Einfluss - wahrscheinlich weil softhdvaapi sich in diesem Punkt gut benehmt.

    In demselben Tab gibt es auch "When a window raises itself". Keine wichtige Option, aber ich habe "do nothing" ausgewählt, um sicher zu sein. Ähnlich, unter Window Manager -> Focus gibt es "Automatically give focus to newly created windows". Das habe ich auch ausgeschaltet... obzwar bin ich nicht ganz sicher, daß das die korrekte Wahl ist. Das sollte sich später zeigen, wann meine Kinder lernen mit den Workspaces zu arbeiten. Diese zweien Options haben jetzt keinen Einfluss, weil es keine neu-geöffneten Fenster in dem System gibt.


    Der HTPC benehmt sich jetzt grundsätzlich nüzlich. Jetzt werde ich die "user experience" noch etwas polieren :-)

    Gibt es manche Möglichkeit, dem softhdvaapi zu sagen, die clicks zu ignorieren? Um in dem full-screen Modus immer zu bleiben (die Fensterdekoration nie zu zeigen). Wenn es keine solche eingebaute Option gibt, muss ich das extern anordnen.


    Spielen mit wmctrl und xdotool wird bis morgen warten. Heute möchte ich etwas früher schlafen gehen :-)

    Danke noch mal...

  • Hmm. Ich spiele weiter mit dem Einfall, etwas automatisch zu tun, abhängig von in welchen Workspace der User sich momentan umschaltet. Ich habe mich wmctrl und xdotool angeschaut... beiden sind eigenständige Programme in der Kommando-Zeile. Und ich ekle mich etwas vor der Möglichkeit, wmcrtl sekündlich zu rufen (einen extra Prozess jedesmal zu starten). XDOtool sondern hat eine Library, die ich in meinen eigenen "Pieces" verwenden könnte... aber z.b. keine "bindings" für Perl. D.h. daß wenn ich etwas sparsames schreiben möchte, würde das reines C bedeuten. Na warum den nicht.


    Anders habe ich auch bemerkt, daß obzwar es angeblich eine Funktion gibt, ein Fenster zu "minimieren", namentlich "iconify" in X11 genannt, es gibt anscheinend keinen Gegenteil ein Fenster zu maximieren, oder sondern in den fullscreen Modus zu setzen. Das muss der Programm selber tun, oder? Ich könnte dem softhdvaapi im "maximiertes Fenster" Modus ein Click der Maus senden, um ihn zu sagen, das Fenster in den fullscreen umzukonfigurieren. Aber... wie würde ich durch wmctrl oder xdotool herausfinden, in welchem Mode sich das Fenster momentan befindet? Ich muss damit noch etwas spielen... aber es wird mir langsam klar, das es wahrscheinlich einfacher wäre, die Sache in den Quellen von softhdvaapi zu finden und einfach ändern+rekompilieren :-)


    ===EDIT===

    Ahh, Quatsch - bei dem wmctrl gibt es eine relevante Option -b toggle. Es kann ein Fenster horizontal und/oder vertikal maximieren, und es kann auch fullscreen einstellen.


    ===EDIT===

    Okay... also wmctrl und xdotool funktionieren bei mir fast nicht. Und obzwar ich ein Kommando bei xdotool gefunden habe, das das softhdcuvid Fenster nach vorne bringen kann, habe ich kein Kommando gefunden, womit ich den Focus zwingen könnte. Unabhängig von der "anti-focus-theft" Option in den WM-Tweaks. Und, ich habe wirklich keine Weise gefunden, wie den aktuellen Status des softhdcuvid Fensters heraus zu finden. Also irgend eine Hoffnung in dieser Richtung ist Quatsch :-)

    Es ist aber sicher möglich, durch wmctrl zu finden, welcher Workspace momentan geöffnet ist: wmctrl -l arbeitet normal. Und ps, kill und andere Kommandos arbeiten sicher normal :-)


    Letzten endes sollte ich vielleicht eine IR-Fernbedienung in Betrieb setzen - dabei hoffentlich gibt es kein Problem mit dem Focus. Und wann ich mit dem Desktop spielen will, beleidigt mich nicht, die Maus zu greifen.