vdr-transcode - swiss knife for transcoding

  • Hallo,


    ich habe jetzt dies getestet:

    ORIGINAL 4G

    DEFAULT 31G

    CRF30 31G

    QUALITY 30 0.4G

    QUALITY 1.5 2G


    Ich werde jetzt mal zwischenstufen ausprobieren und gucken, wo die Qualität vergleichbar zum Original ist.


    Was anderes:

    Kann man vt so einstellen, dass es nicht konvertiert, wenn die Quelle schon h264 ist, wenn das Ziel auch h264 ist?

    Natürlich gibt es das scenario, dass man dann dennoch konvertieren will, um die Bitrate anzupassen. Aber ich würde h264 Aufnahmen skippen wollen.


    Gruß,

    Hendrik

  • Das ist Standard.


    Danke für die Infos.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Hallo,


    irgendwo ist noch der Wurm drin.

    Ich schaffe es nicht mehr unter 32GB zu kommen.


    Ich sehe aber das Problem nicht... Siehst du etwas?


    Gruß,

    Hendrik

    Files

    • logfile.zip

      (20.47 kB, downloaded 6 times, last: )
    • logfile.zip

      (29.82 kB, downloaded 6 times, last: )

    yavdr 0.5 auf M3N78-EM, Cine S2

    The post was edited 1 time, last by henfri ().

  • Wo gibt es was zu sehen?


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Hallo,


    sorry, hab die Log-Datei nochmal oben angehängt - ich weiß nicht, was da schief gegangen ist.

    Hier die betreffende Zeile:

    Code
    1. ffmpeg -hide_banner -hwaccel vaapi -vaapi_device /dev/dri/renderD128 -hwaccel_output_format vaapi -i concat:00001.ts -map 0:v:0 -map 0:1 -map 0:2 -map 0:3 -c:v:0 h264_vaapi -profile:v high -level 4.1 -qp 21 -g 50 -vf deinterlace_vaapi -c:1 aac -b:1 96k -c:2 copy -c:3 copy -quality 0.5 -map_chapters -1 ../2018-09-01.00.28.10-14.rec/00001.ts

    Da wird ja der Quality Parameter korrekt übergeben.


    Gruß,

    Hendrik

  • -qp 21


    waren wir uns nicht einig, dass der Wert größer sein muss? Also -crf 30 oder so.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Hallo,


    also

    Code
    1. vt -test -quality -test 30
    2. [h264_vaapi @ 0x561f65b0fc80] Invalid quality level: valid range is 0-2, using 2.

    Ich finde keine Dokumentation von "quality".

    Und

    Führt auch zu 30G.


    Gruß,

    Hendrik

  • Nimm doch einfach den vorhandenen Parameter -crf


    -crf <n> # quality h264 default 21, < = better


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

    The post was edited 1 time, last by jsffm ().