vdr-transcode - swiss knife for transcoding

  • Ah, ok! Danke für die rasche Antwort!

    habe dazu folgendes festgestellt:

    irgendwie liegt es an den time-markern von dem ts-file.

    wenn ich das original-ts mit mplayer abspiele, beginnt die zeitspur irgendwo bei 9 stunden (anstatt bei 0).

    nach einem durchlauf wie dem oben (aufruf wurde von vt erzeugt):

    Code
    1. ffmpeg -hide_banner -ss 00:03:53 -to 01:45:05 -i concat:00001.ts -map 0:v:0 -map 0:1 -map 0:2 -map 0:3 -map 0:4 -c:v copy -c:1 copy -c:2 copy -c:3 copy -c:4 dvd_subtitle -metadata creation_time=2017-12-24T13:25:00 ../test.mp4

    stimmen die timestamps dann. Dann kann man einen zweiten durchlauf starten (mit dem durch vt erzeugten file als eingabe) und es passt.

    ist ziemlich eigenartig bei streams und ffmpeg...

    lg

    Otto

    VDR-User #132
    server: debian buster (virtuell unter proxmox), 2 x dvb-s2 (unicable)
    clients: kodis auf raspi, wetek, debian, fedora und android per vnsi


    The post was edited 1 time, last by oTTo001 ().

  • Ja, seltsam, ich hab grad mal nen kurzen Test gemacht, original ts, geht nicht, Kopie von ts nach ts, geht.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Neue Version:


    Bugfixes


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • vdpau

    Ich habe das Decoding mit vdpau eingebaut, das Problem war/ist, man braucht einen Zugriff auf den X-server, also DISPLAY=, bei mir ist das 0.0


    Wenn jemand was Anderes braucht, muss ich das konfigurierbar machen.


    Das ist interessant für die, die kein cuda haben.


    Ich möchte das noch einen Tag Testen, bevor ich das veröffentliche.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

    The post was edited 2 times, last by jsffm ().

  • Neu Version:


    Jetzt mit vdpau-Unterstützung.


    Das reduziert die CPU-Last.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Kurze Installationsanweisung ergänzt.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Ich habe das Skript gestern entdeckt und gleich eingesetzt, ich wollte einfach mal Danke dafür sagen!

    Blog


    VDR1 (Server): Asus P5QL Pro, Intel Quad Core, NVIDIA GT 640 (Zotac), Digital Devices Cine V7, OrigenAE S21T, yavdr ansible an Röhre mit vga2scart

    VDR2 (Client): AsRock ION 330, yavdr 0.6 an Panasonic Beamer (HDMI)

  • In Beschreibung Volume ergänzt:


    -vol <factor>|<stream>=<factor> # Volume


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Neue Version


    Bugfixes, vor Allem in Automation, wer das einsetzt, sollte updaten.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

    The post was edited 1 time, last by jsffm ().

  • Neue Version:


    Bugfixes


    Neu:


    Videos, die nach vdr konvertiert werden und weder 25, noch 50 fps haben werden entsprechend nach 25 oder 50 fps konvertiert. Dazu benutze ich den Filter -vf fps=<fps>.


    Stand: 17.2.


    Das heisst, ich habe länger nichts dran geändert, was für die Stabilität spricht.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Ich benötige mal eure Hilfestellung. Um die Hardwarebeschleunigung per vaapi zu nutzen muss ich wohl einen xserver installieren, sonst schein es nicht zu funktionieten. Momentan kommt folgende Fehlermeldung:


    [AVHWDeviceContext @ 0x5634deedbae0] No VA display found for device: /dev/dri/renderD128. Device creation failed: -22. Failed to set value '/dev/dri/renderD128' for option 'vaapi_device': Invalid argument


    Gibt es auf einem headless Server eine bestimmte Vorgehensweise um einen xserver zu installieren?

  • Du brauchst kein KDE oder sowas, Du brauchst nur X. Wie Du das am Besten installierst solltest Du die Debian Spezialisten fragen.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Ok, ich hab es gefunden, ich hab jetzt mal xserver-xorg-video-dummy und i965-va-driver installiert. Jetzt muss ich nur noch irgendwann mal auf vdr 2.4.1 und ffmpeg 4.2 umstellen dann sollte vdr-transcode auf dem server funktionieren. Mit ffmpeg 3.4.6 gibts fehler mit cut und rc_mode. Aber dafür mach ich ne neue VM mit focal am Wochenende.

  • Wenn Du Probleme hast, ffmpeg 4.2 zu installieren, zeig mir mal die Protokolle mit ffmpeg 3.4, evtl. kann man das ja einfach anpassen.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • ffmpeg -hide_banner -hwaccel vaapi -vaapi_device /dev/dri/renderD128 -hwaccel_output_format vaapi -i concat:00001.ts|00002.ts|00003.ts -map 0:v:0 -map 0:1 -map 0:2 -c:v hevc_vaapi -profile:v main -tier high -rc_mode CQP -qp 28 -g 50 -c:$ Unrecognized option 'rc_mode'. Error splitting the argument list: Option not found


    Das ist der Fehler der jetzt noch kommt.

  • Ich hab mal ein bischen rumgespielt, in ffmpeg 3.4 scheint da einiges zu fehlen oder komplett anders zu sein. Der generierte Befehl aus dem log läuft erst wenn ich


    -profile:v main -tier high -rc_mode CQP


    rausnehme.


    -i concat:00001.ts|00002.ts|00003.ts


    schein 3.4 auch nicht zu verstehen mit -i 00001.ts läuft wenigstens mal der erste Part.


    Wird wohl einfacher sein das Ganze erst unter Focal zu probieren.

  • concat sollte mit 3.4 aber funktionieren, vaapi ist etwas eingschränkt, das stimmt.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Ich hab das mal gerade mit 3.4.5 getestet, concat funktioniert.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Mit ffmpeg -h encoder=h264_vaapikannst Du Dir die möglichen Parameter anzeigen lassen.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Ich habe jetzt mal auf ubuntu bionic auf ffmpeg 4.2 umgestellt, damit läuft jetzt alles wie es soll. Ist eine nvidia Karte GT 1030 viel schneller im transcodieren von h264 nach hevc? Die intel hd630 schafft das bei mir etwa mit faktor 3x.