vdr-transcode - swiss knife for transcoding

  • Du erwähntest einen vt.log, nicht logfile, ok, hätte man übersetzen können ...


    Edit:


    Die angehängte Datei ist nicht die logfile, die befindet sich im Aufnahmeverzeichnis.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

    The post was edited 1 time, last by jsffm ().

  • Quote


    Du erwähntest einen vt.log,

    Sorry, war abgekürzt.


    Quote

    die befindet sich im Aufnahmeverzeichnis.

    Ich kann da aber keine Logdatei finden, muß man das als Parameter mitgeben, damit eine erzeugt wird? Oder handelt es sich um die Ausgaben, die vdr-transcode macht wenn es wandelt?

    Blog


    VDR1 (Server): Asus P5QL Pro, Intel Quad Core, NVIDIA GT 640 (Zotac), Digital Devices Cine V7, OrigenAE S21T, yavdr ansible an Röhre mit vga2scart

    VDR2 (Client): AsRock ION 330, yavdr 0.6 an Panasonic Beamer (HDMI)

  • Ja, die werden in eine Datei "logfile" geschrieben. In Deinem Fall fürchte ich allerdings, dass das nicht weiterhilft, da es vermutl. ein vdr, bzw. plugin Problem ist.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

    The post was edited 1 time, last by jsffm ().

  • Vermute ich auch, ich werde mal sukzessive die Plugins deaktivieren und dann schaumerma.

    Blog


    VDR1 (Server): Asus P5QL Pro, Intel Quad Core, NVIDIA GT 640 (Zotac), Digital Devices Cine V7, OrigenAE S21T, yavdr ansible an Röhre mit vga2scart

    VDR2 (Client): AsRock ION 330, yavdr 0.6 an Panasonic Beamer (HDMI)

  • Problem gefunden, softhddevice-openglosd scheint die von vdr-transcode gewandelten Aufnahmen nicht zu mögen, mit dem normalen softhddevice läuft es.

    Blog


    VDR1 (Server): Asus P5QL Pro, Intel Quad Core, NVIDIA GT 640 (Zotac), Digital Devices Cine V7, OrigenAE S21T, yavdr ansible an Röhre mit vga2scart

    VDR2 (Client): AsRock ION 330, yavdr 0.6 an Panasonic Beamer (HDMI)

  • Es hat sich viel getan, daher eine neue Version:


    Changelog:


    -i Eingabe direkt per http möglich, z.B. Mediathek.

    -vc|-vcodec <codec> # overwrites -h264|-hevc|-mpeg2

    -mark <mark> # mark at the end of transcoded recordings

    -odir <path> # output directory

    --diag

    -o mp3 Es wird nur die Tonspur ausgegeben.

    aaclib=aac Standard

    kvazaar HEVC Encoder, weniger CPU-Last als libx265, somit schneller

    Debiannutzer finden hier eine passende ffmpeg-Version, die auch libfdk_aac enthält.

    libx265 Preset auf ultrafast geändert.
    blancs in Dateiname erlaubt, danke an Frankkaktus


    bugfixes


    Viel Spaß damit


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Test der neuen Version:


    - zuerst neues ffmpeg 4.3.1 und x265 kompiliert:

    - neue version installiert

    - /etc/vdr-transcode.conf:

    - test geht schief:

    werden die Audio-Einträge in der vdr-transcode.conf auf "copy" gesetzt wird eine mp4 erstellt .....


    Meine Fragen/ Bitte um Hilfe:

    1) was mache ich hier falsch bzw. wie kann ich abhilfe schaffen? (-aac_6ch_br 256 bringt die Meldung "-aac_6ch_br wrong"; -aac_stereo_br 96 erstellt ein File

    2) ich würde gern meine Aufnahme in FullHD-Videos mit aac/ ac3 / stereo-sound auf möglichst minimale Größe bringen wollen. Untertitel benötige ich nicht (leider werden die Untertitel nicht mittig im Video plaziert). Deutsche Tonspur + Englische + Russsiche + Französische + Spanische Tonspur wäre super. Wie muss meine vdr-transcode.conf dann aussehen?

    ------------------------------------------------------------------------------------------------------------------------------------------------

    BM2LTS im VDR-Portal   http://www.bm2lts.de   http://www.sc-schulze.de

    ------------------------------------------------------------------------------------------------------------------------------------------------

    Empfang: Octopus Net S2 max (8 Tuner) +Netceiver mit 2x DVB-s2 dual

    Kopfstation/ Wohnzimmer: Intel NUC8i3BEH2; BM2LTS v3.2.XX

    VDR: Intel NUC D54250WYKH2; BM2LTS Route 66

    weitere Client's: FireTV 4k mit Kodi u. VNSI-Plugin

    ------------------------------------------------------------------------------------------------------------------------------------------------


    The post was edited 2 times, last by stschulze ().

  • Code
    1. [NULL @ 0x5593efe42e00] Unable to find a suitable output format for 'aac'

    Da stimmt was mit Deinem ffmpeg nicht.


    Testen wir mal die neue Diag-Funktion


    Code
    1. vt --diag

    Davon hätte ich gerne die Ausgabe


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • ------------------------------------------------------------------------------------------------------------------------------------------------

    BM2LTS im VDR-Portal   http://www.bm2lts.de   http://www.sc-schulze.de

    ------------------------------------------------------------------------------------------------------------------------------------------------

    Empfang: Octopus Net S2 max (8 Tuner) +Netceiver mit 2x DVB-s2 dual

    Kopfstation/ Wohnzimmer: Intel NUC8i3BEH2; BM2LTS v3.2.XX

    VDR: Intel NUC D54250WYKH2; BM2LTS Route 66

    weitere Client's: FireTV 4k mit Kodi u. VNSI-Plugin

    ------------------------------------------------------------------------------------------------------------------------------------------------


  • Zur Sicherheit nochmal


    Code
    1. ffmpeg -hide_banner -encoders | grep aac


    Da fehlt offensichtlich aac


    Was mir noch aufgefallen ist:


    Code
    1. -r 30 #<n> # fps

    30 ist ziemlich ungewöhnlich.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Gib doch mal das Ergebnis von


    Code
    1. ffmpeg -hide_banner -buildconf 2>&1 | grep disable


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Du hast --enable-libfdk-aac

    Warum nutzt Du das nicht?


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Code
    1. root@BM2LTSR66Nuc64native:/media/hd/recordings/Autotimer/Nachrichten/Tagesschau/2020-11-15.20.00.1-0.rec# ffmpeg -hide_banner -buildconf 2>&1 | grep disable
    2. --disable-filter=resample
    3. root@BM2LTSR66Nuc64native:/media/hd/recordings/Autotimer/Nachrichten/Tagesschau/2020-11-15.20.00.1-0.rec# ffmpeg -hide_banner -encoders | grep aac
    4. A..... aac AAC (Advanced Audio Coding)
    5. A..... libfdk_aac Fraunhofer FDK AAC (codec aac)



    -r 30 #<n> # fps


    Welchen Wert sollte ich nehmen? 25? 50 braucht es doch nicht ...oder?


    Das File wird mit libfdk_aac größer als mit aac .....

    ------------------------------------------------------------------------------------------------------------------------------------------------

    BM2LTS im VDR-Portal   http://www.bm2lts.de   http://www.sc-schulze.de

    ------------------------------------------------------------------------------------------------------------------------------------------------

    Empfang: Octopus Net S2 max (8 Tuner) +Netceiver mit 2x DVB-s2 dual

    Kopfstation/ Wohnzimmer: Intel NUC8i3BEH2; BM2LTS v3.2.XX

    VDR: Intel NUC D54250WYKH2; BM2LTS Route 66

    weitere Client's: FireTV 4k mit Kodi u. VNSI-Plugin

    ------------------------------------------------------------------------------------------------------------------------------------------------


  • Zu -aac_6ch_br, da ist tatsächlich noch ein bug drin, aber 256k ist Standard und braucht nicht angegeben zu werden.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • aac und libfdk_aac sollten die gleiche Größe erzeugen.


    Um der Meldung [NULL @ 0x5593efe42e00] Unable to find a suitable output format for 'aac' nach zu gehen, brauche ich die Datei logfile im Zielverzeichnis, die sollte immer gepostet werden.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Zu Deiner Konfiguration:


    Code
    1. -aac_stereo_br # default 96k
    2. -hevc_level #<level>

    Hier fehlt der Parameter, das führt vermutlich zu Fehlern


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • was sollte da stehen ...sinnvollerweise? hevc_level

    ------------------------------------------------------------------------------------------------------------------------------------------------

    BM2LTS im VDR-Portal   http://www.bm2lts.de   http://www.sc-schulze.de

    ------------------------------------------------------------------------------------------------------------------------------------------------

    Empfang: Octopus Net S2 max (8 Tuner) +Netceiver mit 2x DVB-s2 dual

    Kopfstation/ Wohnzimmer: Intel NUC8i3BEH2; BM2LTS v3.2.XX

    VDR: Intel NUC D54250WYKH2; BM2LTS Route 66

    weitere Client's: FireTV 4k mit Kodi u. VNSI-Plugin

    ------------------------------------------------------------------------------------------------------------------------------------------------


  • Wenn Du das nicht weisst, brauchst Du es auch nicht ;)

    Das ist der level für hevc, einfach weglassen.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • das sieht doch schon mal ganz gut aus :)Danke für die Hilfe

    Files

    ------------------------------------------------------------------------------------------------------------------------------------------------

    BM2LTS im VDR-Portal   http://www.bm2lts.de   http://www.sc-schulze.de

    ------------------------------------------------------------------------------------------------------------------------------------------------

    Empfang: Octopus Net S2 max (8 Tuner) +Netceiver mit 2x DVB-s2 dual

    Kopfstation/ Wohnzimmer: Intel NUC8i3BEH2; BM2LTS v3.2.XX

    VDR: Intel NUC D54250WYKH2; BM2LTS Route 66

    weitere Client's: FireTV 4k mit Kodi u. VNSI-Plugin

    ------------------------------------------------------------------------------------------------------------------------------------------------


  • Was mir noch aufgefallen ist:


    Code
    1. -mark <mark> # mark at the end of transcoded recordings
    2. -odir /media/hd/recordings/VideoTranscoding/OUTPUT #<path> # output directory

    Ich hatte bei der Programmierung ausgeschlossen, dass beides gleichzeitig angegeben wird, weil das m.E. keinen Sinn macht. Des Weiteren macht die Anweisung -mark <mark> so natürlich auch wenig Sinn.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding