yavdr experimental für Ubuntu 20.04 (yavdr ansible @ focal)

  • Kannst du mal den ist-Zustand der Datei zeigen?

    Ich hänge die Datei einfach mal an...

    Ich habe hierfür, wie besschrieben, ein separates Verzeichnis "/host_vars" in "vdr-ansible" angelegt. Die angefügte Datei liegt dort unter dem Namen "localhost"

  • Die Raute vor #channellogo_languages solltest du noch entfernen.


    Cheers,

    Ole

  • Die Raute vor #channellogo_languages solltest du noch entfernen.


    Cheers,

    Ole

    OK. Das war für mich nicht ersichtlich, dass dieser Ausdruck Bestandteil der Konfiguration ist. Ich habe dies als Erläuterung interpretiert. Danke für die Aufklärung! Ich probiere es aus, habe aber momentan meinen alten VDR wieder im Betrieb genommen (alte Platte wieder in meinen VDR). Dauert also...ich melde mich in den nächsten Tagen, ob das Skript durchgelaufen ist.

    Schönen Dank für die Hinweise!!!

  • Bitte auch an die Bionic-User denken

    Für die gibt es seit gestern Abend auch Pakete zum ausprobieren: https://launchpad.net/~seahawk…+archive/ubuntu/vdr-2.4.1

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • OK. Das war für mich nicht ersichtlich, dass dieser Ausdruck Bestandteil der Konfiguration ist. Ich habe dies als Erläuterung interpretiert. Danke für die Aufklärung! Ich probiere es aus, habe aber momentan meinen alten VDR wieder im Betrieb genommen (alte Platte wieder in meinen VDR). Dauert also...ich melde mich in den nächsten Tagen, ob das Skript durchgelaufen ist.

    Schönen Dank für die Hinweise!!!

    Also, die Hinweise waren natürlich richtig. Die Intallation ist durchgelaufen wie sie sollte. Danek nochmal für die Hinweise.


    Derzeit käpfe ich mit der Konfiguration meiner DD Cine 6.5. Der Kerlen erkennt das Gerät wie erwartet und es werden wohl auch zwei Tuner angelegt.


    Code
    1. [ 3.914934] ddbridge 0000:05:00.0: detected Digital Devices Cine S2 V6.5 DVB adapter
    2. [ 3.934525] ddbridge 0000:05:00.0: Port 0: Link 0, Link Port 0 (TAB 1): DUAL DVB-S2
    3. [ 3.955467] dvbdev: DVB: registering new adapter (DDBridge)
    4. [ 3.955468] dvbdev: DVB: registering new adapter (DDBridge)
    5. [ 4.199307] ddbridge 0000:05:00.0: DVB: registering adapter 0 frontend 0 (STV090x Multistandard)...
    6. [ 4.243401] ddbridge 0000:05:00.0: DVB: registering adapter 1 frontend 0 (STV090x Multistandard)...


    In den Einstellungen für VDR wird aber nur ein Device angezeigt, das aber keine Singnale vom LNB erhält. Das Kernel-Moul gibt folgende Ausgabe:


    In den Systemeinstellungen von VDR ist als Primäres DVB-Interface = 2 voreingestellt. Ich kann diesen Wert nur von 2 auf 1 umstellen, dann kommt aber die Bedineoberfläche von VDR nicht zurück. Der Versuch mit w_scan nach neue Kanälren auf dem Tuner zu suchen, ist mit der Fehlermeldung, dass nichts gefunden wird abgebrochen.


    Hat vielleicht jemand eine Idee, wo ich nach dem Fehler noch suchen könnte?

  • Da müßte sich noch ein Tuner melden ("attach"), bei mir etwa (dmesg):

    wobei ich einen dvb-c/t-Zusatz (flex-Modul) auf "Tab3" noch dazu habe.

    Ohne Tuner auch keine Frontends,

    bitte ls /dev/dvb/* kontrollieren,

    hier:

    ls /dev/dvb/*

    /dev/dvb/adapter0:

    demux0 dvr0 frontend0 net0


    /dev/dvb/adapter1:

    demux0 dvr0 frontend0 net0


    /dev/dvb/adapter2:

    demux0 dvr0 frontend0 net0


    /dev/dvb/adapter3:

    demux0 dvr0 frontend0 net0


    Ist auch das "Disketten-Kabel" (Zusatzstromversorgung) angeschlossen?

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-460.32), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.6-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.10.9-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Das ist mir nicht klar: Die Cine S2 6.5 hat doch aber nur 2 Tuner, warum sollte sich da noch ein Adapter melden?


    Meine Ausgaben sieht wie folgt aus:

    Code
    1. /dev/dvb/adapter0:
    2. demux0 dvr0 frontend0 net0
    3. /dev/dvb/adapter1:
    4. demux0 dvr0 frontend0 net0


    An den Anschlüssen der Karte habe ich nichts verändert. Wenn ich mit yavdr 0.6 starte, funktioniert ja alles wie es soll.

  • Das ist mir nicht klar: Die Cine S2 6.5 hat doch aber nur 2 Tuner, warum sollte sich da noch ein Adapter melden?


    Meine Ausgaben sieht wie folgt aus:

    Code
    1. /dev/dvb/adapter0:
    2. demux0 dvr0 frontend0 net0
    3. /dev/dvb/adapter1:
    4. demux0 dvr0 frontend0 net0


    An den Anschlüssen der Karte habe ich nichts verändert. Wenn ich mit yavdr 0.6 starte, funktioniert ja alles wie es soll.

    Habe jetzt zum Testen die Koaxkabel der zwei Tuner getauscht. Aber auch das hat nicht gebracht. Wenn ich im Einstellungsmenü von VDR das Primäre Device umstelle, erhalte ich folgende Meldungen im Logfile:


    Code
    1. May 10 13:30:10 yavdr vdr: [3810] device 1 receiver thread ended (pid=3756, tid=3810)
    2. May 10 13:30:10 yavdr vdr: video/vdpau: can't render mixer: An invalid handle value was provided.
    3. May 10 13:30:10 yavdr vdr: [3756] OSD size changed to 720x480 @ 1
    4. May 10 13:30:10 yavdr vdr: [3756] info: Primäres Interface wird umgeschaltet...
    5. May 10 13:30:10 yavdr vdr: [3756] ERROR: no OSD provider available - using dummy OSD!
    6. May 10 13:30:16 yavdr vdr: osd2web: Info: Can't get schedules
    7. May 10 13:30:34 yavdr vdr: [3761] frontend 1/0 timed out while tuning to channel 8 (zdf_neo HD), tp 111361
  • Ist das "primäre Interface" nun 3? Bei mir, mit 4 Einträgen in /dev/dvb/..., ist es "5".

    Ich bilde mir ein, in dem Thread was von "2" gelesen zu haben?

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-460.32), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.6-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.10.9-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Meinst Du diese Ausgabe von lspci?


    Code
    1. 05:00.0 Multimedia controller: Digital Devices GmbH Octopus DVB Adapter
    2. Subsystem: Digital Devices GmbH Cine S2 V6.5 DVB adapter
    3. Flags: bus master, fast devsel, latency 0, IRQ 16
    4. Memory at f3100000 (64-bit, non-prefetchable) [size=64K]
    5. Capabilities: <access denied>
    6. Kernel driver in use: ddbridge
    7. Kernel modules: ddbridge


    Beim Start von VDR kann man als Parameter --device=NUM (Nummer des Device der DVB-Karte) angeben. Hier steht bei mir 2 drin. Über das Einstellungsmenü im VDR kann man im Bereich DVB ja zudem das primäre Device angeben (oder die in der setup.conf manuell setzen). Hier habe ich aber nur eine Auswahl zwischen 1 und 2. Wenn ich den Parameter auf 2 belasse, erhalte ich zumindenst die Bedienoberfläche, aber kein TV-Bild (die Signal-Inforamtion sagt, dass hier nichts ankommt). Wenn ich diese Einstellung auf 1 verändere, wird auch die Bedienoberfläche des VDR nicht mehr angezeigt. Bist Du der Meinung, dass hier als Device-Nummer = 5 gesetzt werden müsste? An welcher Stelle sollte dies dann konfiguriert werden?


    Ich habe auch versucht, ein anderes Ausgabeplugin für die Cine S2 6.5 zu verwenden. Eine Ausgabe des VDR-Skins erhalte ich "gefühlt" bisher nur mit softhddevice. Gib es eine Empfehlung, welches Ausgabeplugin unter focal für die Cine 2S verwendet werden sollte (meine alte Installation yavdr 0.6 läuft mit softhddevice problemlos)?

  • Wenn Du --device=2 mitgibst, wird auch nur 1 Tuner benutzt, und zwar Nummer 2. Für beide den Eintrag --device= weglassen.

  • In den DVB-Einstellungen, wenn 2 Einträge in /dev/dvb/ existieren, muß sich das eigentlich auf 3 einstellen lassen.

    Ich kann jedenfalls 1,2,3,4,5 wählen bei meinem System (hat aber 4 frontends).

    Es ist mittels der Modulparameter auch möglich, die Devices anders zuzuordnen:

    Code
    1. parm: adapter_nr:DVB adapter numbers (array of short)
    2. parm: adapter_alloc:0-one adapter per io, 1-one per tab with io, 2-one per tab, 3-one for all (int)

    Wenn ein "adapter_alloc" von 1 oder 2 für ddbridge gesetzt sein sollte, kann auch nur 1 device (mit 2 Frontends) und damit max. 2 als Nummer des softhddevices möglich sein, das würde dann aber als "frontend0" und "frontend1" in derselben Zeile unter /dev/dvb/* auftauchen.

    Man kann auch "adapter_nr" setzen, z.B. auf "adapter_nr=2,3" (Zählung beginnt nicht bei "0") und dann müßte nach Neustart

    das Softhddevice auf 1 zu stellen sein.

    Aber irgendwo muß noch ein Fe_ler stecken ... normal tut man am besten nix dergleichen.

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-460.32), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.6-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.10.9-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Beim Installieren des vor-plugin-iptv ist mir aufgefallen, dass es eine Abhängigkeit gibt zu libplacebo. Leider bindet das Plugin die Version von der Ubuntu Distribution und nicht die Version aus dem yaVDR PPA. Das Ergebnis ist eine doppelte Installation von libplacebo - ich weiß nicht ob das sich nicht auch auf das Ausgabeplugin softhdvaapi auswirkt.

    Ist es möglich die Abhängigkeiten anzupassen und das vdr-plugin-iptv neu zu bauen?


    Vielen Dank,

    adumar

    VDR1 Fujitsu D3400-B2 Celeron 3930 HD610, 8GB RAM, WinTV-quadHD (DVB-T), yaVDR ansible BIONIC, softhdvaapi, skindesigner

    VDR2 NUC8i3BEH2, 16GB RAM, WinTV-dualHD (DVB-T/DVB-C), yaVDR ansible FOCAL, softhdvaapi, skindesigner

  • Beim Installieren des vor-plugin-iptv ist mir aufgefallen, dass es eine Abhängigkeit gibt zu libplacebo.

    Das kann ich anhand des Quellpakets gerade nicht nachvollziehen - hängt eventuell VLC oder eine der Abhängigkeiten des Pakets davon ab?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Tja, Du hast recht - es ist der vlc.


    Wenn ich versuche das libplacebo7 Paket zu deinstallieren wird vlc auch mitgenommen

    Hoffentlich gibt es kein Durcheinander mit den Versionen.


    Gruß,

    adumar

    VDR1 Fujitsu D3400-B2 Celeron 3930 HD610, 8GB RAM, WinTV-quadHD (DVB-T), yaVDR ansible BIONIC, softhdvaapi, skindesigner

    VDR2 NUC8i3BEH2, 16GB RAM, WinTV-dualHD (DVB-T/DVB-C), yaVDR ansible FOCAL, softhdvaapi, skindesigner

  • Kann ich nachvollziehen und mit dem letzten Commit scheint der VDR dann einfach komplett einzufrieren, wenn das OSD angezeigt wird (mit LCARS als Skin). Vielleicht hat jojo61 da eine Idee dazu.

    Ich baue erst mal die Version 2.63 wieder im PPA, die hat ja halbwegs funktioniert...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Kann ich nachvollziehen und mit dem letzten Commit scheint der VDR dann einfach komplett einzufrieren, wenn das OSD angezeigt wird (mit LCARS als Skin). Vielleicht hat jojo61 da eine Idee dazu.

    Ich baue erst mal die Version 2.63 wieder im PPA, die hat ja halbwegs funktioniert...

    Von welcher placebo Version redet ihr denn hier. Ich hatte eine Änderung eingecheckt weil die neueren placebo Versionen das API geändert hatten und es deswegen gar nicht mehr ging. Derzeit teste ich mit der placebo API Version 59.