yavdr experimental für Ubuntu 20.04 (yavdr ansible @ focal)

  • Wie komme ich denn per node2 an die Rohdaten?

    Der Empfänger wird über das Kernel-Modul serial_ir eingebunden, lircd ist da nicht mehr beteiligt. Du kannst bei gestopptem eventlircd.service und eventlircd.socket mit ir-keytable -t die Tastendrücke ansehen und wenn du die Keytable löschst (ir-keytable -c), bekommst du die rohen dekodierten Scancodes.


    Im VDR kannst du über die Fernbedienungseinstellungen (vgl. https://projects.vdr-developer…dr.git/tree/HISTORY#n7587 ff.) festlegen, dass zu schnell gesendete Tastenwiederholungen ignoriert werden sollen.


    Wenn das auch mit KODI ein Problem ist, kann man sich mit einem Repeat-Filter behelfen:

    Code: /etc/systemd/system/repeat-filter.socket
    1. [Socket]
    2. ListenStream=/run/lirc/lircd_filter
    3. [Install]
    4. WantedBy=sockets.target
    5. Also=repeat-filter.service
    Code: /var/lib/vdr/config/systemd/user/kodi.service.d/lircd.conf
    1. [Service]
    2. Environment=LIRC_SOCKET_PATH=/run/lirc/lircd_filter

    Und dann noch mit systemctl enable repeat-filter.socket anschalten. Dann sollte der Dienst automatisch starten, wenn jemand auf /run/lirc/lircd_filter zugreift.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • das Ubuntu Kodi ist wieder aktueller als das aus deinem PPA.

    Das sollte jetzt für bionic und focal behoben sein.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke für die Tipps. Werde ich später mal ausprobieren.

    Registrieter VDR User Nr. 1237


  • Moin,


    habe Gestern "auf die Schnelle" nochmal ein Focal System aufgesetzt und yavdr ansible Playbook laufen lassen.

    Ubuntu 20.04 (focal-live-server-amd64.iso) als daily build vom USB Stick gestartet und installiert.

    Hardware: Intel NUC7i3BNH, System bootet von USB Datenträger (SanDisk Extreme Pro UHS-II). 2x SSDs intern für Video.

    Trennung von System (USB Wechselmedium) und Video (HD intern) ist super - kann ich nur empfehlen.


    Als Frontend verwende ich diesmal softhdvaapi:


    Welches Anfangs nicht startete. Fehler im Log:

    Habe die Monitorerkennung nochmal durchlaufen, in /etc/X11/xorg.conf.d/20-intel.conf fehlte einfach nur: Option "DRI" "3"

    Danach lief es. Keine Ahnung ob das an meinem exotischen? NEC 40" Monitor liegt. Eventl. hilft es ja Anderen.


    Freue mich nun über das System:-) Wenn Ende April Ubuntu 20.04 LTS released wird, wiederhole ich die Installation auf ein anderes USB Medium.

    Edit fstab - fertig :-)


    Munter bleiben, Rossi

  • Und fünf Minuten später kommt dann der nächste um die Ecke und sagt, dass er den Permashift-Patch haben will...

    :evil:

    Apropos und Off-Topic: Wie ist denn der derzeitige Stand bei Permashift? Gibt es eine Distribution, die den Patch hat und sind Patch und Plugin stabil?

    Registrieter VDR User Nr. 1237


  • Hallo,

    ich habe focal installiert, dann die

    yavdr-ubuntu-experimental-vdr-focal

    eingebunden.


    Läuft alles bis auf das softhddevice


    Ich nutze -v va-aapi auf einer recht neuen intel plattform.

    Starte das plugin mit -D und attache es dann später.


    Das klassische softhddevice startet und zeigt mir immerhin surrealistische bilder. (Habe aber kein LSD genommen).

    Ich bekomme im syslog: No hw driver or OpenGL Osd disabled - use soft OSD, sehe aber OSD.


    Nutze ich softhdvaapi (3.1.0)

    bekomme ich:

    OpenGl Thread not started successfully, using Dummy OSD

    Es öffnet sich nur ein schwarzes Fenster.


    glxgears läuft. Habe auch schon jede Menge Abhängigkeiten versucht zutesten.

    Hat einer einen Tip?





  • Was hast du denn für Hardware? Nutzt du Wayland oder eine Sitzung mit X-Server?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hast du das Paket i965-va-driver-shaders installiert?

    Wie startest du den X-Server?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • ich habe focal installiert, dann die

    yavdr-ubuntu-experimental-vdr-focal

    eingebunden.

    Dann fehlt dir vermutlich noch die neuere Version der libplacebo aus ppa:yavdr/experimental-main - das PPA sollte auch noch eingebunden werden, weil die Pakete in ppa:yavdr/experimental-vdr dagegen gebaut werden.


    Für softhdvaapi muss man IIRC noch DRI in Version 3 aktivieren, das sollte mit so einem Snippet für die Xorg-Konfiguration gehen:

    Code: /etc/X11/xorg.conf.d/20-intel.conf
    1. Section "Device"
    2. Driver "intel"
    3. Option "DRI" "3"
    4. EndSection

    Woher die Fehlfarben beim normalen softhddevice kommen, ist mir gerade nicht klar. Ich muss mal mein VAAPI-Testsystem für focal nach längerer Pause wieder auf den aktuellen Stand bringen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Danke für Eure Geduld.

    Ich habe jetzt das softhddevice laufen. Bin also erstmal happy.

    Ich hatte einen dummer Fehler in meiner xorg.conf: defaultdepth war auf 30 gesetzt.


    FYI:

    das softhdvaapi crasht immer noch, obwohl ich DRI auf 3 gesetzt hatte.

    Läuft das "normalerweise" bei einer focal/yavdr(experimental) Installation mit der Intel Graphik?


    wenn ich es mit -D starte kommt:

    [softhddev]detached - OpenGl Worker Thread not tried to start

    [softhddev]OpenGl Thread not started successfully, using Dummy OSD

    scheint ok zu sein, dann, wenn ich es mit ATTA aktiv gemacht habe kommt im syslog:

    OSD size changed to 3840x2160 @ 1

    und ich habe einen schwarzen Bildschirm


    Ich schalte dann per "live" das menu ein, sehe auch was im Browser aber nichts im Fenster.

    Wechsel ich dann den Kanal, chrasht softhdvaapi.


    Falls ich etwas ausprobieren soll/kann/darf: gerne.

  • Läuft das "normalerweise" bei einer focal/yavdr(experimental) Installation mit der Intel Graphik?

    Ich baue die Pakete ja hauptsächlich für yavdr-ansible, wo ein ansible-Playbook die Konfiguration des Systems übernimmt. Da gibt es kein GDM und GNOME, sondern eine schlanke Openbox-Session (ich weiß nicht, wie gut der Compositor mutter mit den softhddevice-Abkömmlingen harmoniert, zu Zeiten von Ubuntu 14.04 ging das mit nvidia-Karten nur mit hoher CPU-Last und Ruckeln). Mit einem vollwertigen Ubuntu-Desktop habe ich das lange nicht mehr probiert.


    Die Ergänzung von Option "DRI" "3" in der Device Section muss man bei yavdr-ansible in https://github.com/yavdr/yavdr…ates/20-intel.conf.j2#L10 bislang noch selber machen, aber auf meinem Haswell-System lief es auch noch nach dem heutigen Updates und erneutem Ausführen des Playbooks mit Ausgabe in Full-HD mit softhddevice und softhdvaapi.

    Falls ich etwas ausprobieren soll/kann/darf: gerne.

    Wenn du magst, kannst du gerne mal probieren, ob eine yavdr-ansible Installation mit dem Focal-Branch ausgehend von einer Ubuntu Server 20.04 Installation auf deinem System funktioniert bzw. es da ein Bild gibt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,

    Teste doch mal mit Full-HD statt 4K. Heisst @1 1Hz? Das ist eher unsupported würde ich sagen...

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Hallo,

    auf meinem NUC8i3BEH2 habe ich yavdr_ansible@focal installiert und auf IPTV umgestiegen. Ich schaue nur diese öffentlich rechtlichen Sender an:

    Ich bekomme ein Bild auf alle Kanäle und die Qualität geht so. Leider stoppt die Wiedergabe auf allen Kanälen außer ARTE nach gefühlt 30 Sekunden.

    Auf allen Kanälen habe ich diese Fehlermeldungen die das syslog fluten:

    Kennt jemand dieses Verhalten? Habe gegoogelt aber leider nichts brauchbares zum Thema gefunden...

    VDR1 Fujitsu D3400-B2 i5-7500 HD630, 8GB RAM, WinTV-quadHD (DVB-T), yaVDR ansible BIONIC, softhdvaapi, skindesigner

    VDR2 NUC8i3BEH2, 16GB RAM, WinTV-dualHD (DVB-T/DVB-C), yaVDR ansible FOCAL, softhdvaapi, skindesigner

  • Ich hab eben mal versucht, auf ein aktuelles Focal-Server-Image die yavdr-ansible Installation zu starten - leider ist er nicht weit gekommen:


    Wo liegt mein Fehler?


    VG...

  • Merkwürdig, ich habe das Playbook gerade erfolgreich durchlaufen lassen - hast du an der group_vars/all bzw. host_vars/localhost eigene Anpassungen vorgenommen? Denn die gid ist in der Version auf Github eindeutig drin: https://github.com/yavdr/yavdr…/focal/group_vars/all#L13 und wird in https://github.com/yavdr/yavdr…/configure_system.yml#L23 genutzt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Merkwürdig, ich habe das Playbook gerade erfolgreich durchlaufen lassen - hast du an der group_vars/all bzw. host_vars/localhost eigene Anpassungen vorgenommen? Denn die gid ist in der Version auf Github eindeutig drin: https://github.com/yavdr/yavdr…/focal/group_vars/all#L13 und wird in https://github.com/yavdr/yavdr…/configure_system.yml#L23 genutzt.

    Ok - Du hast völlig richtig vermutet. Ich hatte in der host_vars/localhost eine (!) Anpassung für den vdr-Block drin (override_vdr_charset) :-/. Ich hatte angenommen, er würde den Rest aus der group_vars/all nehmen...


    Hab jetzt den gesamten Block in der host_vars/localhost drin und das Script läuft noch... ;-)