[Gelöst] yavdr ansible - Wakeonlan funktioniert mal wieder nicht

  • Hallo,


    seit ich yavdr ansible installiert habe funktioniert Wakeonlan leider nicht mehr. Das funktionierte mit yavdr 0.6 noch einwandfrei auf derselben Hardware.

    Ich habe mir jetzt diverse Seiten im Netz zu dem Thema angesehen und auch einiges ausprobiert, aber nichts zu machen, das Ding startet nicht, was insofern doof ist, da ich noch einen zweiten vdr betreibe ohne Empfangsteil, der diesen starten soll, wenn man ihn benutzen möchte.


    Ob es ein Fehler in netplan ist oder der Fehler bei mir liegt konnte ich bisher nicht herausfinden, aber vielleicht hat ja hier noch jemand eine zündende Idee.


    Im BIOS ist WOL eingeschaltet, soviel vorweg.


    lspci ergibt das:


    Ausgabe von ifconfig:

    Code
    1. enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    2. inet 192.168.1.5 netmask 255.255.255.0 broadcast 192.168.1.255
    3. inet6 2003:e1:170e:8100:226:18ff:fe1b:87a1 prefixlen 64 scopeid 0x0<global>
    4. inet6 fe80::226:18ff:fe1b:87a1 prefixlen 64 scopeid 0x20<link>
    5. ether 00:26:18:1b:87:a1 txqueuelen 1000 (Ethernet)
    6. RX packets 21356 bytes 4475362 (4.4 MB)
    7. RX errors 0 dropped 6947 overruns 0 frame 0
    8. TX packets 5414 bytes 1162960 (1.1 MB)
    9. TX errors 0 dropped 0 overruns 0 carrier 1 collisions 0


    Ausgabe von ethtool enp2s0:


    Meine /etc/netplan/01-static-netcfg.yaml

    netplan apply habe ich natürlich ausgeführt



    Und cat /proc/acpi/wakeup


    Hier sieht man, daß P0P9 disabled ist, ich vermute GBEC ist die Ethernet Karte, die auch disabled ist.


    Wenn ich mittels

    Code
    1. echo -n P0P9 | sudo tee /proc/acpi/wakeup

    bzw.

    Code
    1. echo -n GEBC | sudo tee /proc/acpi/wakeup

    versuche die beiden zu enablen, so funktioniert das nur bei P0P9, GEBC lässt sich nicht enablen.

    Mal abgesehen davon, daß bei jedem Reboot P0P9 wieder disabled wird.


    Irgendwelche Ideen?


    massi

    Blog


    VDR1 (Server): Asus P5QL Pro, Intel Quad Core, NVIDIA GT 640 (Zotac), Digital Devices Cine V7, OrigenAE S21T, yavdr ansible an Röhre mit vga2scart

    VDR2 (Client): AsRock ION 330, yavdr 0.6 an Panasonic Beamer (HDMI)

    The post was edited 1 time, last by massi ().

  • Bei meinem ION-System musste ich bei den neueren Kerneln nachhelfen und habe das mit einer Systemd-Unit gelöst:

    Code: /etc/systemd/system/wol.service
    1. [Unit]
    2. Description=Enable WOL for P0P6 device
    3. After=network-online.target
    4. [Service]
    5. Type=oneshot
    6. ExecStart=/bin/dash -c "echo -n P0P6 > /proc/acpi/wakeup"
    7. [Install]
    8. WantedBy=multi-user.target

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke für Deine Antwort, jetzt ist zwar das P0P9 enabled, aber der Wakeup funktioniert leider immer noch nicht.

    Blog


    VDR1 (Server): Asus P5QL Pro, Intel Quad Core, NVIDIA GT 640 (Zotac), Digital Devices Cine V7, OrigenAE S21T, yavdr ansible an Röhre mit vga2scart

    VDR2 (Client): AsRock ION 330, yavdr 0.6 an Panasonic Beamer (HDMI)

  • Hilft es, wenn du zusätzlich mit ethtool das WOL anschaltest?

    Code
    1. [Unit]
    2. Description=Enable WOL for P0P9 device
    3. After=network-online.target
    4. [Service]
    5. Type=oneshot
    6. ExecStart=/bin/dash -c "echo -n P0P9 > /proc/acpi/wakeup"
    7. ExecStart=/sbin/ethtool -s enp2s0 wol g
    8. [Install]
    9. WantedBy=multi-user.target

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo,


    Quote


    Hilft es, wenn du zusätzlich mit ethtool das WOL anschaltest?

    Das war ja schon eingeschaltet, brachte aber auch nix.


    Ich habe es inzwischen aber lösen können, obwohl es etwas seltsam ist.


    Ich habe die Zeile

    Code
    1. ExecStart=/bin/dash -c "echo -n P0P9 > /proc/acpi/wakeup"

    durch diese Zeile ersetzt

    Code
    1. ExecStart=/bin/dash -c "echo -n GBEC > /proc/acpi/wakeup"

    Dann geht es, das Seltsame, cat /proc/acpi/wakeup zeigt aber immer noch den Status "disabled" für GBEC und für P0P9 an.

    Code
    1. P0P9 S4 *disabled pci:0000:00:1c.5
    2. GBEC S4 *disabled

    Aber egal, danke für den Tipp mit dem systemd, da wäre ich selber mal wieder nicht drauf gekommen.:-/


    Hauptsache es funktioniert jetzt.

    Blog


    VDR1 (Server): Asus P5QL Pro, Intel Quad Core, NVIDIA GT 640 (Zotac), Digital Devices Cine V7, OrigenAE S21T, yavdr ansible an Röhre mit vga2scart

    VDR2 (Client): AsRock ION 330, yavdr 0.6 an Panasonic Beamer (HDMI)

  • Hallo,

    sind den diese Strings immer gleich?

    P0P9 und GBEC?

    Wo kann man dies nachlesen?


    Wenn ich Zeit finde baue ich eine Ansible-Role (oder ist das schon in der Mache?)

    Grüße, Dieter :-)

  • Quote

    sind den diese Strings immer gleich?

    Das ist das Problem, da kocht jeder Hersteller sein eigenes Süppchen und das gilt es dann erstmal herauszufinden.

    Blog


    VDR1 (Server): Asus P5QL Pro, Intel Quad Core, NVIDIA GT 640 (Zotac), Digital Devices Cine V7, OrigenAE S21T, yavdr ansible an Röhre mit vga2scart

    VDR2 (Client): AsRock ION 330, yavdr 0.6 an Panasonic Beamer (HDMI)

  • Bei mir gibt es diese:

    Und vom Dell m4500:

    Heist das wir müssen einfach probieren?

    Grüße, Dieter :-)

  • Interessant:

    Code
    1. GLAN: Gigabit Ethernet

    Grüße, Dieter :-)

  • Hi,

    keiner der Werte in /proc/acpi/wakeup hat bisher geholfen.

    Nach manuellem boot stehen sie auf enabled (d.H. der wol.service funktioniert).


    Was ich bisher gefunden habe:

    acpi-wakeup-4-letters-code-meaning

    make-changes-to-proc-acpi-wakeup-permanent

    ubuntuusers


    Mit

    Code
    1. lspci -tv

    kann man die "Verdrahtung" anzeigen.

    Demnach müsste es dieser Eintrag sein:

    Code
    1. /proc/acpi/wakeup:
    2. RP03 S4 *enabled pci:0000:00:1c.2

    Reicht aber nicht. Bei S4 ist er auch enabled, aber was ist mit S5? Das ist vermutlich das Problem.

    (Die Hardware kann's, hat ja mit 12.04 jahrelang funktioniert)

    Grüße, Dieter :-)

  • Hallo,


    ich bekomme es auch nicht hin. Ich habe alle Tipps, die ich hier und an anderer Stelle gefundewn habe, probiert. Rechner fährt runter und bleibt aus.

    Mit yavdr 0.5.0a hat es funktioniert.


    Bei mir ist der Ethernet controller GIGE.

    cat /proc/acpi/wakeup sagt:

    Code
    1. Device S-state Status Sysfs node
    2. EC S3 *disabled platform:PNP0C09:00
    3. OHC1 S3 *enabled pci:0000:00:04.0
    4. EHC1 S3 *enabled pci:0000:00:04.1
    5. OHC2 S3 *enabled pci:0000:00:06.0
    6. EHC2 S3 *enabled pci:0000:00:06.1
    7. ARPT S5 *disabled pci:0000:03:00.0
    8. GIGE S5 *enabled pci:0000:04:00.0

    Ich bin ratlos, was ich noch machen kann.


    Danke für eure bisherigen Arbeiten und Hilfen, ohne die bei mir kein VDR laufen würde.


    Viele Grüße,

    Thomas

    Mac Mini | Sat-IP | Ubuntu 18.04 | yavdr-ansible
    Raspberry Pi 3+ | Sat-IP | raspbian | vdr 2.2.0

  • In /usr/share/vdr/shutdown-hooks/S90acpi-wakeup ist [ -z "$WAKEALARM" ] && export WAKEALARM="/sys/class/rtc/rtc0/wakealarm" definiert.

    Was sagt "cat /sys/class/rtc/rtc0/wakealarm"?

    Bei älteren Kernels und vermutlich auch noch yavdr-0.5 war der Pfad zu wakealarm mal etwas anders. Bitte kontrollieren.


    Oder geht es hier doch nur um WOL?

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.5 mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-455, --no-unified-memory), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.5-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.9.9-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Ist im BIOS auch alles richtig eingestellt?


    Ich musste bei meinem Asus Board noch unter Power -> APM Configuration


    Power On by PCI Devices

    und

    Power On By PCIe Devices


    auf enabled setzen damit es funktioniert.

    Blog


    VDR1 (Server): Asus P5QL Pro, Intel Quad Core, NVIDIA GT 640 (Zotac), Digital Devices Cine V7, OrigenAE S21T, yavdr ansible an Röhre mit vga2scart

    VDR2 (Client): AsRock ION 330, yavdr 0.6 an Panasonic Beamer (HDMI)

  • Ich bin ratlos, was ich noch machen kann.

    Was für ein Ethernet-Controller ist da verbaut (lspci -mmnnvvv)? Eventuell irgendwas, das den alx-Treiber nutzt?

    Was sagt ethtool zu dem Netzwerkadapter? Gibt es eine Fehlermeldung, wenn du versuchst WOL damit zu aktivieren?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Es geht nur um WOL. Einschalten für Aufnahmen funktioniert.


    BIOS mit einstellbaren Optionen gibt es beim Mac Mini nicht. Da irgendwelche Werte zu ändern ist etwas trickreich. Aber das sollte passen, denn wenn ich die alte HD mit yavdr 0.5.0a reinstecke, funktioniert es. Nur mit der neuen Platte und yavdr-ansible leider nicht.


    Der Ethernet-Controller ist ein Broadcom BCM57765.

    ethtool hat keine Probleme. Das gibt mir keine Fehlermeldung.

    Mac Mini | Sat-IP | Ubuntu 18.04 | yavdr-ansible
    Raspberry Pi 3+ | Sat-IP | raspbian | vdr 2.2.0

  • Der Ethernet-Controller ist ein Broadcom BCM57765.

    Sicher, dass du das nicht mit dem Kartenleser verwechselst (vgl. z.B. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=717325)?

    Code
    1. 04:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe [14e4:16b5] (rev 10)
    2. 04:00.1 SD Host controller [0805]: Broadcom Corporation NetXtreme BCM57765 Memory Card Reader [14e4:16bc] (rev 10)

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich hatte sowas ähnliche bei meinem Server unter focal auch. Der hatte beim runterfahren nicht die notwendigen Daten für einen WOL gespeichert.

    Ich habe mir dafür eine systemd-Unit geschrieben. Danach hat es geklappt.

    Probier es doch mal aus.

    Datei /etc/systemd/system/wol@.servicemit folgendem Inhalt anlegen:

    Dann noch ein systemctl enable wol@eno1 und danach funktionierte der WOL (eno1 ist dann mit deiner Netzwerkkartenbezeichnung zu ersetzen)


    Markus

  • seahawk1986 : nein, das verwechsle ich nicht.

    Code
    1. 04:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme BCM57765 Gigabit Ethernet PCIe

    Mac Mini | Sat-IP | Ubuntu 18.04 | yavdr-ansible
    Raspberry Pi 3+ | Sat-IP | raspbian | vdr 2.2.0

  • Hilft es eventuell das Treibermodul tg3 in die MODULES_WHITELIST in /etc/default/acpi-support aufzunehmen (vgl. https://askubuntu.com/a/1160570)?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • /etc/default/acpi-support gibt es bei mir nicht. Da gibt es nur /etc/default/acpid.

    Sollte ich /etc/default/acpi-support anlegen? Wie muss die aussehen?


    ofenheizer Das habe ich schon wie weiter oben beschrieben eingerichtet.

    Mac Mini | Sat-IP | Ubuntu 18.04 | yavdr-ansible
    Raspberry Pi 3+ | Sat-IP | raspbian | vdr 2.2.0