[gelöst] yaVDR Ansible - kein Wakeup bei Timeraufnahmen

  • Hallo verehrte und kundige Mitstreiter.


    Mein System fährt leider nicht mehr automatisch hoch wenn Timeraufnahmen anstehen. Leider kann ich noch nicht einmal einschränken, ob es seit der Neuinstallation von yavdr-ansible scheitert (ich hatte soviel uptime ;o)) oder erst danach.


    Wenn ich zu Testzwecken den Rechner per sudo rtcwake -m no -s 60 && sudo poweroff wieder aufwecke, funktioniert das auch.


    In /etc/vdr/vdr-addon-acpiwakeup.conf steht ACPI_ENABLED=no, so dass ich davon ausgehe, dass standardmäßig der wakeup per rtc-wakeup aktiviert wird.


    cat /proc/driver/rtc gibt:


    Wo liegt denn wohl das Problem?

    Mein VDR: yaVDR Ansible, Ubuntu 18.04.3 LTS auf ASROCK QM1900M, 2 x Mushkin DIMM 1 GB DDR3-1333, 1024MB ZOTAC GeForce GT 630 Zone Edition Passiv, 40GB Intel 320 Series 2.5" SATA 3Gb/ MLC asynchro, L4M-Twin S2 ver 6.5, 300 Watt be quiet! Pure Power L8 Non-Modular in: Silverstone ML03B Desktop

  • In /etc/vdr/vdr-addon-acpiwakeup.conf steht ACPI_ENABLED=no, so dass ich davon ausgehe, dass standardmäßig der wakeup per rtc-wakeup aktiviert wird.

    Das sollte auf "yes" stehen, rtc-wakeup wird von yavdr-ansible nicht genutzt, das geht direkt über den vom Kernel angelegten Geräteknoten für die RTC (/sys/class/rtc/rtc0/wakealarm).


    Der einzige Fall in dem das Playbook den Wert no setzt, ist wenn man in der Variablen wakeup_method ( https://github.com/yavdr/yavdr…bionic/group_vars/all#L96 ) eine andere Wakeup-Methode als acpiwakeup einstellt - vgl. https://github.com/yavdr/yavdr…-addon-acpiwakeup.conf.j2

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke für die schnelle Antwort. Aber auch nach ACPI_ENABLED=yes ändert sich leider nichts. (Wert geändert, reboot, Timer programmiert, ausgeschaltet, nichts passiert).

    In group_vars/all hatte ich bei der Installation nichts verändert: wakeup_method: acpiwakeup (und natürlich keine localhost variablen angelegt).


    Ist das soweit okay?

    Code
    1. Sep 10 21:36:33 yavdr vdr-addon-acpiwakeup: Writing 0 to /sys/class/rtc/rtc0/wakealarm
    2. Sep 10 21:36:33 yavdr vdr-addon-acpiwakeup: Writing 1568145693 to /sys/class/rtc/rtc0/wakealarm
    3. Sep 10 21:44:43 yavdr kernel: [ 1.759415] rtc_cmos 00:00: RTC can wake from S4
    4. Sep 10 21:44:43 yavdr kernel: [ 1.759571] rtc_cmos 00:00: rtc core: registered rtc_cmos as rtc0
    5. Sep 10 21:44:43 yavdr kernel: [ 1.759606] rtc_cmos 00:00: alarms up to one month, y3k, 242 bytes nvram
    6. Sep 10 21:44:43 yavdr kernel: [ 1.802178] rtc_cmos 00:00: setting system clock to 2019-09-10 19:44:35 UTC (1568144675)

    Mein VDR: yaVDR Ansible, Ubuntu 18.04.3 LTS auf ASROCK QM1900M, 2 x Mushkin DIMM 1 GB DDR3-1333, 1024MB ZOTAC GeForce GT 630 Zone Edition Passiv, 40GB Intel 320 Series 2.5" SATA 3Gb/ MLC asynchro, L4M-Twin S2 ver 6.5, 300 Watt be quiet! Pure Power L8 Non-Modular in: Silverstone ML03B Desktop

    The post was edited 1 time, last by Jinx138 ().

  • Was steht denn beim Shutdown mit gesetztem Timer im Log? War der Timer weit genug in der Zukunft (größer als die Brückenzeit zwischen Timern - vgl. http://www.vdr-wiki.de/wiki/in…enutzerhandbuch#Sonstiges - wenn man den Shutdown erzwingt, setzt der VDR keine Aufweckzeitpunkt)?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Quote

    wenn man den Shutdown erzwingt, setzt der VDR keine Aufweckzeitpunkt

    Aha. Ich check das und meld mich wieder.

    Mein VDR: yaVDR Ansible, Ubuntu 18.04.3 LTS auf ASROCK QM1900M, 2 x Mushkin DIMM 1 GB DDR3-1333, 1024MB ZOTAC GeForce GT 630 Zone Edition Passiv, 40GB Intel 320 Series 2.5" SATA 3Gb/ MLC asynchro, L4M-Twin S2 ver 6.5, 300 Watt be quiet! Pure Power L8 Non-Modular in: Silverstone ML03B Desktop

  • Jup, das war es. Hatte beim Testen immer den shutdown erzwungen und wunderte mich, dass der Rechner nicht von alleine anging.

    Aber aus welchem Grund ACPI_ENABLED=no ist mir ein Rätsel. Ich hab mit Sicherheit nichts daran geändert... Wurst, nu geht's.

    Danke seahawk1986 !

    Mein VDR: yaVDR Ansible, Ubuntu 18.04.3 LTS auf ASROCK QM1900M, 2 x Mushkin DIMM 1 GB DDR3-1333, 1024MB ZOTAC GeForce GT 630 Zone Edition Passiv, 40GB Intel 320 Series 2.5" SATA 3Gb/ MLC asynchro, L4M-Twin S2 ver 6.5, 300 Watt be quiet! Pure Power L8 Non-Modular in: Silverstone ML03B Desktop

  • Ich war über das "ACPI_ENABLED=no" auch gestolpert, bis mir aufgefallen ist, daß im "yavdr-ansible/roles/wakeup/tasks/main.yml" die Installation der Templates auskommentiert ist und somit die ursprüngliche Einstellung vom Ubuntu Server nicht aktualisiert wird.