• Hat hier jemand einen VDR auf einem aktuellen Fedora laufen? Ich habe "Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)" Karten und wollte wissen, ob die problemlos laufen?

    Ich will nämlich mein altes Gentoo-System auf Fedora updaten.

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Die Treiber/Module sind seit glaub ich Kernel 4.14 mit dabei, kein dkms dafür mehr notwendig. Wobei mir Rev.V3 nichts sagt, meine sind etwa (aus lspci -v) "Digital Devices GmbH Cine S2 V6 DVB adapter". Wenn Ihre tatsächlich noch ältere sind, könnten die noch die "ngene"-Treiber brauchen, da sieht es vermutlich schlecht aus.

    Ich will hier fast Werbung für yavdr-ansible machen, das läuft mittlerweile bei mir stabiler als die ältere 0.6 (war aber bereits ziemlich "verbastelt").

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915, softhddevice-vaa
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarDust2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible, HWE-Edge-Kernel 5.2.13-generic

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB)

  • Bei mir werden die Karten irgend wie nicht angezeigt. Ich habe die mit einem experimentellen Treiber (ddbridge) in Betrieb genommen, da die damals sehr neu waren (Januar 2010)

    Code
    1. 06:00.0 Multimedia controller: Digital Devices GmbH Octopus CI DVB Adapter
    2. Subsystem: Digital Devices GmbH Octopus CI
    3. Flags: bus master, fast devsel, latency 0, IRQ 73
    4. Memory at fbef0000 (64-bit, non-prefetchable) [size=64K]
    5. Capabilities: [50] Power Management version 3
    6. Capabilities: [70] MSI: Enable+ Count=1/2 Maskable- 64bit+
    7. Capabilities: [90] Express Endpoint, MSI 00
    8. Capabilities: [100] Vendor Specific Information: ID=0000 Rev=0 Len=00c <?>
    9. Kernel driver in use: DDBridge
    10. Kernel modules: ddbridge


    Ursprünglich wollte ich noch ein CI-Modul dran hängen, doch habe ich das dann nie gebraucht und gemacht.

    Das ist ja für den Server wichtig.


    Der Client, Atom-D525, sollte ja unter Fedora laufen und die VDR-Ausgabe über HDMI machen können.

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Das war nur das CI-Modul.

    Mein ddbridge-Adapter sieht aktuell (yavdr-ansible, Kernel 5.2.11) so aus:

    Code
    1. 03:00.0 Multimedia controller: Digital Devices GmbH Octopus DVB Adapter
    2. Subsystem: Digital Devices GmbH Cine S2 V6 DVB adapter
    3. Flags: bus master, fast devsel, latency 0, IRQ 16
    4. Memory at f7e00000 (64-bit, non-prefetchable) [size=64K]
    5. Capabilities: [50] Power Management version 3
    6. Capabilities: [70] MSI: Enable- Count=1/2 Maskable- 64bit+
    7. Capabilities: [90] Express Endpoint, MSI 00
    8. Capabilities: [100] Vendor Specific Information: ID=0000 Rev=0 Len=00c <?>
    9. Kernel driver in use: ddbridge
    10. Kernel modules: ddbridge

    und die Devices werden in der dmesg aufgelistet:

    Es handelt sich bei mir um eine DVB-S2 mit Flex-Modul für DVB-C/T

    Wie gesagt, seit Kernel 4.14 sind die Treiber integriert, kein dkms-media-build oder dkms-experimental-dings mehr nötig dafür.

    Da es leider nur mehr CAMs für CI- (eingeschränkt, wird "irrtümlich" CI+ genannt) gibt und Linux/VDR das nicht offiziell unterstützt, hab ich so eins auch nicht.

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915, softhddevice-vaa
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarDust2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible, HWE-Edge-Kernel 5.2.13-generic

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB)

  • Ich habe es aus Zeitgründen (und dem mich nicht überzeugenden Programm) nie zu einem CI-Mudul geschafft. Hier mein dmesg-Ausschnitt:

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Da fällt mir das Alter des ddbridge-Treibers auf: 2010-2011, bei mir (neuer Kernel) ist es 2010-2017.

    Und v.a., daß bei Ihnen zwar 2 CIs bzw. ein Dual-Slot-CI(?), aber keine Frontends auftauchen.

    Bei Ihnen fehlt wohl doch das Tuner/Frontend-Modul im Kernel, welche Version ist das?

    Wie schon gesagt, ab 4.14 oder vielleicht 4.19, also in aktuellen Fedora-Versionen jedenfalls, sollten die Treiber dabei sein.

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915, softhddevice-vaa
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarDust2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible, HWE-Edge-Kernel 5.2.13-generic

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB)

  • Frontends werden durch den VDR selbst gestellt ()vdr.log):


    Dadurch, das der Server jetzt ins 7. Jahr geht, will ich parallel einen neuen 2. installieren. Wenn jetzt alles im Kenel ist, freut mich das und ich nehme mir einen "alten" PC und brauche mir nur noch die DVB-S2 Karten-Erweiterung kaufen.



    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Noch eine andere Frage: Ich habe jetzt auf Fedora (Client) folgendes installiert:

    Code
    1. dnf install vdr-vnsiserver
    2. dnf install kodi

    Damit sollte es ja theoretisch funktionieren, dass ich an meinen alten VDR-Server gehe. Mein bisheriger VDR-Client (auch 7 Jahre) macht das ja. Nun das Problem, dass nach der Installation keine setup.conf angelegt ist. Ich bekomme den VDR (Client) nicht gestartet. GIbt es da bei Fedora etwas Besonderes?

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Wenn Sie mit kodi an den vdr wollen, brauchen Sie den vnsi-Client (kodi-addon-pvr-vdr-vnsi) für Kodi auf dem Client-System und nicht den vdr-vnsiserver.

    Auf dem alten VDR-Server sollte eine allowed-hosts.conf den Zugriff für die IP/das Subnetz des Clients erlauben.

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915, softhddevice-vaa
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarDust2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible, HWE-Edge-Kernel 5.2.13-generic

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB)

  • Ok, dann kann ich also von meinem Laptop aus den alten VDR-Server direkt kontaktieren. Dazu müsste ich jedoch den Server mit

    Code
    1. dnf install vdr-vnsiserver

    aktualisieren. Den fasse ich jedoch nicht an, da der ein Running-System mit einem 7 jahre alten Gentoo ist.


    Darum meine Vorgehensweise: Lokal auf dem Laptop einen VDR laufen lassen, der mit dem streamdev-client auf den Server geht und den dann lokalen VDR mit dem Kodi als Backend anzusteuern.


    Ist das falsch gedacht?

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Kodi als Frontend. Ja, wenn auf dem alten Gentoo ein streamdev-server läuft, sollte das auch gehen. Wichtig ist, auf dem VDR, der als Client läuft, den streamdev-Server NICHT installieren, nur den client. Aber dafür auf diesem den vdr-vnsiserver.

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915, softhddevice-vaa
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarDust2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible, HWE-Edge-Kernel 5.2.13-generic

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB)

  • Das funktioniert nicht:

    Mache ich dann ein Update mit "dnf update" kommt

    Code
    1. Problem: package vdr-vnsiserver-1.6.0-3.fc30.x86_64 requires vdr(abi)(x86-64) = 2.4.0, but none of the providers can be installed
    2. - cannot install both vdr-2.4.1-1.fc30.x86_64 and vdr-2.4.0-6.fc30.x86_64
    3. - cannot install both vdr-2.4.0-6.fc30.x86_64 and vdr-2.4.1-1.fc30.x86_64
    4. - cannot install the best update candidate for package vdr-vnsiserver-1.6.0-3.fc30.x86_64
    5. - cannot install the best update candidate for package vdr-2.4.0-6.fc30.x86_64


    Entweder also VDR oder vdr-vnsiserver. :-(





    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Irgendwie fehlt mir noch der Zusammenhang. Die Versionen scheinen sich in Fedora im Augenblick zu beißen. Vielleicht muss ich tiefer in die Adminstration von Fedora einsteigen

    Code
    1. Pakete mit nicht auflösbaren Abhängigkeiten werden übersprungen:
    2.  vdr-vnsiserver                            x86_64                      1.6.0-3.fc30                                       fedora                      189 k


    Wenn ich es richtig verstanden habe: Kodi -> vdr-vnsiserver -> vdr -> vdr-streamdev-client --> zum Server ?



    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Unabhängig von Kodi habe ich den VDR über das xine-Plugin zum laufen bekommen, aber der verbindet sich leider noch nicht mit dem Server. Ich bin noch am "rätseln" ob es am Netzwerk (eher weniger), an der Version oder Konfiguration liegt.

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Ich habe hier kein Fedora, aber kann sein daß der vdr-vnsiserver noch die 2.2er-Version ist?

    Wegen des streamdev-Servers am Fedora-Server wirst doch mal ran müssen und die streamdevhosts.conf kontrollieren, ob Dein Subnetz oder die IP des Clients gelistet ist?

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915, softhddevice-vaa
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarDust2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible, HWE-Edge-Kernel 5.2.13-generic

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB)

  • Das Subnetz ist drin. Aber die Versionen:

    Code
    1. Installieren:
    2. vdr-vnsiserver x86_64 1.6.0-3.fc30 fedora 189 k
    3. Herunterstufen:
    4. vdr x86_64 2.4.0-6.fc30 fedora 1.1 M
    5. vdr-streamdev-client x86_64 0.6.1-0.20.gitb84b7d85.fc30 fedora 76 k
    6. vdr-softhddevice x86_64 0.6.1-19.20151103git6dfa88a.fc30 rpmfusion-free 133 k
    7. vdr-xineliboutput x86_64 2.1.0-10.20181005gitb298178.fc30 rpmfusion-free 246 k
    8. vdr-xineliboutput-plugin x86_64 2.1.0-10.20181005gitb298178.fc30 rpmfusion-free 263 k

    Vielleicht liegt es aber auch an den VDR-Versionen, wenn ich nicht über Kodi gehe, sondern den VDR direkt mit xine-Output-Plugin starte. Der Server hat die VDR-Version 1.7.23 und der Client die 2.4.1.

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Bin heute ein wenig daneben. Also in der neuen fc30 ist noch der vnsiserver von vdr-1.6, aber der vdr ist schon 2.4.1?

    Wobei .... vnsiserver braucht es ja nur am alten Gentoo-Server, doch so ich weiß, sind die Clients von neueren Kodi-Versionen mit dem alten Server nicht zufrieden.

    Streamdev sollte aber "von vdr zu vdr" schon funktionieren, auch ohne vnsi. Und so ich glaube, gibt es da auch keine inkompatible Protokolländerung?

    Am Client-VDR auf Fedora würde ich jedenfalls nicht den alten vnsi-server installieren bzw. geht das wohl gar nicht wegen inkompatiblem ABI.

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915, softhddevice-vaa
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarDust2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible, HWE-Edge-Kernel 5.2.13-generic

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB)

  • Bin heute ein wenig daneben. Also in der neuen fc30 ist noch der vnsiserver von vdr-1.6, aber der vdr ist schon 2.4.1?

    Ja.


    AM alten VDR-Server 1-7-23 ist kein vnsi installiert, aber der streamdev-server (0.5.1).
    Auf fc30 habe ich nur das installiert:

    Code
    1. vdr (2.4.1/2.4.1) - The Video Disk Recorder
    2. softhddevice (0.6.1rc1) - A software and GPU emulated HD device
    3. streamdev-client (0.6.1-git) - VTP Streaming Client
    4. xineliboutput (2.1.0) - X11/xine-lib output plugin

    Meine Vermutung, da auch am Server kein Zugriff über den Port (in der vdr.log) erfolgt, dass der neue Client nicht mit dem alten Server klar kommt. Firewall gibts da nicht.



    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Wurde der Streamdev-Standardport nicht mal dazwischen geändert von 2001 auf 6419? Vielleicht am neuen Streamdev-Client den alten Port einstellen oder nmap auf den alten Server machen und herausfinden ...

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915, softhddevice-vaa
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarDust2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible, HWE-Edge-Kernel 5.2.13-generic

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB)

  • Hallo,


    Wurde der Streamdev-Standardport nicht mal dazwischen geändert von 2001 auf 6419

    ...nicht Streamdev-Port,dass ist der svdrp-port.

    Bis VDR 1.7.14 war der Standard-Port 2001, seit Version 1.7.15 ist es 6419

    Streamdev-Port ist default 3000

    Gruss

    Wolfgang