Syslog wird mit Meldungen "dvb_frontend: dvb_frontend_get_frequency_limits: frequency interval ..." überschwemmt

  • Hallo zusammen,


    seit heute taucht in meinem syslog/kernlog folgende Meldungen ca .alle 20 Sekunden auf:


    kernel: [ 3301.430594] dvb_frontend: dvb_frontend_get_frequency_limits: frequency interval: tuner: 42000000...870000000, frontend: 0...0 Aug 1 18:44:06 thbaserver


    Ich habe versucht, den loglevel von VDR herunterzusetzen (in /etc/vdr/conf.d/00-vdr.conf --log=1 für "nur Fehler"), das hat aber nichts gebacht. Vielleicht weil es gar keine VDR-Meldung, sondern eine Kernel-Meldung ist?


    Könnte die Ursache ein Kernel-Update sein, welches mein Ubuntu-System heute über die "Aktualisierungsverwaltung" installiert hat?


    Wie werde ich diese Meldungen wieder los?


    Danke.


  • Danke HelmutB,


    du hast Recht, die Meldungen tauchten erst nach einem Update auf den 5.0er-Kernel auf (wurde mir vorgeschlagen über die "Aktualisierungsverwaltung") .

    Mein System ist ein Ubunut 18.04.1

    vorher --> linux-image-4.18.0-25-generic

    nachher --> linux-image-5.0.0-23-generic


    Den Kernel selber patchen geht leider über meine Linux-Kenntnisse hinaus, daher sehe ich im Moment 2 Lösungswege:

    1. ich gehe zurück zum alten 4.18er Kernel (ich muss mich noch einlesen wie man sowas macht und verhindert, dass dann immer wieder ein Update erfolgt - ich glaube mit GRUB, siehe https://kilobyte.bplaced.net/u…date-rueckgaengig-machen/)

    2. gibt es einen Weg/Einstellung, daß Debug-Kernelmeldungen nicht mehr im Syslog/Kern.log auftauchen?


    Danke

    Thomas

  • dprintk ist in dvb_frontend.c als #define dprintk(fmt, arg...) \ printk(KERN_DEBUG pr_fmt("%s: " fmt), __func__, ##arg) definiert.

    Es gibt 8 Loglevels:

    #define KERN_EMERG "<0>" /* system is unusable*/

    #define KERN_ALERT "<1>" /* action must be taken immediately*/

    #define KERN_CRIT "<2>" /* critical conditions*/

    #define KERN_ERR "<3>" /* error conditions*/

    #define KERN_WARNING "<4>" /* warning conditions*/

    #define KERN_NOTICE "<5>" /* normal but significant condition*/

    #define KERN_INFO "<6>" /* informational*/

    #define KERN_DEBUG "<7>" /* debug-level messages*/


    Dein Konsole Loglevel siehst du mit: $ cat /proc/sys/kernel/printk (die erste von 4 Zahlen).

    Was steht bei dir in der Ausgabe?

    Zum Ändern: - z.B. nach einem $ echo "6" > /proc/sys/kernel/printk werden nur die Levels 0 bis 6 an der Konsole angezeigt. Die Level 7 Meldungen sieht man dann nur mit 'dmesg'.


    Man kann das loglevel schon beim booten als Kernel Parameter mitgeben: z.B loglevel=3.

    Für Ubuntu: https://wiki.ubuntuusers.de/Bootoptionen/


    Helmut

    Edit: so in etwa: GRUB_CMDLINE_LINUX="loglevel=3 ....."

  • thba1 ,


    diese Meldungen hatte ich auch eine Weile. Sie sind dann allerdings mit einem späteren Kernel-Update wieder verschwunden. Bei welchem kann ich aber nicht mehr sagen.


    Grüsse

    kamel5

    VDR 2.4.1: ASUS M5A97 PRO, FX6100, 16GB, 2TB HD, GT630, Fedora 30 Kernel 5.3 X86_64, Devicebonding 2 x 1 auf 2, TT6400, DVBSky S952 V3

  • kamel5

    Da habe ich auch so einen Rest Hoffnung, dass das in nachfolgenden Kernel-Versionen wieder verschwindet, ich weiß aber nicht ob und wann da bei Ubuntu was geändert werden wird, deshalb möchte ich es jetzt gerne abstellen


    HelmutB

    Danke für die Info.

    cat /proc/sys/kernel/printk liefert bei mir

    4 4 1 7, also sollten die Meldungen schon nicht mehr auftreten.

    Selbst mit echo "2" > /proc/sys/kernel/printkkommen die Meldungen aber immer noch.

    Falls ich es nicht gut beschrieben habe: Ich sehe die Meldung(en) etwa alle 20 Sekunden im "kern.log" und "syslog" in der GUI "Systemprotokollbetrachter" als neu hinzugekommene Zeile. Und dort stören sie mich, da man dann andere (wichtige) Meldungen leicht übersieht.


    Ich habe auch in der GRUB Konfig den loglevel verändert, leider aber ohne Erfolg.

    cat /proc/cmdlineliefert bei mir BOOT_IMAGE=/boot/vmlinuz-5.0.0-23-generic root=UUID=d32897df-abe5-4cc6-975d-cfe251f50c83 ro libata.force=noncq loglevel=3 quiet splash loglevel=3 vt.handoff=1

    (loglevel steht wohl zweimal drin da ich in /etc/default/grub den loglevel sowohl in die Zeile GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3" als auch in die Zeile GRUB_CMDLINE_LINUX="libata.force=noncq loglevel=3"eingetragen habe)


    Sehe ich das falsch, oder betrifft loglevel in der GRUB Konfig nur den Bootvorgang und nicht den laufenden Betrieb?

  • Danke Helmut,


    in meiner /etc/sysctl.d/10-console-messages.confsteht
    # the following stops low-level messages on consolekernel.printk = 4 4 1 7


    und in /etc/sysctl.d/99-sysctl.confsteht

    # Uncomment the following to stop low-level messages on console #kernel.printk = 3 4 1 3


    Habe auch schon mal ausprobiert das in /etc/sysctl.d/99-sysctl.conf auszukommentieren, aber wieder ohne Erfolg.


    Für mein Verständnis: eine Änderung von kernel.printk hier oder wie oben duch echo "3" > /proc/sys/kernel/printkmüsste sich schon auch auf die zyklischen Meldungen im GUI "Systemprotokollbetrachter" auswirken, oder ?

    Ich frage deshalb dumm, weil in Zusammenhang mit printk und grub immer von "Console" die Rede ist. Nicht daß sich das nur bei einem System ohne grafischen Desktop auswirkt, aber in den log-Files (welche der "Systemprotokollbetrachter" anzeigt) die Meldungen nach wie vor munter reingeschrieben werden.

  • Hi,

    Bei Ubuntu kannst du einfach einen allgemeinen Ubuntu Kernel installieren. I. d. R. klappt das.

    Da gibt es die neuesten...

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Ich habe es jetzt erst registriert - du verwendest den grafischen "Systemprotokollbetrachter" und siehst syslog / kernlog.

    Wenn es stimmt, dann verwendet Ubuntu schon seit längerem nicht mehr "/var/log/messages" sondern eben syslog. Da werden aber alle möglichen Infos angezeigt, auch Kernelmeldungen. Vermutlich siehst du auch Meldungen, bei der die printk Konfiguartion nicht berücksichtigt wird - so wie in dmesg.

    Hier eine Erklärung und mit weiterem Link wie man /var/log/messages bei Ubuntu wieder aktiviert,

    https://unix.stackexchange.com…where-is-var-log-messages


    (ich habe tail -F /var/log/messages immer in einem Terminalfenster laufen)

    Helmut

  • was heist das genau mit dem dev_dbg - wie bekommt man hierrüber die Meldungen weg?


    Am besten auch in der sysctl.conf bzw dessen .d Verzeichnis... oder schon über Kernel Parameter bei Grub...?


    EDIT: ich denke es sollte so irgendwie gehen...


    Ich habe den folgenden Kernel Parameter angehängt... Um den Modulnamen und die Funktion zu finden habe ich folgenden Befehlt verwendet:


    sudo cat /sys/kernel/debug/dynamic_debug/control


    Der Name meines Moduls ist ts20201 und die Funktion ist ts2020_set_params. Daraus habe ich dann folgendes gebaut:


    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1 ts20201.dyndbg='func ts2020_set_params -p'"


    Das -p schaltet das pr_debug() Flag ab und es sollten keine Meldungen mehr kommen.


    Aber leider funktioniert es noch nicht so :(


  • Also ich denke meine Annahme mit dem Modul ts20201war falsch... das war nur das erste was ich beim nach oben scrollen mit dvb-frontends gesehen habe.


    aber selbst ein echo "module dvb_frontend -p" | sudo tee /sys/kernel/debug/dynamic_debug/control bringt das Teil nicht zum schweigen...


    EDIT: mist ich habe erst 5.0 - also nicht 5.1.12 :dösen


    Erklärt wieso ich das auch nicht in /sys/kernel/debug/dynamic_debug/control finde....


    Nur warum werden die Meldungen noch in dmesg geloggt?


    Code
    1. thomas@vdr:~$ cat /proc/sys/kernel/printk
    2. 3 3 1 7


    EDIT2:

    Ok, wird ja oben schon genannt: Syslog wird mit Meldungen "dvb_frontend: dvb_frontend_get_frequency_limits: frequency interval ..." überschwemmt


    Also kann man das nicht wirklich einzeln abschalten?

  • Ich habe mir wie folgt Abhilfe geschaffen:


    1. Meldungen für rsyslogd blocken (damit die Logdateien nicht zu groß werden):

    Code
    1. cat /etc/rsyslog.d/10-ignore.conf
    2. :msg, contains, "dvb_frontend_get_frequency_limits" stop

    2. Und damit mir dmesg nicht zuviel ausgibt, folgenden alias:

    Code
    1. alias dmesg='dmesg -l emerg,alert,crit,err,warn,notice,info'

    Siehe auch hier.


    Sollte reichen, bis es in einem späteren Kernel gefixt ist.


    Änderungen bei /proc/sys/kernel/printk brachten bei mir keinen Erfolg.

    My VDRs: