Solution for Satip and Unicable LNBs

  • Hi,

    The existing Unicable LNBs need more time to startup than regular quad LNBs.

    (Inverto has two models. I use the Durline UK124).


    If these LNBs are not supplied from another source (== already booted), the plugin does not wait long enough for the LNB to boot up. So the stream is stopped and the power is removed.

    With VLC I see the same behavior.

    Is there a way to increase the timeout? or is this timeout controlled by the DD Octopus? (DD support said no).


    Edit: See posting #6 for a solution.

    Grüße, Dieter :-)

    The post was edited 1 time, last by Dieter ().

  • Just found this:

    Code
    1. class cSatipDevice
    2. ....
    3. enum
    4. ....
    5. eTuningTimeoutMs = 1000 // in milliseconds

    So it is hardcoded, but still not to complicated to change. I will try to increase for a test.

    Grüße, Dieter :-)

  • There is a second definition with same name. That should be long enough (20secs).

    Code
    1. class cSatipTuner
    2. ....
    3. eTuningTimeoutMs = 20000, // in milliseconds

    Seems that it a bit more complicated as I first tougth. :-)

    I think the constant with the 1 sec is used to tune.

    Grüße, Dieter :-)

  • I am not sure if this helps also for satip & unicable, but try searching for "systemctl enable wait-for-dvb@0.service" over all forums.

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Hi,

    The Octopus turns on the LNB supply after it gets a stream request. For that the VDR must run first.


    Well, I could hack some simple code that opens a stream before starting VDR. Not to nice though.

    Grüße, Dieter :-)

  • Hi,

    I changed this value from 1000 to 5000 and it seams to work just fine now without an external power supply for the LNB (mine is Dura-Line UK124).

    At start of VDR it takes a few seconds until the LNB booted.

    Code
    1. class cSatipDevice
    2. ....
    3. enum
    4. ....
    5. eTuningTimeoutMs = 5000 // in milliseconds

    rofafor : Do you think this is ok, or is there some hidden problem?

    Grüße, Dieter :-)