[gelöst] Ansible - schwarze Balken rechts und links ...

  • Ich bin im Moment wieder auf yaVDR 0.6 und kann die Ausgabe von xrandr -d :1 nachliefern:

    Auffälliger Unterschied: DVI-I-0 ist "primary" - jetzt (unter ansible) ist HDMI-0 primary



    Da ich die Einstellungen eigentlich vom alten yaVDR übernommen habe, müssten die Werte bei ansible gleich sein:

    Code
    1. softhddevice.AutoCrop.Delay = 5
    2. softhddevice.AutoCrop.Interval = 25
    3. softhddevice.AutoCrop.Tolerance = 5

    Trotz dieser Einstellungen habe ich jetzt gerade (yaVDR 0.6) Vollbild ohne Balken!


    Ich werde sobald wie möglich zu Ansible wechseln und das AutoCrop deaktivieren und schauen, was die Balken dann machen ...

    Unter ansible ist AutoCrop ausgeschaltet (alle Werte auf 0) und die Balken links und rechts sind trotzdem da :-(


    Kann es viell. am nvidia-Treiber liegen?

    Dzt ist nvidia-driver-390 installiert; ich glaube unter yaVDR 0.6 wars Version 384.

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

    The post was edited 2 times, last by davie2000 ().

  • DVI und HDMI ... hmm, und welcher Eingang ist jetzt am TV aktiv? Mußten Sie beim ansible den Eingang umschalten, um was zu sehen?

    Bei HDMI gibt es das lästige Overscan, d.h. es wird ein wenig "gezoomt". Irgendein Treiber kann davon ausgehend bei HDMI "underscan" machen ... aber dann wäre das OSD wohl auch etwas abgeschnitten ...

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915, softhddevice-vaa
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarDust2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible, HWE-Edge-Kernel 5.2.13-generic

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB)

  • "connected" ist jeweils auf beiden yaVDRs der HDMI-Ausgang.

    Ich bin der "du" ;-) und musste glaub ich nach der Installation NICHT umstellen.

    Komisch ist ja eben, dass das OSD einwandfrei im Vollbild dargestellt wird.

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Wie sehen denn die Einstellungen für das Video-Anzeigeformat in den DVB-Einstellungen des VDR aus (http://www.vdr-wiki.de/wiki/index.php/Benutzerhandbuch#DVB)?


    Ist in softhddevice das automatische Cropping aktiviert? Man kann das über svdrp mittels svdrpsend plug softhddevice hotk 25 an- und abschalten (es gibt jeweils eine OSD-Message, was gerade aktiv ist).


    Laut Wiki-Seite zu softhddevice gibt es eine Reihe von Hotkeys, um die Darstellung zu beeinflussen:

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Die DVB-Einstellungen in der setup.conf sehen so aus:

    Primäres DVD-Interface: 3

    Standardkonformität: DVB

    Videoformat: 16:9

    Dolby-Digital-Ton benutzen: ja

    ...


    Ich habe die Hotkeys von oben beginnend ausgeführt und manchmal zwar eine Meldung am OSD gesehen (zB "autocrop enabled") aber das Bild hat sich nicht verändert.

    Bei svdrpsend plug softhddevice hotk 40 ist das Bild dann plötzlich "gesprungen" und die Ränder sind weg -> Vollbild! :love:


    Aber dann ist das OSD-Menü (skindesigner) nicht mehr sichtbar :wand kein einziges Menüelement wird mehr angezeigt.

    links sollte das Menü stehen (Programm, Kanäle, Timer, ...) und unten die Recordings und Temperaturen.


    Nach einem Reboot ist zwar das OSD wieder sichtbar, aber auch die schwarze Balken sind wieder da. ;(


    Werde jetzt mal schauen, ob ich den Parameter "stretch other aspect ratios to display" irgendwie in den regulären Plugin-Einstellungen am OSD dauerhaft einstellen kann.


    Update:

    Unter System - Einstellungen - Plugins - softhddevice - Video kann ich für die Option "16:9 and other ..." auf den Wert "pan&scan" (vorher: pillarbox) umstellen und dann sind die Balken zwar weg, aber auch das OSD :(

    Mal schauen, ob die Umstellung einen Reboot überlebt und das OSD dann wieder sichtbar ist ...

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

    The post was edited 1 time, last by davie2000 ().

  • Videoformat: 16:9

    Auch wenn es widersinnig erscheint, würde ich da mal versuchen 4:3 einstellen - in https://projects.vdr-developer…-43-Sendungen-%C3%A4ndern steht da noch ein bisschen dazu.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich bin mir ziemlich sicher, dass die Umstellung auf 4:3 eines der ersten Dinge war, die ich ausprobiert habe; das aber nichts gebracht hat.

    Ich werde mich noch ein bißchen damit herumspielen, aber für mich scheint "pan&scan" hier die Lösung zu sein.

    Komisch zwar, dass das unter yaVDR 0.6 nicht nötig war, um Vollbild zu haben, aber egal.


    Für die Sache, dass das OSD verschwindet, wenn man im in den softhddevice-Einstellungen etwas ändert mache ich einen neuen Thread auf.


    Vielen Dank für eure tolle Unterstützung!

    Ich bin zwar froh, dass es nur so eine "Kleinigkeit" war, aber etwas enttäuscht, dass ich das nicht selbst herausgefunden habe.

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Hi,

    Warum testest du nicht mal ohne Skindesigner...

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Verhält sich leider auch bei zB LCars gleich.

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD