[gelöst] Ansible - schwarze Balken rechts und links ...

  • Dank eurer tollen Unterstützung nutzen wir mittlerweile auch yaVDR ansible mit VDR 2.4 *freu*


    Alle Einstellungen wurden vom alten yaVDR übernommen bzw. abgeglichen: alle Einstellungen, die man im OSD vornehmen kann (VDR, Plugins) sind exakt gleich.

    Die setup.conf Dateien stimmen überein.


    Trotzdem haben wir unter Bionic links und rechts ca. 6 mm breite schwarze Streifen beim Fernsehbild.

    Das Skindesigner OSD nutzt den Fernsehschirm komplett aus und zeigt keine schwarzen Streifen links und rechts.

    Dabei ist es egal ob 1080i, 720p oder 576 Material geschaut wird.

    Es handelt sich um den PC aus der Signatur.



    Hat jemand von euch eine Idee, woran das nun wieder liegen könnte?

    Bzw. wie man den Fehler beheben kann?



    Update - LÖSUNG:

    Im OSD-Menü unter System - Einstellungen - Plugins - softhddevice - Video die Option 16:9+other video display format auf "pan&scan" stellen.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 1 time, last by davie2000 ().

  • Trotzdem haben wir unter Bionic links und rechts ca. 6 mm breite schwarze Streifen beim Fernsehbild.


    Das Skindesigner OSD nutzt den Fernsehschirm komplett aus und zeigt keine schwarzen Streifen links und rechts.

    Ist das bei allen Sendern der Fall? Wie sah die alte /etc/X11/xorg.conf.yavdr aus?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ja, ist bei allen Sendern der Fall.

    Die Datei liefere ich nach, sobald ich auf den alten VDR umswitchen kann.

    Hier der Inhalt der Datei:

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 2 times, last by davie2000 ().

  • Welches Ausgabeplugin hast du? Ist das noch das vorinstallierte vdr-plugin-softhddevice-vpp oder hast du das schon durch das Paket vdr-plugin-softhddevice-openglosd-ffmpeg-2.8 ersetzt?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich dachte ich hätte - wie schon unter yaVDR 0.6 - softhddevice-openglosd installiert.

    "apt-cache policy" bestätigt das und zwar in der Version: "Installiert: 1:0.6.1rc1-26-569fde5-3yavdr10~bionic"


    Soll ich mal "openglosd-ffmpeg-2.8" probieren?

    Einfach drüberinstallieren (sudo apt install ...) oder vorher das alte entfernen (purge)?


    Update:

    Was mir gerade noch im syslog aufgefallen ist:
    Die üblichen Buffermeldungen (a la "10:15:22.555 +51 768 0/\ms 15+7+4 v-buf") kamen bisher (yaVDR 0.6) immer genau alle 60 Sekunden.

    Unter Bionic kommen sie entweder alle paar Sekunden bzw. öfter pro Sekunde (unter Streß???) oder alle 50 Sekunden! 60 Hz-Modus ist eigentlich nicht aktiviert.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 1 time, last by davie2000 ().

  • In den Einstellungen von softhddevice kann man die Ränder des Videobildes beschneiden lassen. Mit DVB-T2 (was ich hier am Testsystem habe) sind die schwarzen Ränder abhängig vom Sender (und Material) - Filme (wie z.B. gerade Junior auf ZDF HD Neo) haben das öfter als direkt fürs TV produziertes HD Material.

    Was mir gerade noch im syslog aufgefallen ist:
    Die üblichen Buffermeldungen (a la "10:15:22.555 +51 768 0/\ms 15+7+4 v-buf") kamen bisher (yaVDR 0.6) immer genau alle 60 Sekunden.


    Unter Bionic kommen sie entweder alle paar Sekunden bzw. öfter pro Sekunde (unter Streß???) oder alle 50 Sekunden! 60 Hz-Modus ist eigentlich nicht aktiviert.

    Was sagt denn xrandr -d :0 auf dem System?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Die Einstellungen von Softhddevice sind gleich wie am alten yaVDR 0.6 und mit dem gibts bei der gleichen Sendung auch keine Streifen/Balken.


    Hier der Output von xrandr:

    Noch zur Info:

    Unser LG-TV ist nur hd-ready, hat bisher aber problemlos 1920 x 1080 mit 50Hz angezeigt. Das hatte ich unter 0.6 übers Webfrontend eingestellt.


    Jetzt wird ja wohl offenbar 1360 x 768 @ 60 Hz verwendet. Wie kann ich denn 1920x1080@50 erzwingen?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 2 times, last by davie2000 ().

  • War der TV bei der Ausführung der install-yavdr07.sh angeschlossen? Die Bildschirmerkennung sollte bei der Auswahl eigentlich einen anderen Mode wählen (können) als 1360x768 mit 60 Hz - kannst du bitte mal die Dateien anhängen, die im Verzeichnis /etc/ansible/facts.d/ liegen?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ja, angeschlossen war der TV bei der Installation ganz sicher; eingeschaltet glaube ich auch.

    Die Dateien aus /etc/ansible/facts.d/ findest du im Anhang - um Dateiendung 'txt' erweitert, um sie hochladen zu können.

    xorg.fact.txt

    xrandr.fact.txt

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Merkwürdig, laut der xorg.fact hat er sich 1920x1080@50 Hz ausgesucht - wie sieht die erstellte /etc/X11/xorg.conf aus?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Die sieht so aus:

    Jetzt check ich gar nichts mehr: lt. den beiden Dateien sollte ich eigentlich 1920x1080@50 haben, oder???


    Auf das damals verwendete Template "xorg.conf.j2" kann ich gerade nicht zugreifen (liegt auf Partition des alten yaVDR).

    Ich bin mir aber sicher, dass ich das nicht editiert habe.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Jetzt check ich gar nichts mehr: lt. den beiden Dateien sollte ich eigentlich 1920x1080@50 haben, oder???

    Da scheint der Name für den Anschluss nicht zu stimmen - du könntest mal versuchen alle Vorkommen von HDMI-1 durch HDMI-0 in der /etc/X11/xorg.conf zu ersetzen oder alternativ das Playbook für die Display-Konfiguration noch mal laufen lassen, während du dich im yavdr-ansible Verzeichnis befindest:

    sudo -H ansible-playbook yavdr07.yml -b -i 'localhost_inventory' --connection=local --tags="yavdr-xorg"

    Danach den Rechner einmal neu starten.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich habe mich für das Playbook entschieden und es hat geklappt *freu*

    Vielen Dank!!! :thumbup:



    Eins noch:

    Ich wolle vorab mein lokales repository aktualisieren wie in deiner README.md angegeben.
    Clone geht natürlich nicht mehr ("Verzeichnis nicht leer") und checkout sagte, dass alles bereits aktuell sei ("gleich wie bionic/master").

    Trotzdem fehlt bei mir lokal zB das Verzeichnis "vdr-plugin-menuorg" unterhalb von "roles".

    Muss ich tatsächlich meine lokale Kopie komplett löschen und dann mit clone den aktuellsten Stand holen?



    Update:

    lt. xandr wurde jetzt zwar 1920x1080@50 gewählt, aber die schwarzen Balken sind immer noch da ;(

    Code
    1. Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
    2. DVI-I-0 disconnected (normal left inverted right x axis y axis)
    3. VGA-0 disconnected (normal left inverted right x axis y axis)
    4. DVI-I-1 disconnected (normal left inverted right x axis y axis)
    5. HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 700mm x 390mm
    6. 1360x768 59.80 + 59.96 59.80
    7. 1920x1080 60.00 59.94 59.93 50.00* 29.97 25.00 23.98 60.00 50.04
    8. 1680x1050 59.95 59.88
    9. 1600x900 59.95 59.82
    10. ...


    Und hier noch die Infos vom yaVDR 0.6:


    Code
    1. xrandr -d :0
    2. Can't open display :0

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 7 times, last by davie2000 ().

  • Und hier noch die Infos vom yaVDR 0.6:

    Bei yaVDR 0.6 läuft der X-Server auf DISPLAY=:1, dementsprechend muss der Befehl xrandr -d :1 lauten.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke, mini73 für den Tipp mit "git pull".

    Jetzt habe ich versuchsweise einfach mal die README.md gelöscht (bei mir lokal) und dann ein "git pull" gemacht: "Bereits aktuell."

    Gleiches Ergebnis bei git pull https://github.com/yavdr/yavdr-ansible.

    Ich hätte jetzt eigentlich erwartet, dass die Datei wieder neu vom GIT geladen wird????



    seahawk1986 : das mit xrandr -d :1 hatte ich schon ausprobiert, aber da kam keine Antwort.

    Vielleicht war ich aber auch zu ungeduldig - werde ich bei Gelegenheit nochmal versuchen.



    Die "Buffer-Zeilen" kommen jetzt wieder jede volle Minute im syslog; die 50Hz scheinen also wirklich zu ziehen.


    Edit:

    Habe jetzt nochmal das ansible Installskript komplett durchlaufen lassen und sogar auf vdr-plugin-softhddevice-openglosd-ffmpeg2.8 gewechselt - die schwarzen vertikalen Streifen bleiben😭


    Edit2:

    Nur das Fernsehbild wird „beschnitten“ - das OSD ist im Vollbild ohne Ränder?????


    Hat noch irgendjemand eine Idee, wie ich diese "=$&Q$%&-Balken los werden kann?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 5 times, last by davie2000 ().

  • Ich hätte jetzt eigentlich erwartet, dass die Datei wieder neu vom GIT geladen wird????

    Wenn du die Datei löschst, hast du eine lokale Änderung in deinem Clon des Git-Repo, die Git erst mal ignoriert, bis du sagt, wie es sie handhaben soll. Die Datei kannst du mit git checkout README.md wieder auf den Stand des HEAD zurücksetzen.


    Vielleicht schaust du dir mal zum Einstieg https://rogerdudler.github.io/git-guide/index.de.html an, da werden die Grundlagen zum Umgang mit Git recht gut vermittelt.


    Nehmen wir mal an, ich wollte für eine Installation eine Datei verändern, die bereits von Git verwaltet wird, dann würde ich das so machen:

    Code
    1. # neuen Branch "ION" erzeugen und in den Branch wechseln
    2. git checkout -b ION
    3. # jetzt die Änderung machen
    4. vim roles/yavdr-desktop/templates/.lircrc.j2
    5. # Datei stagen und Änderungen committen
    6. git add roles/yavdr-desktop/templates/.lircrc.j2
    7. git commit -m "use KEY_PROG2 for KODI"

    Später kann man dann im Branch bionic wieder ein git pull machen und im Branch ION ein git merge bionic, um die Änderungen zusammenzuführen (dabei muss man ggf. noch Merge-Konflikte auflösen).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • kurzer git-Grundkurs...


    Es gibt:

    - das Remote-Repository

    - dein lokales Repository

    - die Staging-Area

    - das Arbeitsverzeichnis


    Mit "git pull" holst du das remote-Repo in dein lokales Repo und aus deinem lokalen Repo in dein Arbeitsverzeichnis, solange es keine Konflikte gibt. "pull" ist eigentlich zwei Kommandos: fetch und merge.

    In deinem Arbeitsverzeichnis kannst du Dateien verändern, löschen, hinzufügen, das interessiert beim pull nicht (solange beim pull keine neuen Änderungen geholt werden, die mit deinen Änderungen im Arbeitsverzeichnis in Konflikt stehen). Sollte es einen Konflikt geben, meldet git das.


    "git status" zeigt dir an, was du lokal verändert hast. Da wird auch ausgegeben, wie du die Änderungen wieder rückgängig machst: git checkout dateiname


    Mit "git checkout ." werden alle veränderten Dateien wieder in den Zustand versetzt, wie sie in deinem lokalen Repo sind. Außerdem kann man damit Branches wechseln usw.


    Mit "git add dateiname" fügst du deine Änderungen der Staging-Area hinzu. Das ist der Bereich, wo du deinen nächsten Commit vorbereitest. "git status" zeigt dir dann ein paar Sachen mehr an.


    Mit "git commit" bringst du die Änderungen in dein lokales Repo, mit "git push" schiebst du die Änderungen aus deinem lokalen Repo in das Remote-Repo (falls du Schreibrechte hast).


    Für weitere Infos zu git gibt es ungefähr eine Million Tutorials... :)

    Hier ist eins:

    https://riedmann.dev/2019/06/02/GitGud.html

  • Vielen, vielen Dank für die sehr ausführlichen Antworten zum Thema GIT - ich sehe jetzt wesentlich klarer und schäme mich ein bißchen, dass ich mich da nicht vorher etwas eingelesen habe. Ich komme dann sicher noch mit der ein oder anderen Spezialfrage auf euch zurück ;)


    Aber das liegt u.a. daran, dass mir meine Mädels - verständlicherweise - in den Ohren liegen, dass der "neue VDR ganz anders ist und nix mehr funktioniert wie vorher". Ich bin ja dank eurer Hilfe schon ein gutes Stück weitergekommen, habe aber noch etliche Baustellen, bis wieder alles so ist "wie früher" :P


    Am wichtigsten erscheint mir aber die Sache mit den schwarzen Balken.

    Habt ihr bitte noch irgendwelche Tipps parat, was ich noch ausprobieren könnte?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Am wichtigsten erscheint mir aber die Sache mit den schwarzen Balken.


    Habt ihr bitte noch irgendwelche Tipps parat, was ich noch ausprobieren könnte?

    Wenn das OSD bis zum Rand dargestellt wird, sollte es eigentlich nicht an der Einstellung des X-Servers liegen.


    Ist die AutoCrop-Option in softhddevice angeschaltet? Wie sehen die Werte für

    • softhddevice.AutoCrop.Interval
    • softhddevice.AutoCrop.Delay
    • softhddevice.AutoCrop.Tolerance

    in der setup.conf aus?


    Hast du mal eine Aufnahme von den betroffenen Sendern gemacht und dir mit einem Mediaplayer wie VLC angesehen, ob die schwarzen Balken teil des Videomaterials sind?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)