[gelöst] yavdr-ansible: systemd emergency exit

  • Hallo,


    hab seit heute Abend beim Booten kein yavdr-Logo mehr, sondern ubuntu 18.04 und nach ca. 20 sekunden geht der Bildschirm auf systemd emergency exit.

    Hab ich jetzt ein Hardwareproblem oder kann sich systemd beim shutdown auch mal verhaspeln?


    Etwas ratlos dreinschau....


    Gruß Micha


    P.S. auch ein image des funktionierenden Systems auf eine 2. Platte kopiert, reagiert leider genau so...

  • Es gibt einen Emergency Mode (emergency.target) von Systemd bei frühen Bootproblemen (z.B. wenn die in der fstab definierte Einträge nicht erfolgreich für das local-fs.target gemountet werden konnten und man sie nicht explizit mit der Mount-Option nofail gekennzeichnet hat) und einen Rettungsmodus (rescue.target), wenn während des Bootens unüberwindbare Probleme auftreten - vgl. https://freedesktop.org/wiki/Software/systemd/Debugging


    Bekommst du die Möglichkeit dich an einer Shell anzumelden? Dann kannst du dir die Ursache mit journalctl und dmesg ansehen und ggf. das root-Dateisystem beschreibbar einbinden, um Probleme an Konfigurationsdateien beheben zu können:

    Code
    1. mount -n -o remount,rw /


    Ein defekter oder nicht mehr angesteckter Datenträger mit fstab-Eintrag wäre neben einem korrumpierten Dateisystem auch eine mögliche Ursache.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • okay danke, ich versuche der Ursache mal auf den Grund zu gehen :)

    zuerst checke ich mal grundlegende Hardwareprobleme auszuschließen mit einem ubuntu-live stick.

    Dann werde ich mich an systemd machen. Zugriff auf die Boot Partition mit dem Betriebssystem hatte ich gestern bereits.

    Ich werde mal schauen, was "systemctl --failed" ausgibt und ob ich daraus schlau werde. Ins journalctl hatte ich gestern geschaut, viele viele Seiten, die ich nicht sogleich überblickt habe..... :(

    The post was edited 1 time, last by zaubi4u ().

  • So, das live-ubuntu hat mir schon gezeigt, dass da nicht alle Festplatten anwesend sind....

    Kurzer Check der fstab zeigte dann, dass die /video-Festplatte nichts mehr sagte :(

    Nach dem Austausch der Videoplatte gegen eine andere und der Anpassung der UUID in der fstab läuft der vdr wieder :)

    Danke für eure Tips :)


    Find es aber schon heftig, dass das gesamte systemd aussteigt wegen einer defekten Platte, die ja nicht mal die systemplatte ist!

    Übrigens hat systemctl --failed ausgegeben, dass nfs.service beim Start fehlerhaft war... Nicht wirklich aussagekräftig auf das Problem hin....


    Gruß Micha


  • Übrigens hat systemctl --failed ausgegeben, dass nfs.service beim Start fehlerhaft war... Nicht wirklich aussagekräftig auf das Problem hin....

    Das war vermutlich ein Folgefehler, daher der Hinweis auf dmesg (da sieht man direkt, welche Platten erkannt wurden) und das Log - darin müssten u.a. die Probleme der aus der fstab generierten Mount-Units zu sehen sein.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)