[epgd/tvm] zipfile not valid bei allen ids

  • Code
    1. root@VDRServer:~/src/epgd# cd vdr-epg-daemon*
    2. root@VDRServer:~/src/epgd/vdr-epg-daemon-0.3.2.git20160413# git clone https://github.com/3PO/epgd-plugin-tvm PLUGINS/tvm
    3. -bash: git: Kommando nicht gefunden.
    4. root@VDRServer:~/src/epgd/vdr-epg-daemon-0.3.2.git20160413#

    beim git clone kommt : kommando nicht gefunden

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • Code
    1. apt-get install git
  • habe nun genau das nochmal gemacht. Auch unter PLUGINS das Verzeichnis TVM mit den geändertem

    Quelldateien von 3PO.

    Allerdings Fehler bei der kompilierung

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • sorry, so tief bin ich nicht im Thema compilieren. Vieleicht kann jemand anderes mit dem Schnippsel was anfangen.


    Was mich wundert ist, dass bei Dir git noch nicht installiert war. Wenn du TVM mal früher von 3PO compiliert hast, wäre git ja da gewesen.

    Womöglich hast du da was aus einer anderen Quelle, die dann ggf. nicht zum Repo von 3PO passt.


    Irgendjemand eine Idee?

  • Mal bei epgd gucken, welche Abhängigkeiten beim kompilieren benötigt werden. Steht in der Readme meine ich.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Nur zur Info (ich weiß, dass dir das wohl nichts bringt dxwilli ):

    Ich bin gesterne abend genau nach der yaVDR-Anleitung von 3PO vorgegangen und heute passt das EPG wieder bzw. es finden sich keine solchen Fehlermeldungen mehr in /var/log/syslog.

    Danke!

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • ich habs damals aus dieser Anleitung von 3PO gebaut:

    dazu brauchte man kein git.

    Die alte Anleitung funktioniert leider nicht mehr. Und mit der neuen endet es in Fehlermeldungen.

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • das /epgd (siehe oben) Verzeichnis hattest du initialisiert (gelöscht) bevor du das Paket mit git geholt hast?

  • ja hatte ich

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • geh das nochmal durch und achte zwischen den Schritten auf Ausgaben zwischen den Schritten, die evtl. weiterhelfen.

    Wenns bei mir und anderen geht, muss es auch bei Dir gehen, oder?

  • ach und prüfe nach dem Löschen des /epgd ob der Kram wirklich weg ist.

  • Ich bin auch nach der Anleitung von 3PO vorgegangen, leider bekomme ich jetzt:


    mysql-server ist tatsächlich nicht installiert, ich habe epgd ursprünglich nach Vorgabe von seahawk mit

    apt install vdr-epg-daemon

    eingerichtet, dabe wurde der MariaDB Server eingerichtet.

    Was mach ich nun? Kann ich die Installation noch irgendwie retten?

    Silverstone LC 16-MR, P5N7A-VM , Cine S2 Dual DVB-S2 V5.5, E5200, 64 GB Crucial CT064M4, 2 TB WD 20EARX

  • Nimm das Quellpaket aus ppa:/yavdr/experimental-main als Basis, darin stimmen die Abhängigkeiten für bionic und das Paket für das Plugin für MariaDB heißt dann mariadb-plugin-epglv, weil das ganze für den MariaDB Server zugeschnitten ist (vorher die *.deb Dateien mit frodo im Namen löschen).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • dxwilli : Schon eine Lösung gefunden? Habe das selbe Problem, auch noch yavdr 0.5...

    Server: Hardware: Intel DH77KC, Celeron G1610, 8GB RAM, 1x 5TB HDD, 2x WD 1,9TB HDD; 1x 64 GB SSD (root), 4x TT3600 USB DVB-S2, System Ubuntu 18.4 / YaVDR ansible headless
    Wohnzimmer-Client: Hardware: Asus At5-ion-T Deluxe (ION2-Board), 2GB Ram, 30GB SSD, USBASP-IR-Emfänger und Einschalter, ohne DVB-Karte, passiv gekühltSystem: YaVDR 0.5, Zugriff auf Server per remote-frontend (defekt).
    Client: Hardware: Lenovo Q150 (nur Netzwerk, 1GB RAM, ohne DVB-Karte, Igor-USB-Empfänger) System: Ubuntu 18.4 / YaVDR ansible

  • Bei yavdr-ansible muss man die Paketquellen für die Quellpakete erst einbinden, damit der Download des Quellpakets für epgd mit apt(-get) source funktioniert:

    Code
    1. sudo add-apt-repository -s ppa:yavdr/experimental-main

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Bei der Befehlsfolge "build-dep vdr-epg-daemon" hakt es.

    Wenn du das von Hand machst, musst du die Paketquellen neu einlesen (add-apt-repository macht das bei neueren Ubuntu-Versionen automatisch): sudo apt update

    habe ich gemacht: in der sources.list die "##" entfernt.

    Das ist ein apt(-get) Befehl:

    sudo apt build-dep vdr-epg-daemon

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)