Quadro P400 no sound [gelöst]

  • Hi,

    Äh Hardware testen in VM ist nicht sehr clever, da gibt es durch VM doch selbst schon genug Probleme...

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Ich wollte auch nur die Installation auf dem USB-Stick checken und mir das Handling anschauen, dafür ist eine VM bestens geeignet.


    Das Problemkind ist mein Produktionssystem, da sind die Fenster mit Zugriff immer knapp.


    vdr-User-# 755 to_h264 chk_r

  • Der Test mit ubuntu hat Erkenntnisse gebracht, dort funktioniert der Ton auf device 3, statt der erwarteten 7. Verwendet wird nouveau.


    Ich habe einiges an Informationen über die Konfiguration gesammelt und werde das jetzt auswerten.


    vdr-User-# 755 to_h264 chk_r

  • Bei meiner GT1030 springt der Ton zwischen subdevice 3 & 7 hin und her, je nachdem ob der TV beim booten an war.

    Vielleicht hast du ja ein ähnliches Problem.

  • Was mir bis jetzt aufgefallen ist:


    Beim ubuntu boot kommt die Meldung:


    Code
    1. Added _OSI(Linux-Lenovo-NV-HDMI-Audio)

    Dazu passt:


    https://patchwork.kernel.org/patch/10533087/


    der patch ist aber im gentoo kernel drin.


    In der ubuntu .config steht unter Anderem:


    Code
    1. CONFIG_THINKPAD_ACPI=m
    2. CONFIG_THINKPAD_ACPI_ALSA_SUPPORT=y
    3. CONFIG_THINKPAD_ACPI_DEBUGFACILITIES=y
    4. # CONFIG_THINKPAD_ACPI_DEBUG is not set
    5. # CONFIG_THINKPAD_ACPI_UNSAFE_LEDS is not set
    6. CONFIG_THINKPAD_ACPI_VIDEO=y
    7. CONFIG_THINKPAD_ACPI_HOTKEY_POLL=y

    Sowas habe ich aber bis jetzt in den gentoo sources noch nicht gefunden.


    vdr-User-# 755 to_h264 chk_r

  • master_red


    Hast Du edid eingebunden?


    vdr-User-# 755 to_h264 chk_r

  • Hallo,

    Code
    1. CONFIG_THINKPAD_ACPI=m
    2. CONFIG_THINKPAD_ACPI_ALSA_SUPPORT=y
    3. CONFIG_THINKPAD_ACPI_DEBUGFACILITIES=y
    4. # CONFIG_THINKPAD_ACPI_DEBUG is not set
    5. # CONFIG_THINKPAD_ACPI_UNSAFE_LEDS is not set
    6. CONFIG_THINKPAD_ACPI_VIDEO=y
    7. CONFIG_THINKPAD_ACPI_HOTKEY_POLL=y

    Sowas habe ich aber bis jetzt in den gentoo sources noch nicht gefunden.


    doch ist im Kernel, hier Linux master64 4.19.34-gentoo, vorhanden

    mfg

  • Ich hab da auch schon was gefunden, ich hatte CONFIG_SND=m, muss aber CONFIG_SND=y sein.


    vdr-User-# 755 to_h264 chk_r

  • muss aber CONFIG_SND=y sein.

    Nicht unbeding. Es ist zwar ein anderes System, aber hier auf meinem alten Sony Notebook (Intel) und gentoo habe ich nurCONFIG_SND_HDA_I915=y direkt im Kernel , CONFIG_SND=m und alle ander 'SND' Optionen nur als Modul.


    In '/etc/conf.d/modules' habe ich 'snd_mixer_oss und 'snd_pcm_oss' eigentragen damit diese beiden Module beim Start immer geladen werden - das habe ich aber schon seit Jahren so drinnen stehen, vielleicht ist es gar nicht mehr notwendig.


    lsmod zeigt das 'snd' Aufgrund vieler Abhängigkeiten automatisch geladen wird.

    snd 57344 9 snd_pcm_oss,snd_hda_intel,snd_hwdep,snd_mixer_oss,snd_hda_codec,snd_hda_codec_idt,snd_timer,snd_hda_codec_generic


    Helmut

  • Added _OSI(Linux-Lenovo-NV-HDMI-Audio)

    Habe ich jetzt auch im log, aber immer noch keinen Ton, das wars also nicht.


    Ich hab mir mal mit einer angepassten und leicht abgspeckten ubuntu config nen eigenen kernel gebaut und damit hatte ich Ton, aber halt mit Treiber nouveau. Nach Installation des Nvidia-Treibers war der Ton dann wieder weg.


    Nutzt hier jemand softhddevice mit nouveau?


    Auf cuda möchte ich ungern verzichten.


    vdr-User-# 755 to_h264 chk_r

  • Hi,

    Noveau ist unbrauchbar...

    Ton muss aber auch mit pulseaudio gehen.

    Evtl doch Ubuntu nutzen?

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • pulseaudio hab ich noch nicht zum Laufen gebracht. Ich glaube nicht, dass es einen Unterschied macht, ob gentoo oder ubuntu. Es kommt letztlich auf die kernel-Parameter an.


    Zu Beachten ist, die P400 hat nur DP-Ports als Ausgang, ich weiss nicht, ob das nen Unterschied macht.


    vdr-User-# 755 to_h264 chk_r

  • Hi,


    ich hatte das Problem einige Zeit liegen lassen, weil ich mich auch mal mit was Andrem beschäftigen wollte. Derzeitiger Stand: Es funktioniert mit Version 390.116 und so läuft es im Moment bei mir. Ich habe das Problem an Nvidia gegeben und folgende Antwort erhalten:


    Code
    1. Thank you for your email, Jürgen. We've seen several reports of this,
    2. now, and they all seem specific to DisplayPort, and possibly also specific
    3. to DisplayPort-to-HDMI dongles.

    also scheint das Problem bekannt zu sein und ich hoffe, dass von dort eine Lösung kommt.


    vdr-User-# 755 to_h264 chk_r

  • master_red


    Bei meiner Testerei hatte ich auch mal ein Problem mit dem Einbinden der edid, ich hatte sie in der monitor section eingebunden, sie gehört aber in die screen section.


    vdr-User-# 755 to_h264 chk_r

  • Mail von Nvidia


    Code
    1. We think we found what is the bug in the driver. Hopefully we'll be
    2. able to release an updated driver with a fix soon. We'll be sure to
    3. call it out in the changelog.


    vdr-User-# 755 to_h264 chk_r

  • Mit der Version 430.26 ist das Problem gelöst.


    vdr-User-# 755 to_h264 chk_r