Asrock J4105-ITX Erfahrungen / Probleme mit SATA und TBS-Karte

  • Hallo,


    nach einigen Jahren bin ich nun bei einem meiner VDR auf Intel umgestiegen und nutze ein Asrock J4105 Board.


    Mit der Ausgabe über softhddevice (0.7.0) (yavdr experimental ppa) bin ich zufrieden - bis auf PIP und dem Fernbedienungsmodus im live-Plugin (klappt nicht so richtig), funktioniert soweit alles ganz gut.


    Mit meiner Konfiguration (siehe Signatur) läuft alles, jedoch mit folgenden Einschränkungen - ggf. kann das der ein oder andere J4105-Besitzer bestätigen:


    1. Irgendwie gibt es ab und an einen Reset? am SATA-Anschluss 2 in Kombination mit einer WDC WD40EZRZ. Anschluss 1 in Kombination mit einer Samsung SSD 840 EVO scheint nicht betroffen:

    Mit einem weiteren BR/DVD-Laufwerk war es m.E. noch schlimmer - ich habe aber keine Logs mehr, da ich es ausgebaut habe. Wenn die o.g. letzten Meldungen auftauchen, hört man auch ein Geräusch bei der Festplatte.

    Ich werde mal probieren, die WD auf SATA3 bzw. 4 zu stecken, dies ist m.E. ein anderer Controller (ASM1062 Serial ATA Controller).


    2. derzeit (Kernel: 4.18.0-17-generic) Probleme mit der Nutzung einer TBS 6981 (6981:8888) DVB-S2 Karte. In nicht definierten Abständen ist der DVB-Signal weg und im Kernel-Log steht mpeg risc op code error. Ein Neustarten des VDR hilft, ist aber keine Lösung. Mit Verwendung von media_build Modulen tritt das Problem nicht auf. Ich vermute mit Kernel 4.20 wird es dann funktionieren, da der Treiber m.E. einen Workaround hierfür besitzt:

    Code
    1. parm: dma_reset_workaround:periodic RiSC dma engine reset; 0-force disable, 1-driver detect (default), 2-force enable (int)

    Genau dieser Reset kommt vor dem Absturz ein oder mehrmals. Im media_build Module habe ich jedoch keine Option angegeben. Das Modul funktioniert OOTB.


    3. WakeUp funktioniert nur richtig, wenn HPET im BIOS abgeschaltet wird. Der daraus entstehende Eintrag im Log hat keine mir bekannten negativen Auswirkungen:

    Code
    1. [ 4230.000463] clocksource: timekeeping watchdog on CPU3: Marking clocksource 'tsc' as unstable because the skew is too large:
    2. [ 4230.000486] clocksource: 'acpi_pm' wd_now: f63a1c wd_last: 3e978 mask: ffffff
    3. [ 4230.000487] clocksource: 'tsc' cs_now: 5cbde85c352 cs_last: 5ca5282b040 mask: ffffffffffffffff
    4. [ 4230.000490] tsc: Marking TSC unstable due to clocksource watchdog
    5. [ 4230.000543] TSC found unstable after boot, most likely due to broken BIOS. Use 'tsc=unstable'.
    6. [ 4230.000545] sched_clock: Marking unstable (4229972523459, 27982829)<-(4229979527168, 21015925)
    7. [ 4230.001152] clocksource: Switched to clocksource acpi_pm

    4. lm-sensors - es sind nicht viele Daten verfügbar. Wenn man das Modul nct6775 lädt, erhält man folgende Werte:

    Die Spannungen sind also nicht alle vorhanden (z.B. 12V Schiene).


    Ggf. kann ja die Liste mit weiteren Tipps ergänzt werden...

    My VDRs:

  • Was sind Deine Einstellungen bzgl. Interpolation? Mir ist gestern wieder aufgefallen, dass die Darstellung von SD Material extrem blockig ist (sieht man sogar aus 3-4m, 55" FHD TV).

    Mit SATA hab ich keine Probleme, allerdings auch nur eine 'Platte' dran (auch 'ne 840 EVO, an ata1). Wenn ich Zeit hab werd ich mal noch 'ne zweite dran hängen.

    VDR1:ASRock Ion 3D 152B, Sundtek SkyTV Ultimate openSUSE Leap 42.2, VDR 2.4.0,
    VDR2: ASRock J4105-ITX, DVBSky S952, openSUSE Tumbleweed, VDR 2.4.0

    softhddevice/vaapidevice, DFAtmo, xmltv2vdr, tvscraper, tvguideng, VDRAdmin-AM (alles git)

  • Irgendwie gibt es ab und an einen Reset? am SATA-Anschluss 2 in Kombination mit einer WDC WD40EZRZ

    schon mal das SATA-Datenkabel getauscht? Manche Kabel sind grottenschlecht, zumal wenn die Verriegelung nicht richtig funktioniert. Ich kann mich dran erinnern (SATA Link down), das ich hier --> http://www.fdm-ware.de/SATA/index.html


    am Dawicontrol eine Alu-Schiene zur Fixierung einbauen musste, weil bei den SATA Buchsen die Verriegelung nicht griff.

  • Ja - das Kabel habe ich schon getauscht - ich glaube 3x, da ich schonmal schlechte Erfahrungen damit gemacht habe. Bei den SATA-Geräten bin ich aber (vermutlich) auf die Ursache eines Problems meines VDRs gestossen, welches ich nie identifizieren konnte. Der VDR (damals mit ION-Board) stürzte in unregelmäßigen Abständen ab (das Bild blieb stehn und der Ton stotterte/zischte in einer Endlosschleife). Ursache war wohl das BR/DVD-Laufwerk, denn also ich dieses jetzt angeschlossen habe (war mangels Stromleitungen der PicoPSU noch abgeklemmt), konnte ich den Absturz durch VDR => Commands => eject reproduzieren. Nunja...Thema am Rande.


    @Der_Pit - also ich habe einen 40" und kann mit dem SD gut leben. Es stimmt aber, dass VDPAU hier besser war. Meine Konfiguration:


    Geht denn PIP bei Dir? Bei mir stürzt der VDR damit ab. Ich nutze derzeit vdr-plugin-softhddevice-vdpau-hevc. Vaapidevice habe ich nur funktionsweise getestet, softhdcuvid (4 Versionen?) noch gar nicht. Da blicke ich derzeit nicht durch, was besser/aktueller ist. Fazit: softhddevice geht gut mit SD, HDTV und HVEC (DVB-T2), Stereo-Ton über HDMI funktioniert (SPDIF noch nicht getestet). PIP ist eher Spielerei.

    My VDRs:

    The post was edited 1 time, last by dad401 ().

  • Ich habe das mit den SATA-Ports nochmal getestet. Am 1. SATA Controller (ata1 und ata2) hängt die SSD und nun ein DVD-Brenner. Am 2. Controller nun die WD-HDD (war vorher an ata2) - das Log ist ähnlich:



    Bisher habe ich jedoch keine negativen Auswirkungen feststellen können. Ich lasse das erstmal so.

    Ergänzend: am 2. SATA-Controller habe ich den 3. Anschluss (ata3) als eSATA per Slotblech nach aussen geführt. Das funktioniert auch (im o.g. Log war dort jedoch nichts angeschlossen).


    Folgendes ist m.E. jedoch zum alten System (ION) anders bzgl. HDD: Wenn ich im VDR den Schnitt einer Aufnahme starte, dann ruckelt/stockt kurzzeitig die Wiedergabe einer Aufnahme (nicht das TV Signal). Das kannte ich bisher noch nicht. Im extrecmenung ist "Bandbreite beim Schneiden begrenzen" aktiviert. Vorher nutze ich jedoch das extrecmenu (ohne ng).

    My VDRs:

  • Im extrecmenung ist "Bandbreite beim Schneiden begrenzen" aktiviert.

    Diese Option gibt es in extrecmenung nicht mehr. Ich habe wohl vergessen, das aus dem Setup-Menü heraus zu nehmen, das mache ich noch.

    ExtrecmenuNG nutzt jetzt überwiegend die internen Funktionen vom Core-VDR, also auch die Schnitt- und Verschiebe-Routinen. Du kannst ja mal versuchen, den Schnitt direkt aus dem originalen VDR-Aufzeichnungsmenü zu starten. Wenn es sich dann genau so verhält, und das sollte es eigentlich, dann ließe sich das nur direkt im Core-VDR beeinflussen.


    Übrigens, wenn man das alte Plugin, also ohne NG, mit "USE_VDR_CUTTER" übersetzt hat, nutze es auch schon nicht mehr die eingebaute Schnittfunktion.

    VDR 2.4.0: ASUS M5A97 PRO, FX6100, 16GB, 2TB HD, GT630, Fedora 29 Kernel 5.0 X86_64, Devicebonding 2 x 1 auf 2, TT6400, DVBSky S952 V3