Aufnahmen auf NAS fehlerhaft

  • hi zusammen,


    ich habe ein Ubuntu 18.04.2 mit vor 2.4 laufen.


    Mein NAS ist mit Samba eingebunden und der vdr kann auf das Netzlaufwerk schreiben zugreifen.


    Leider misslingen die Aufnahmen, d.h. die Aufnahme funktioniert die ersten ca. 20 Sekunden problemlos...dann wird allerdings das Bild mit extrem vielen Artefakten bis zur Unkenntlichkeit geschreddert.


    Das Verhalten zeigt sich sowohl bei Nutzung von SMB v2.0, v2.1 und 3.0. SMB v1.0 habe ich nicht getestet.


    Mir ist bewusst, dass auch NFS möglich ist, dies möchte ich jedoch nicht wirklich nutzen.


    Bei dem NAS handelt es sich um ein QNAP TS-559 Pro+ mit QTS 4.2.6. SMBv3.0 habe ich hier aktiviert. Das NAS setze ich bereits seit vielen Jahren erfolgreich für die Speicherung der Aufnahmen ein. Leider ist seit Ubuntu 18.04 und vdr 2.4 das Problem vorhanden.


    Ach so ...Aufnahmen auf die lokale SSD funktionieren problemlos.


    Wo könnte ich ansetzen, um das Problem zu lösen .....


    VG Stephan

    ------------------------------------------------------------------------------------------------------------------------------------------------

    BM2LTS im VDR-Portal   http://www.bm2lts.de   http://www.sc-schulze.de

    ------------------------------------------------------------------------------------------------------------------------------------------------

    Empfang: Octopus Net S2 max (8 Tuner) +Netceiver mit 2x DVB-s2 dual

    Kopfstation/ Wohnzimmer: Intel NUC8i3BEH2; BM2LTS v3.2.XX

    VDR: Intel NUC D54250WYKH2; BM2LTS Route 66

    weitere Client's: FireTV 4k mit Kodi u. VNSI-Plugin

    ------------------------------------------------------------------------------------------------------------------------------------------------


  • Mein NAS ist mit Samba eingebunden und der vdr kann auf das Netzlaufwerk schreiben zugreifen.

    Wie genau hast du die Freigabe eingebunden?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,


    versuch doch mal in smb.conf

    Code
    1. strict sync = no
    2. socket options = TCP_NODELAY SO_RCVBUF=65535 SO_SNDBUF=65535 IPTOS_LOWDELAY

    CU

    9000h

    Es ist eagl in wlehcer Reiehnfogle die Bchustebaen in Woeretrn vokrmomen. Huapstache der estre und leztte Bchustbae sitmmen.

  • Hi,


    versuche es mal mit diesen /etc/fstab Eintrag zum QNAP NAS


    Code
    1. //IP4-NAS/Meine/Ablage /Meine/VDR/recordings cifs x-systemd.automount,noauto,username=NAS,password=NAS

    (VDR) NUC8I3BEH * BM2LTS * Octopus NET S2 Max * Reel NetCeiver ## (AVR) Denon X-1400H ## (UHD-Player) LG UP970 ## (OLED TV) LG OLED 65E97LA


  • hi,


    @ cInfo: mit dem Eintrag in der Stab gelingt der Mount .... allerdings werden die aufnahmen geshreddert ....


    @alle:


    die smb.conf des Qnap NAS sieht wie folgt aus:


    wenn ich auf eine Samba-Freigabe zu einem Ubuntu_18.04 in einer VM sichere ....gelingen die Aufnahmen....die smb.conf sieht hier recht einfach aus:



    Die große Frage ist, welche Einstellung in der smb.conf des QNAP bewirkt das Problem?

    ------------------------------------------------------------------------------------------------------------------------------------------------

    BM2LTS im VDR-Portal   http://www.bm2lts.de   http://www.sc-schulze.de

    ------------------------------------------------------------------------------------------------------------------------------------------------

    Empfang: Octopus Net S2 max (8 Tuner) +Netceiver mit 2x DVB-s2 dual

    Kopfstation/ Wohnzimmer: Intel NUC8i3BEH2; BM2LTS v3.2.XX

    VDR: Intel NUC D54250WYKH2; BM2LTS Route 66

    weitere Client's: FireTV 4k mit Kodi u. VNSI-Plugin

    ------------------------------------------------------------------------------------------------------------------------------------------------