yaVDR ansible: Picture-in-Picture softhddevice => Neustart

  • Hallo zusammen,


    ich möchte im softhddevice Picture-in-Picture auf meinen Intel-System nutzen. Wenn ich PiP-start gibt es eine Bauchlandung, der VDR (oder zumindest das Frontend) startet neu:

    4x yaVDR 0.7: ASUS P5N7A-VM // 2*TeVii S460 // Atric mit Lirc // 4*1,5TB // 7" TFT

  • Da Crasht der komplette VDR.

    Mar 5 12:30:42 vdr-uhd vdr: video/vaapi: out of decoders

    Das klingt so, als ob das Plugin da nicht in der Lage ist mehr als eine Videospur mit vaapi anzuzeigen - ob das eine hardwareseitige Limitierung ist (was für Hardware nutzt du denn?) oder ob das Problem in softhddevice steckt weiß ich leider nicht, dazu kenne ich ffmpeg nicht gut genug.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich meinte die Intel-IGP, die das Hardwaredecoding für die Ausgabe macht.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Nachdem vaapidevice die PIP-Funktionalität rausgeworfen hat, stehen die Chancen vermutlich nicht allzu gut, dass man das erfolgreich mit va-api und softhddevice nutzen kann.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Besteht eine Chance das "alte" Plugin PIP zu reanimieren?

    Wenn jemand einen Patch bastelt, der es wieder nutzbar macht - das osdpip-Plugin war schon nicht mehr gegen das ffmpeg in trusty baubar ...


    Ansonsten gäbe es noch das yavdr-addon-pip, das startet bei Bedarf eine zweite VDR-Instanz (die man z.B. über streamdev oder satip versorgen kann), um eine PIP/PBP Funktionalität zu realisieren.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Andere Frage:

    Beim yaVDR bisher kam eine Meldung, wenn das Frontend detached ist. Bei ansible kommt sie (zumindest bei mir) nicht mehr.


    Ist dies einstellbar, so dass dann wieder eine Meldung kommt?

    4x yaVDR 0.7: ASUS P5N7A-VM // 2*TeVii S460 // Atric mit Lirc // 4*1,5TB // 7" TFT

  • Ich versuche das gerade nachzuvollziehen, was du geschrieben hast - bei mir klappt das detachen des Frontends beim Drücken der Power-Taste auf der Fernbedienung mit vaapidevice einwandfrei:


    Und sobald das Frontend detached ist, zeigt er das Hintergrundbild mit roten Power-Symbol im Logo an, um zu signalisieren, dass das Frontend versucht den VDR herunterzufahren:

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Und wenn ich das Frontend detache frontend-dbus-send stop bekomme ich das Hintergrundbild, das ein detachtes Frontend signalisiert:



    Edit: mit frontend-dbus-send toggle klappt das nicht, das muss ich mir noch mal ansehen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Und bei einem Deta -> Atta Zyklus habe ich mit sowohl mit softhddevice als auch mit vaapidevice nach dem Attachen ein Bild (der Laptop, der als Intel-Testsystem dient, hängt über streamdev-client am Haupt-VDR).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Edit: mit frontend-dbus-send toggle klappt das nicht, das muss ich mir noch mal ansehen.

    Da genügt eine Anpassung in der /usr/lib/python3/dist-packages/yavdr_frontend/yavdrfrontend.py, um das zu beheben:

    Ich muss noch mal schauen, ob ich mich irgendwo darauf verlasse, dass toggle nicht-interaktiv arbeitet, ansonsten packe ich das demnächst ins Paket.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Die Änderung ist mittlerweile im Paket.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)