[yavdr-ansible] Probleme beim Verschieben von Aufnahmen mit Unterverzeichnis

  • Ich habe einen Bug im yavdr-ansible festgestellt, der beim Verschieben von Aufzeichnungen über das OSD-Aufzeichnungsmenü auftritt.

    Dieser Fehler tritt nur beim Verschieben von Aufzeichnungen auf, die noch ein Unterverzeichnis mit z.B. einem Episodentitel haben.


    Wenn ich solch eine Aufzeichnung verschieben will, dann bleibt der VDR einfach hängen und das letzte OSD bleibt stehen, Bild und Ton laufen weiter, aber der VDR ist unbedienbar. Das ist unabhängig vom OSD selbst, denn auch beim "klassischen VDR OSD" passiert das. Hier hilft nur noch ein "reboot"!


    Verschiebe ich dagegen eine "normale" Aufzeichnung ohne Unterverzeichnis/Episodentitel, dann klappt das problemlos, wie erwartet.


    Um das nochmals zu verdeutlichen habe ich 2 Auszüge aus dem syslog gemacht.

    1. Verschieben einer Aufzeichnung ohne Unterverzeichnis:

    Code
    1. yaVDR vdr: [967] VNSI: Requesting clients to reload recordings list (1)
    2. yaVDR irexec[639]: KEY_RIGHT
    3. yaVDR vdr: [783] [extrecmenu] moving /srv/vdr/video/Hubert_und_Staller/2019-02-08.20.14.11-0.rec to /srv/vdr/video/The_Team__I/Hubert_und_Staller/2019-02-08.20.14.11-0.rec
    4. yaVDR irexec[639]: KEY_BLUE
    5. yaVDR vdr: [783] executing '/usr/lib/vdr/vdr-recordingaction move "/srv/vdr/video/Hubert_und_Staller/2019-02-08.20.14.11-0.rec" "/srv/vdr/video/The_Team__I/Hubert_und_Staller/2019-02-08.20.14.11-0.rec"'
    6. yaVDR recordingaction: executing /usr/share/vdr/recording-hooks/R90.custom as shell script
    7. yaVDR vdr: [967] VNSI: Requesting clients to reload recordings list (1)
    8. ...


    2. Verschieben einer Aufzeichnung mit einem Unterverzeichnis/Episodentitel:

    Code
    1. yaVDR vdr: [967] VNSI: Requesting clients to reload recordings list (1)
    2. yaVDR irexec[639]: KEY_BLUE
    3. yaVDR vdr: [783] [extrecmenu] moving /srv/vdr/video/The_Team_(3)/Vierteilige_europäische_Krimireihe/2019-02-26.23.17.25-0.rec to /srv/vdr/video/The_Team__I/The_Team_(3)/Vierteilige_europäische_Krimireihe/2019-02-26.23.17.25-0.rec

    Mehr Einträge gibt es im syslog hier nicht mehr!

    Da der VDR sich nicht mehr bedienen lässt muss ich über die Konsole den VDR rebooten.

    Nach dem Reboot ist dann die Aufzeichnung allerdings korrekt verschoben, d.h. die Aktion wird prinzipiell ausgeführt, aber irgendwo bleibt der VDR komplett hängen.


    Paul

  • Ich sehe in Deinem Log, dass das extrecmenu involviert ist.


    Denn ich kann keine Probleme beim Verschieben von Aufnahmen mit Unterverzeichnissen bestätigen. Mache ich sehr oft. Benutze aber das extrecmenu nicht mehr, da das ja inzwischen mit dem normalen VDR-Aufzeichnungsmenü geht (über Info und dann Editieren, dort dann das Zielverzeichnis wählen und OK).

  • Stimmt, wenn ich das extrecmenu-Plugin deaktiviere, dann geht das auch so, wie von Dir beschrieben über das interne VDR-Aufzeichnungsmenü.


    Aber wenn das "nur" am extrecmenu-Plugin liegt, dann bin ich scheinbar der einzigste, der das Plugin noch einsetzt! :/

    Schade, denn ich finde das Plugin doch etwas komfortabler als das interne VDR-Aufzeichnungsmenü.

  • Naja, früher war das auch eines meiner must-have-Plugins. Aber seit der VDR das Verschieben auch selbst beherrscht und das Plugin scheinbar nicht mehr gepflegt wird und immer mal wieder Probleme verursacht hat, setzten es bestimmt nicht mehr so viele ein wie früher.

    Bei mir ist es auch rausgeflogen :-)

  • dann bin ich scheinbar der einzigste, der das Plugin noch einsetzt!

    Bist du nicht :-)


    Für mich ist es immer noch ein must-have Plugin, da beim Verschieben die verfügbaren Verzeichnisse zur Auswahl angezeigt werden und man diese mit der Fernbedienung auswählen kann, während man bei internen vdr Verschieben den Verzeichnisnamen wissen und eintippen muß.


    Außerdem erlaubt es zusätzlich zum Aufnahmedatum noch die Filmlänge in der Übersicht anzuzeigen.


    Sehr schade.

  • während man bei internen vdr Verschieben den Verzeichnisnamen wissen und eintippen muß

    Werden die Namen bei dir nicht angezeigt, wenn du die rote Taste drückst?


    Klaus