Nextcloud hinter einem Reverseproxy - Probleme mit der Konfig

  • Hallo zusammen,


    ich habe einen Nextcloudserver und habe nun einen Reverseproxy bezüglich SSL terminierung vorgeschaltet. Der Reverseproxy bedient auch noch andere Systeme die auch ohne Probleme funktionieren. Nur das Nextcloudsystem funktioniert irgendwie nicht.


    Das Fehlerbild ist folgendes. Ich greife auf die externe URL vom Nextcloudserver zu und bekomme die Anmeldemaske. Ich melde mich an und nach erfolgreicher abmeldung werde ich automatisch auf die interne Serveradresse weitergeleitet was natürlich nicht funktionieren kann. Woher kommt dieser Redirect vom Nextcloudserver? Falls ja wie schalte ich das ab?


    Meine Konfig sieht derzeit so aus:


    Reverseproxy

    <VirtualHost *:80>

    ServerName nextcloud.mydomain.com

    RewriteEngine On

    RewriteRule ^/$ https://nextcloud.mydomain.com/nextcloud/$1 [L,R]

    ProxyRequests Off

    ProxyPass / http://nextcloudsrv01.intra.mydomain.com/

    </VirtualHost>



    <VirtualHost *:443>

    ServerName nextcloud.mydomain.com

    SSLEngine on

    SSLProxyEngine on

    SSLCertificateFile /etc/ssl/certs/wwwsrv01.crt

    SSLCertificateKeyFile /etc/ssl/private/wwwsrv01.key

    ProxyRequests Off

    ProxyPass / http://nextcloudsrv01.intra.mydomain.com/

    </VirtualHost>


    Mit dem ersten Virtual Host auf Port 80 möchte ich bezwecken das alle Request automatisch vom Webserver auf SSL terminiert werden. Der zweite macht dann die SSL Konfig zum Nextcloudserver.

  • Hi,

    folgende Ideen:

    - in der config/config.php von nextcloud:
    -- bei trusted_domains nextcloud.mydomain.com hinzufügen
    -- overwrite.cli.url prüfen und ggf. löschen/anpassen


    Bei *:80 kannst Du Dir das mit Rewrite sparen - ein
    <VirtualHost *:80>

    ServerName nextcloud.mydomain.com

    Redirect "/" "https://nextcloud.mydomain.com/"

    </VirtualHost>

    sollte reichen


    Vielleicht ist was dabei, was Dich weiterbringt


    mfg sd

  • Versuch doch mal zu deinem

    Code
    1. ProxyPass / http://nextcloudsrv01.intra.mydomain.com/

    auch noch einen


    Code
    1. ProxyPassReverse / http://nextcloudsrv01.intra.mydomain.com/

    einzutragen.


    Ich hab meine Weiterleitungen immer so in der proxy.conf unter /etc/appache2/mod-enabled eingetragen.


    Gruß

    msv

  • Hallo,


    danke für eure Tipps. Ich habe beide Vorschläge umgesetzt und nun funktioniert die Weiterleitung wie gewünscht.


    Ein Problem habe ich noch. Mit zeigt die Adminpage vom Nextcloud diese beiden Warnings an:


    Dein Webserver ist nicht ordnungsgemäß für die Auflösung von "/ocm-provider/" eingerichtet. Dies hängt höchstwahrscheinlich mit einer Webserverkonfiguration zusammen, die nicht aktualisiert wurde, um diesen Ordner direkt zu liefern. Bitte vergleiche Deine Konfiguration mit den mitgelieferten Rewrite-Regeln in ".htaccess" für Apache oder den in der Nginx-Dokumentation bereitgestellten auf dessen Dokumentationsseite. Auf Nginx sind das typischerweise die Zeilen, die mit "location ~" beginnen und ein Update benötigen.


    Dein Webserver ist nicht ordnungsgemäß für die Auflösung von "/ocs-provider/" eingerichtet. Dies hängt höchstwahrscheinlich mit einer Webserverkonfiguration zusammen, die nicht aktualisiert wurde, um diesen Ordner direkt zu liefern. Bitte vergleiche Deine Konfiguration mit den mitgelieferten Rewrite-Regeln in ".htaccess" für Apache oder den in der Nginx-Dokumentation bereitgestellten auf dessen Dokumentationsseite. Auf Nginx sind das typischerweise die Zeilen, die mit "location ~" beginnen und ein Update benötigen.


    Da ich aber einen Apache Reverseproxy vorgeschaltet habe wird die verlinkte Anleitung bei mir nicht funktionieren. Auch nutze ich kein nginx. Jemand

  • versuchs doch mal mit dieser "nextcloud.conf" in sites-available. Must nur die Pfade und domain an deine Umgebung anpassen.



    Danach dann ein "a2ensite nextcloud.conf" und apache2 neustarten. Dann sollten die Meldungen eigentlich "platt" sein.

    (entnommen der nextcloud-Doku und dem nextcloud forum)


    Gruß
    msv