VDR EPGSYNC

  • Hallo vdr'ler allesamt,


    mein "headless" und "device-less" VDR-Client mit nachfolgender Konfiguration


    Code
    1. ii vdr 2.2.0-6+b1 amd64 Video Disk Recorder for DVB cards
    2. ii vdr-plugin-epgsync 1.0.1-2 amd64 VDR plugin for EPG synchronization between VDR systems
    3. ii vdr-plugin-live 0.3.0+git20160123-1 amd64 Web administration plugin for VDR
    4. ii vdr-plugin-softhddevice 0.6.0+git20160108-1+b1 amd64 HD output device plugin for VDR
    5. ii vdr-plugin-svdrpservice 1.0.0-5 amd64 VDR plugin that provides a SVDRP service for other plugins


    soll die EPG Daten meines VDR Servers abfragen und synchronisieren, damit ich ihn über vdr-live zum Programmieren von Aufnahmen benutzen kann.


    Auf dem VDR-Client habe ich nachfolgendes konfiguriert


    Code
    1. #
    2. # svdrpservice VDR plugin arguments
    3. #
    4. [svdrpservice]
    5. 10.148.1.246:6419


    Selbiger Eintrag steht auch in der /etc/vdr/conf.d/50-epgsync.conf.


    Wenn ich die Synchronisation vom Client aus mit dem Befehl svdrpsend PLUG epgsync SYNC starte, erscheint im Logfile nachfolgende Meldung


    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [519] connect from 127.0.0.1, port 58716 - accepted

    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [535] epgsync thread started (pid=519, tid=535, prio=high)

    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [535] svdrpservice: Invalid server IP ''

    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [535] epgsync thread ended (pid=519, tid=535)

    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [519] ERROR: EpgSync: Verbindung zum Server fehlgeschlagen

    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [519] closing SVDRP connection



    Es scheint mir so, als hätte der VDR die Remote IP Adresse des VDR-Servers nicht erkannt, aber sowohl die Konfigurationsdatei wie auch der eingetragene Wert sind doch richtig, oder?


    Dann habe ich noch versucht, ob die beiden Rechner gegenseitig den Port 6419 öffnen können, was mit nmap wie auch svdrpsend funktioniert.


    Das ist die Abfrage vom VDR-Client zum VDR-Server:



    Das ist die Abfrage vom VDR-Server zum VDR-Client:



    So, und jetzt bin ich mit meinem Latein erstmal am Ende ...


    Vielen Dank für jegliche Hilfe und Tipps!

  • Die config von svdrpservice ist sicher falsch. Ruf doch mal die Hilfe auf oder stell IP und port über das Osd ein.


    Wobei laut hier sollte es stimmen.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 1 time, last by TheChief ().

  • Hi TheChief,


    tja, genau das habe ich ja auch gelesen.


    Und funzt trotzdem nicht. Mich wundert, dass svdrpsend auf Befehlsebene in beiden Richtungen funktioniert (siehe oben) und ich habe außerdem nirgendwo mal einen Screenshot einer dokumentierten Konfiguration dieser beiden Plugins gefunden. Habe ja noch die Hoffnung dass der schmirl das mal sieht und mir hilft ...

  • Naja, er findet auf jedenfalls die ServerIP nicht:

    Code
    1. Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [535] svdrpservice: Invalid server IP ''

    Warum das so ist, gilt es zu klären. Kann der VDR eventuell die ServerIP aus der Datei nicht parsen? Bei Live besipielweise wird die IP mit "--ip=x.x.x.x". Bei svdrpservice wird js nur IP und Port angegeben ohne weiteres Argument. Schreib doch mal in die Config (nur zum testen) mal --ip=x.x.x.x rein, mal sehen, was das Log dann ausspuckt. Leserechte hat der VDR auf die Datei nehme ich an.


    EDIT: Hab das mal getestet. Sollte gehen. Probier mal "vdr --showargs"


    Und schreib mal bei gestopptem VDR in die setup.conf:


    svdrpservice.ServerIP=10.148.1.246

    svdrpservice.ServerPort=6419


    Oder eben per OSD konfigurieren, wie schon gesagt.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 2 times, last by TheChief ().

  • Ich danke Dir für Deine Mühe und werde berichten ...

    OSD geht aber nicht weil das eine "head- und device-less" VM ist. Höchtens vielleicht mit xine Framebuffer Interface, das könnte vielleicht funktionieren.

  • Na dann halt per Hand in die setup.conf.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hi,

    Du kannst doch per Live-Plugin das OSD nutzen.


    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de