Softhddevice + ffmpeg > 3.2 (vdpau)

  • Just realized that opengl osd is now supported :)

    So i tested new version but sadly playback is very jerky even in sd channels, same as sc44 already reported here


    log.txt


    Hmmm the whole desktop is laggy during playback...


    Code
    1. PID USER PR NI VIRT RES SHR S %CPU %MEM ZEIT+ BEFEHL
    2. 43940 vdr 1 0 3560332 266392 97624 S 18,9 1,6 2:28.29 vdr
    3. 1217 root 1 0 238308 93364 64728 S 12,9 0,6 5:17.19 Xorg

    Asus H170 PRO GAMING, Intel Core i7-6700T, 16GB RAM, GeForce GTX 1050 2GB, Samsung SSD 860 EVO 1TB SSD + 3TB WD Red, Mystique SaTiX-S2 Dual, Archlinux -> VDR4Arch


    "Freunde sind Menschen, die dich mögen obwohl sie dich kennen"

    The post was edited 1 time, last by cooljay032 ().

  • Is there any hd channel in mpeg2, or how can i test this? Btw. i tried all sort of channels, with the same result.


    My desktop is Xfce with Xorg, running on a separate screen. Any further Tests, Logs or anything i can provide? :saint:

    Asus H170 PRO GAMING, Intel Core i7-6700T, 16GB RAM, GeForce GTX 1050 2GB, Samsung SSD 860 EVO 1TB SSD + 3TB WD Red, Mystique SaTiX-S2 Dual, Archlinux -> VDR4Arch


    "Freunde sind Menschen, die dich mögen obwohl sie dich kennen"

  • Just found a little time to test with 1920x1080 resolution, watching TV is much better now.

    GPU info looks like there are more than enough resources, but desktop still not really smooth. Hmmm


    Asus H170 PRO GAMING, Intel Core i7-6700T, 16GB RAM, GeForce GTX 1050 2GB, Samsung SSD 860 EVO 1TB SSD + 3TB WD Red, Mystique SaTiX-S2 Dual, Archlinux -> VDR4Arch


    "Freunde sind Menschen, die dich mögen obwohl sie dich kennen"

  • Works great with Ubuntu 19.10 (ffmpeg 4.1.4) and GT610.


    There are only two issues I noticed:

    • I needed to set an audio delay of -100ms, otherwise video and audio is not lip-synced. I use passthtrough and pulseaudio. The sound goes from my GT610 via HDMI to my AV-receiver. With the same configuration I didn't need an audio delay with Ubuntu 18.04, using an older softhddevice-fork by jojo61.
    • There is one older PES recording (vdr-filetype) which plays with wrong speed. If you are interested to investigate this, I could upload the recording folder for you.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • I am not sure if it was build with opengl. I just found this at the end of the README.



    Optional:
    for openGL osd need libs gl glu glew freetype2

    If these are the right packages:


    libgl1-mesa-dev

    libglu1-mesa-dev

    libfreetype6-dev


    -which I had already installed- then it should have been build with opengl-support.


    How can I check if softhddevice really uses it?

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • then it works :)

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • hm... but when I look into the Makefile:


    Code
    1. ifeq ($(OPENGLOSD),1)
    2. OBJS += openglosd.o
    3. endif


    I wonder why there is no openglosd.o after compiling?

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • set -l3.7 in vdr start options, and see in syslog

    If opengl osd

    Jan 29 10:00:38 ua0lnjvdr vdr: [2627] [softhddev]Trying to start OpenGL Worker Thread

    Jan 29 10:00:38 ua0lnjvdr vdr: [2661] oglThread thread started (pid=2627, tid=2661, prio=high)

    Jan 29 10:00:38 ua0lnjvdr vdr: [2661] [softhddev]OpenGL Context initialized

    Jan 29 10:00:38 ua0lnjvdr vdr: [2661] [softhddev]Shaders initialized

    Jan 29 10:00:38 ua0lnjvdr vdr: [2661] [softhddev]Vertex buffers initialized

    Jan 29 10:00:38 ua0lnjvdr vdr: [2661] [softhddev]Maximum Pixmap size: 32768x32768px

    Jan 29 10:00:38 ua0lnjvdr vdr: [2627] [softhddev]OpenGL Worker Thread successfully started


    if soft osd

    [softhddev]No hw driver or OpenGL Osd disabled - use soft OSD



    Also

    pkg-config --exists glew glu freetype2 && echo 1

  • I needed to install

    libglew-dev libglm-dev

    and also

    freeglut3-dev


    otherwise there comes an error, although the Makefile check was successful:


    openglosd.h:5:10: fatal error: GL/freeglut.h: Datei oder Verzeichnis nicht gefunden

    5 | #include <GL/freeglut.h>


    Now it compiles with openglosd. But I can't try it out before tomorrow - a recording is running

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • It doesn't work. I get no osd, the remote control doesn't work and controlling the vdr via terminal/ssh-connection is also not possible. I can't even stop vdr (started from command line in a terminal) with Control-C . Instead I need to open a second terminal to kill vdr.


    I attach the complete log.


    With -w disable-ogl-osd the vaapi+vdpau branch works like before.


    The vaapi+vdpau+cuvid has the same problem with oglosd and there is (using -w disable-ogl-osd) a further issue with channel switching: often the picture is black. Somtimes the pictures comes after several seconds, sometimes it keeps black. This is a log when the new channel doesn't appear - I can't see anything suspicious:


    Files

    • log.txt

      (18.92 kB, downloaded 35 times, last: )

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • It seems the card does not support shaders 3.3 version.

    You made log without -w disable-ogl-osd, there is Trying to start OpenGL Worker Thread.

    With disable-ogl-osd the vaapi+vdpau+cuvid have issue with channel switching?


    Please uncomment in makefile DDEBUG and DOSD_DEBUG, and make log without disable-ogl-osd.

  • export MESA_GL_VERSION_OVERRIDE=3.2 doesn't help.

    According to the Nvidia settings tool the GT610 supports OpenGL 4.60

    shaders version? no idea


    vaapi+vdpau+cuvid with enabled openglosd (no -w disable-ogl-osd parameter): I can't switch channels, because vdr does not respond to any key. Maybe the log shows why OSD is not working?


    vaapi+vdpau+cuvid with disabled openglosd (using -w disable-ogl-osd parameter): both time when switching to channel 36 I had a black picture. On the console the debug output says

    Code
    1. [mpeg2video @ 0x7fdf5c083580] Invalid frame dimensions 0x0.

    (this is not in syslog)

    Files

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Hi,

    Your channel Hamburg 1 is the last DVB-T channel I received at my parents home near of you. The others switched to DVB-T2 HD.

    Regards Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • In my case it is a DVB-C channel

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!