Kernel für Hauppauge WinTV Dual-HD installieren

  • Hallo


    Ich habe mir einen Hauppauge WinTV Dual-HD Stick gekauft für DVB-C und brauchte dafür einen neuen Kernel. Gefunden habe ich nach diesem Beitrag diese Seite. Wie bekomme ich den installiert? Wenn ich die einzelnen Links aufmache finde ich dort jede Menge deb-Dateien, da sind 3mal linux-headers, 3mal linux-image und eine linux-firmware-hauppauge und eine linux-doc-mediatree. Kann ich die alle in ein Verzeichnis packen und mit dpkg -i *.deb installieren oder funktioniert das nicht mit den ganzen Dateien?

    Danke schon mal im voraus.


    Bye, Klaus

    ASRock H61M,Celeron 530, 4GB Kingston RAM, ASUS GT610, 750GB, Silverstone Milo ML3,CIR mit Harmony 300i, yaVDR 0.6, Sundtek MediaTV Digital Home (DVB-C)

  • Einfach das PPA hinzufügen (wie in https://launchpad.net/~b-rad/+…ernel+mediatree+hauppauge beschrieben) und dann die gewünschten Pakete installieren. Vorher am besten nachsehen, ob da irgendwelche dkms-Pakete installiert sind, die eventuell nicht mit dem neueren Kernel zurecht kommen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke dir schon mal. Wie überprüfe ich den die Sache mit den dkms-Paketen? Sorry, ich bin schon so lange raus mit dem ganzen selbst-bauen, ich nutze seit Jahren nur noch apt-get update und apt-get dist-upgrade.


    Bye, Klaus

    ASRock H61M,Celeron 530, 4GB Kingston RAM, ASUS GT610, 750GB, Silverstone Milo ML3,CIR mit Harmony 300i, yaVDR 0.6, Sundtek MediaTV Digital Home (DVB-C)

  • Wie überprüfe ich den die Sache mit den dkms-Paketen?

    dkm status - potentiell problematisch sind die DKMS-Pakete für die DVB-Treiber.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Da kommt nur:


    klaus@Diogenes:~$ dkms status

    nvidia-384, 384.130, 3.13.0-164-generic, x86_64: installed

    nvidia-384, 384.130, 3.13.0-165-generic, x86_64: installed

    klaus@Diogenes:~$


    Ich warte jetzt ab, bis die Aufnahmen für meine Frau durch sind und springe dann ins kalte Nass. Wenn ich mir etwas zerschieße, spiele ich das Backup wieder ein und installiere yavdr-ansible auf einer anderen Partition.


    Bye, Klaus


    Dein Engagement ist einfach der Wahnsinn hier!

    ASRock H61M,Celeron 530, 4GB Kingston RAM, ASUS GT610, 750GB, Silverstone Milo ML3,CIR mit Harmony 300i, yaVDR 0.6, Sundtek MediaTV Digital Home (DVB-C)

  • Hallo


    Jetzt habe ich die Pakete zusammen bekommen, dank Mango drüben von easyvdr. Wenn ich jetzt das eingebe:


    klaus@Diogenes:~$ sudo apt-get -f install linux-headers-4.4.0-141201901161620 linux-headers-4.4.0-141201901161620-generic linux-image-4.4.0-141201901161620-generic linux-image-extra-4.4.0-141201901161620-generic linux-firmware-hauppauge

    [sudo] password for klaus:

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Probieren Sie »apt-get -f install«, um dies zu korrigieren:

    Die folgenden Pakete haben unerfüllte Abhängigkeiten:

    linux-image-unsigned-4.19.0-041900-generic : Hängt ab von: linux-base (>= 4.5ubuntu1~16.04.1) soll aber nicht installiert werden

    Hängt ab von: linux-modules-4.19.0-041900-generic ist aber nicht installierbar

    E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

    klaus@Diogenes:~$


    Was hat es mit dem Paket linux-base von 4.5ubuntu auf sich?


    klaus@Diogenes:~$ sudo apt-cache search linux-base

    linux-base - Basispaket für alle Linux-Abbilder

    libzlcore-data - ZLibrary cross-platform development library (support files)

    libzlcore0.12 - ZLibrary cross-platform development library (shared library)

    lime-forensics-dkms - kernel module to memory dump (DKMS)

    esys-particle - Software for particle-based numerical modelling. MPI version.

    libzlcore-dev - ZLibrary cross-platform development library (development files)

    libzltext-data - ZLibrary text model/viewer part (support files)

    libzltext-dev - ZLibrary text model/viewer part (development files)

    libzltext0.12 - ZLibrary text model/viewer part (shared library)

    libzlui-gtk - GTK+ interface module for ZLibrary

    libzlui-qt4 - Qt4 interface module for ZLibrary

    klaus@Diogenes:~$


    Hat jemand eine Idee, was ich noch machen kann?


    Bye, Klaus

    ASRock H61M,Celeron 530, 4GB Kingston RAM, ASUS GT610, 750GB, Silverstone Milo ML3,CIR mit Harmony 300i, yaVDR 0.6, Sundtek MediaTV Digital Home (DVB-C)