0.6.2 2.Festplatte einbinden

  • Hallo,


    nachdem ich die letzten Jahre doch sehr zufrieden war mit meinem yavdr 0.5, war ich aufgrund von EOL der Meinung mal auf die neueste Version 0.6.2 upzudaten. Die Gelegenheit nutzte ich gleich zum Einbau und Installation auf SSD. Die "alte" Platte sollte weiter mit den vorhandenen Videos als Videoplatte dienen. Um sicherzustellen, dass das "alte" System erhalten bleibt, habe ich nur mit der SSD von USB installiert, Das hat auch funktioniert.

    blkid der SSD:

    Code
    1. yavdr@HTPC:~$ sudo blkid
    2. /dev/sdf1: UUID="702eccd0-fe1b-4585-8fde-db8bc80c94e6" TYPE="ext4"
    3. /dev/sdf5: UUID="b088e3bc-e6a3-470b-af89-b0af3ff4419a" TYPE="swap"

    die "alte":

    Code
    1. /dev/sda1: UUID="6642a0e1-3fea-454d-85c2-b7926631a6fd" TYPE="ext4"
    2. /dev/sda2: UUID="7e087f0a-81c2-4d70-812a-ec9d58de41b4" TYPE="ext4"
    3. /dev/sda3: UUID="291a96c9-7537-49fb-ba33-5aba23ab4322" TYPE="swap"

    "sda2" ist die "alte" Videopartition.

    Alles weitere hat soweit funktioniert, channels.conf. timer.conf umgezogen etc etc. alles i.o. FB und Imon gehen auch..............


    Aber ich bekomms nicht gebacken die "alte" Platte als Videoverzeichnis einzubinden.

    fstab (neues System):

    Code
    1. # <file system> <mount point> <type> <options> <dump> <pass>
    2. # / was on /dev/sdb1 during installation
    3. UUID=702eccd0-fe1b-4585-8fde-db8bc80c94e6 / ext4 errors=remount-ro 0 1
    4. # /srv was on /dev/sda2 during installation
    5. UUID=7e087f0a-81c2-4d70-812a-ec9d58de41b4 /srv/vdr/video.00/ ext4 defaults 0 2
    6. # swap was on /dev/sdb5 during installation
    7. UUID=b088e3bc-e6a3-470b-af89-b0af3ff4419a none swap sw 0 0

    das hier geht nicht, weil belegt.

    Code
    1. yavdr@HTPC:~$ sudo stop vdr
    2. vdr stop/waiting
    3. yavdr@HTPC:~$ sudo mv /srv/vdr/video.00 /srv/vdr/video
    4. mv: das Verschieben von »/srv/vdr/video.00" nach »/srv/vdr/video/video.00" ist nicht möglich: Das Gerät oder die Ressource ist belegt

    das hier hab ich ebenfalls alles probiert:

    Code
    1. yavdr@HTPC:~$ sudo ln -s /srv/vdr/video /srv/vdr/video.00
    2. ln: Die symbolische Verknüpfung »/srv/vdr/video.00/video" konnte nicht angelegt werden: Eingabe-/Ausgabefehler
    3. yavdr@HTPC:~$
    Code
    1. yavdr@HTPC:~$ sudo ls -all /srv/vdr/video.00/
    2. insgesamt 36
    3. drwxr-xr-x 5 root root 4096 Feb 5 11:46 .
    4. drwxr-xr-x 4 vdr vdr 4096 Feb 4 23:33 ..
    5. drwxrwxrwx 2 root root 20480 Jan 12 2017 picture
    6. drwxrwxrwx 2 root root 4096 Jun 4 2016 video
    7. drwxr-xr-x 6 root root 4096 Feb 4 21:59 video.00
    8. yavdr@HTPC:~$ sudo chown -R vdr.vdr /srv/vdr/video.00/

    Hab natürlich dazwischen auch nen reboot gemacht, komm aber nicht weiter. Wenn ich über "Aufnahmeverzeichnis neu einlesen" im Menü gehe, bekomme ich nur den freien Speicherplatz auf der SSD angezeigt, sonst nichts. Irgendwie fehlt da trotz allem noch ein Link oder so, aber ich komm nicht drauf

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.5
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • "sda2" ist die "alte" Videopartition.

    Kannst du mal die alte /etc/fstab zeigen? Die Berechtigungen sehen nicht so aus, als ob deren oberste Verzeichnisebene nach /srv/vdr/video.00/ gehört.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.5
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • Das sieht vernünftiger aus:

    Code
    1. UUID=7e087f0a-81c2-4d70-812a-ec9d58de41b4 /srv ext4 defaults 0 2

    Wenn du das in der neuen fstab eingetragen hast, musst du nach einem Reboot eigentlich nur noch den Symlink von /srv/vdr/video.00 nach /srv/vdr/video anlegen, damit der VDR sein Videoverzeichnis findet.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • "neue" fstab

    Code
    1. # <file system> <mount point> <type> <options> <dump> <pass>
    2. # / was on /dev/sdb1 during installation
    3. UUID=702eccd0-fe1b-4585-8fde-db8bc80c94e6 / ext4 errors=remount-ro 0 1
    4. # /srv was on /dev/sda2 during installation
    5. UUID=7e087f0a-81c2-4d70-812a-ec9d58de41b4 /srv ext4 defaults 0 2
    6. # swap was on /dev/sdb5 during installation
    7. UUID=b088e3bc-e6a3-470b-af89-b0af3ff4419a none swap sw 0 0
    8. ~

    und folgendes:

    Code
    1. yavdr@HTPC:~$ sudo ln -s /srv/vdr/video.00 /srv/vdr/video
    2. [sudo] password for yavdr:
    3. ln: Die symbolische Verknüpfung »/srv/vdr/video" konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
    4. yavdr@HTPC:~$ sudo ln -s /srv/vdr/video /srv/vdr/video.00
    5. ln: Die symbolische Verknüpfung »/srv/vdr/video.00" konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
    6. yavdr@HTPC:~$ sudo ls -all /srv/vdr/video
    7. ls: Zugriff auf /srv/vdr/video nicht möglich: Datei oder Verzeichnis nicht gefunden

    leider nein......................, im Gegenteil, Bildschirm schwarz, nur Mauszeiger. Vorher ging alles andere............

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.5
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • Zeig mal bitte wie das jetzt in /srv/video aussieht:

    Code
    1. cd /srv/vdr
    2. ls -l

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • uupsii...............

    Code
    1. yavdr@HTPC:~$ cd /srv/vdr
    2. -bash: cd: /srv/vdr: Datei oder Verzeichnis nicht gefunden
    3. yavdr@HTPC:~$ cd /srv
    4. yavdr@HTPC:/srv$ ls -l
    5. insgesamt 28
    6. drwxrwxrwx 2 vdr vdr 20480 Jan 12 2017 picture
    7. drwxrwxrwx 2 vdr vdr 4096 Jun 4 2016 video
    8. drwxr-xr-x 6 vdr vdr 4096 Feb 4 21:59 video.00
    9. yavdr@HTPC:/srv$

    ich kapier grad gar nix mehr, /srv/vdr/ und /srv/vdr/video ware n "mal" vorhanden, definitiv

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.5
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • Dann schau doch als erstes, ob deine Aufnahmen in /srv/video oder /srv/video.00 liegen. Dann erstellst du ein Verzeichnis /srv/vdr/ und verschiebst den Ordner mit dem alten Aufnahmeverzeichnis nach /srv/vdr/video. Zum Schluss legst du noch einen Symlink /srv/vdr/video.00 an, der auf /srv/vdr/video zeigt. Dann den Rechner einmal neu starten.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • fstab ändern oder bleibt die so

    Code
    1. UUID=7e087f0a-81c2-4d70-812a-ec9d58de41b4 /srv

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.5
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • hier hab ich dann die Videos gefunden, was ein P....:


    Code
    1. yavdr@HTPC:/srv/video.00/vdr/video.00$ dir

    Frag mich bitte nicht, wie dieses Durcheinander entstanden ist. Wenn ichs wüsste, hätte ich hier vermutlich nicht fragen müssen............

    Das hab ich dann gemacht:

    Code
    1. yavdr@HTPC:~$ sudo mv /srv/video.00/vdr/video.00 /srv/vdr/video
    2. yavdr@HTPC:~$ cd /srv/vdr/video
    3. yavdr@HTPC:/srv/vdr/video$ dir
    4. 3_Days_to_Kill.......................

    so weit so gut.

    Dann den Link:

    Code
    1. yavdr@HTPC:~$ sudo ln -s /srv/vdr/video /srv/vdr/video.00
    2. yavdr@HTPC:~$

    und die Rechte:

    Code
    1. yavdr@HTPC:~$ sudo chown -R vdr.vdr /srv/vdr/video.00/

    reboot gemacht, und jieiepyeah hurrei, es geht! DANKE!!!!:):thumbup: Disk72%-47:51 frei

    HTPC: Selfmade Woodcase, semipassiv
    GIGABYTE GA-P965-DS4, Intel E8400 2x3,0Ghz, 2x2GB DDRII-800, Pallit Nvidia GT520
    1x DigitalDevices Cine S2 Dual Tuner, LCD iMON Ultrabay mit RM200
    Blu-Ray Combo Drive SATA LiteOn IHES112-115
    yaVDR 0.5
    TV: Panasonic TX-P50GT30E
    Sound: Logitech Z-5500

  • Hallo Zusammen.

    Ich hatte wie hier beschrieben das gleiche Problem. Die hier beschriebene Lösung hatte bei mir nicht ganz geholfen, weshalb ich euch meine abgeänderte Version auch noch beschreiben möchte für den Fall das jemand ähnliche Probleme hat.


    1. Man findet heraus welche UUID die Festplatte besitzt und trägt sie in die /etc/fstab ein.

    Hier entsteht schon das erte Hürde. Zu Problemen führt es wenn man wie ganz am Anfang beschrieben

    Code
    1. UUID=b9dc1637-5712-49cb-8f06-e4cef3684b40 /srv/vdr/video.00 xfs defaults 0 0

    als Pfad verwendet. Da wir die alten Filme später im Pfad


    /srv/vdr/video benötigen wäre vorerst dieser Eintrag zu bevorzugen (Link des alten Video- Ordners auf /srv daraus folgt => Ordern der Installation wird ausgehebelt):


    Code
    1. UUID=b9dc1637-5712-49cb-8f06-e4cef3684b40 /srv xfs defaults 0 0

    2. Anschließen sollte sich alle Filme nach einem Neustart unter /srv auffinden lassen.

    Es kann sein das der VDR nach einem Neustart dunkel bleibt, da ihm den Ordner /srv/vdr/video durch die neue Zuordnung von /srv noch fehlt. Ich habe als nächstes die benötigte Ordnerstruktur angelegt:

    Code
    1. mkdir /srv/vdr
    2. mkdir /srv/vdr/video

    3. Alles aus dem alten Verzeichnis ins neu Video-Verzeichnis verschieben


    Code
    1. cp /srv/* /srv/vdr/video


    4. Rechte sicherheitshalber neu setzen und ein neustarten ist nie verkehrt:


    Code
    1. chown -R vdr.vdr /srv/vdr/video.00/
    2. reboot


    Ein Link war nicht mehr nötig.


    Gruß

    VDR_1:

    Asus J3455-M, GT 710, SSD 240GB, 8GB DDR3, 1x DvbSky S950 with yavdr-ansible (testing)

    VDR_2:

    AsRock J3455, GT 710, SSD 120GB + SATA 400GB, 8GB DDR3, 1x DvbSky S952 with yavdr-ansible (testing)

  • Ich muss mich auch an dieses Thema anhängen, weil ich auch Probleme bei den Aufnahmen habe.

    Zur Erklärung: habe eine Server/Client Konfiguration. Die Aufnahmen sollen generell auf dem Server erfolgen.

    Die fstab:

    Die beiden xfs formatierten Platten sind eine je 3 und 4 Tb grosse Platten, die der Aufnahm dienen sollen. Da die kleinere Platte voll ist, habe ich

    die neue hinzugefügt.

    Die Festplatteninfo zeigt folgendes:

    Allerdings landen keine Aufnahmen auf sdb1.


    Irgendwie blicke ich nicht mehr durch und könnte ein paar Tips brauchen.


    Gruss Willi

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • da habe ich das testhalber hinverlinkt

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • Was ist die "richtige" Stelle

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • so ist es nach umount:

    /dev/sdc1 2,8T 2,6T 163G 95% /srv/vdr/video.01
    /dev/sdb1 3,7T 34M 3,7T 1% /srv/vdr/video.02
    /srv/vdr/video.02;/srv/vdr/video.01;/srv/vdr/video.00 6,5T 2,6T 3,9T 41% /srv/share/vdr


    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • Der VDR 2.2.0 unterstützt von sich aus nicht mehr das Verteilen von Aufnahmen auf mehrere Aufnahmeverzeichnisse.

    Es gibt von SHF das vdr-plugin-distributedvideodir, das das Problem löst. Du mus dann zusätzlich zur Installation des Plugins noch festlegen, dass das Aufnahmeverzeichnis /srv/vdr/video.00 statt dem standardmäßig genutzten /srv/vdr/video ist (es sollte ein Symlink von dem einen Pfad auf den anderen existieren), also so eine Zeile einfügen:

    Code: /etc/vdr/conf.d/01-vdr-videodir.conf
    1. [vdr]
    2. --video=/srv/vdr/video.00

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Verstehe ich das richtig, dieses Pluginverteilt die Aufnahmen auf verschiedene Platten?

    Das wollte ich eigentlich nicht. sdb1 ist die neue Platte, und soll generell die Aufnahmeplatte sein. sdc1 ist voll mit Filmen und

    sollte eigentlich als so eine Art Unterordner fungieren, nur wie?

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • Das wollte ich eigentlich nicht. sdb1 ist die neue Platte, und soll generell die Aufnahmeplatte sein. sdc1 ist voll mit Filmen und

    sollte eigentlich als so eine Art Unterordner fungieren, nur wie?

    Es gibt die Möglichkeit neben einem Hauptverzeichnis weitere Verzeichnisse ohne sichbare erste Ordnerebene einzubinden, vgl. https://www.yavdr.org/document…rst_recording_level_patch


    Dazu müsste das Videoverzeichnis auf sdb1 als /srv/vdr/video/local gemountet werden und der Rest in anderen Ordnern im Pfad /srv/vdr/video/

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)