ppa, Abhängigkeiten sind nicht erfüllt, aber warum?

  • Hallo,


    ich versuche gerade, ein PPA zu erstellen: https://launchpad.net/~markus-…archive/ubuntu/stable-vdr .

    vdr-plugin-softhddevice baut nicht :( .

    Fehler: "sbuild-build-depends-vdr-plugin-softhddevice-dummy : Depends: libavcodec-ffmpeg-opti-dev but it is not going to be installed".


    Ich habe aber im gleichen PPA ffmpeg erfolgreich gebaut. Und bei ffmpeg wird angezeigt:


    Code
    1. Built packages
    2. ...
    3. libavcodec-ffmpeg-opti-dev development files for libavcodec


    Und weiter unten:


    Code
    1. Package files
    2. ...
    3. libavcodec-ffmpeg-opti-dev_2.7.2-0mavdr1_amd64.deb (4.3 MiB)


    Er müsste also nur dieses Paket installieren, dann wäre die Abhängigkeit erfüllt.

    Warum macht er das nicht? Bzw. was muss ich tun, damit er das macht?


    ~ Markus

    VDR1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Xubuntu 18.04, VDR 2.4x
    VDR2: ASUS P4B533, Celeron 2.4G, FF 1.5, Ubuntu 10.10, VDR 1.6 (SS2 Rev 2.6B)
    VDR Server: sheeva-plug

  • Ich habe den Fehler jetzt gefunden.

    ffmpeg selbst konnte aufgrund von falsch gepflegten Abhängigkeiten nicht installiert werden

    VDR1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Xubuntu 18.04, VDR 2.4x
    VDR2: ASUS P4B533, Celeron 2.4G, FF 1.5, Ubuntu 10.10, VDR 1.6 (SS2 Rev 2.6B)
    VDR Server: sheeva-plug