keine Ausgabe mehr über das vdr-softhddevice Plugin

  • Hallo,


    Seit Samstag habe ich ein Problem mit dem VDR-2.4.0 unter Fedora 29, ich bekomme einfach keine Ausgabe mehr über das vdr-softhddevice Plugin, das softhddevice Fenster bleibt schwarz.

    Die DVB-Treiber für die TT6400-S2 sind korrekt geladen, da ich ansonsten an meinem Monitor auf HDMI-2 kein Bild hätte.


    Die Logmeldungen sehen glaube ich in Ordnung aus:

    Aufruf mit dem softhddevice Plugin lautet:

    Code
    1. /usr/sbin/vdr -v /video -D0 -u vdr -p 6419 --plugin='dvbhddevice' --plugin='dvbsddevice' --plugin='softhddevice -g 1680x1050 -a hw:0,0 -d :1.0 -v vdpau'

    Hat jemand eine Idee ?

    Gruß MartinKG

    Fedora33 x86_64 Gnome Desktop vdr 2.4.4 mit vdr-softhddevice plugin.

    ViewSonic VX3276 HDMI-1 <------------> HDMI NVidia Geforce-gt-1030

    ViewSonic VX3276 HDMI-2 <------------> HDMI Technotrend S2-6400

  • Hallo,


    --plugin='dvbsddevice'

    mit der TT-6400 brauchst du dieses Plugin nicht.(ist für SD FF)


    Gruss

    Wolfgang

    TT S2-6400 - saa716x kompilieren unter 20.04(Focal)

  • mach aber auch keinen Unterschied beim Fehlerbild.

    Gruß MartinKG

    Fedora33 x86_64 Gnome Desktop vdr 2.4.4 mit vdr-softhddevice plugin.

    ViewSonic VX3276 HDMI-1 <------------> HDMI NVidia Geforce-gt-1030

    ViewSonic VX3276 HDMI-2 <------------> HDMI Technotrend S2-6400

  • Die DVB-Treiber für die TT6400-S2 sind korrekt geladen, da ich ansonsten an meinem Monitor auf HDMI-2 kein Bild hätte.

    Eine gleichzeitige Ausgabe über zwei Ausgabeplugins geht nicht - du müsstest dann jeweils das primary device umschalten bzw. in den Einstellungen von softhddevice festlegen, dass es sich automatisch zum primary device macht, wenn es attached wird (was laut Log aktuell nicht der Fall ist:

    Die Logmeldungen sehen glaube ich in Ordnung aus:

    Code
    1. [martin@fc29 ~]$ journalctl -xe
    2. [...]
    3. Nov 11 14:28:55 fc29 vdr[3989]: [3989] setting primary device to 1
    4. [...]
    5. Nov 11 14:28:55 fc29 vdr[3989]: [3989] [softhddev] softhddevice 1 is not the primary device!

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Eine gleichzeitige Ausgabe über zwei Ausgabeplugins geht nicht - du müsstest dann jeweils das primary device umschalten bzw. in den Einstellungen von softhddevice festlegen, dass es sich automatisch zum primary device macht, wenn es attached wird (was laut Log aktuell nicht der Fall ist:

    nachdem ich in der /etc/vdr/setup.conf
    softhddevice.MakePrimary = 1 eingestellt hatte, ging es.


    Vielen, Dank :tup

    Gruß MartinKG

    Fedora33 x86_64 Gnome Desktop vdr 2.4.4 mit vdr-softhddevice plugin.

    ViewSonic VX3276 HDMI-1 <------------> HDMI NVidia Geforce-gt-1030

    ViewSonic VX3276 HDMI-2 <------------> HDMI Technotrend S2-6400

  • Jetzt habe ich nur noch eine Meldung, wenn ich das nopacity plugin mit rein nehme:


    Code
    1. nopacity: No TrueColor OSD found! Aborting!



    Wie kann ich das noch beseitigen ?

    Gruß MartinKG

    Fedora33 x86_64 Gnome Desktop vdr 2.4.4 mit vdr-softhddevice plugin.

    ViewSonic VX3276 HDMI-1 <------------> HDMI NVidia Geforce-gt-1030

    ViewSonic VX3276 HDMI-2 <------------> HDMI Technotrend S2-6400

  • Du willst mit Grafikkarte ausgeben, richtig? Warum lädst du dann dvbhddevice?

    Ich möchte auf dem Gnome Desktop über die Grafikkarte mit Hilfe des softhddevice Plugin ausgeben und wenn ich nur TV schauen möchte, schalte ich auf HDMI-2 um. Das ging ja seither auch immer.


    Gruß MartinKG

    Fedora33 x86_64 Gnome Desktop vdr 2.4.4 mit vdr-softhddevice plugin.

    ViewSonic VX3276 HDMI-1 <------------> HDMI NVidia Geforce-gt-1030

    ViewSonic VX3276 HDMI-2 <------------> HDMI Technotrend S2-6400

    The post was edited 1 time, last by MartinKG ().

  • Wie kann ich das noch beseitigen ?

    Da sollte es eine Option in den Einstellungen von dvbhddevice für die Unterstützung von TrueColor geben - hast du schon versucht dvbhddevice.TrueColorOsd = 1 zu setzen?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Da sollte es eine Option in den Einstellungen von dvbhddevice für die Unterstützung von TrueColor geben - hast du schon versucht dvbhddevice.TrueColorOsd = 1 zu setzen?

    Habe jetzt den skinnopacity wieder am Laufen, weis jetzt nicht genau was ich geändert habe.

    Die Logmeldungen passen wieder.


    In der setup.conf hatte ich auf jeden Fall dvbhddevice.TrueColorOsd = 0 ungeändert belassen.

    Files

    Gruß MartinKG

    Fedora33 x86_64 Gnome Desktop vdr 2.4.4 mit vdr-softhddevice plugin.

    ViewSonic VX3276 HDMI-1 <------------> HDMI NVidia Geforce-gt-1030

    ViewSonic VX3276 HDMI-2 <------------> HDMI Technotrend S2-6400