[NAS-NFS] Wartezeit, wenn das Aufzeichnungs-Menu geöffnet wird (kein OSD), welches per NFS gemountet wird...

  • Hallo zusammen,


    ich nutze aktuell vdr-2.4.0. Das Videoverzeichnis ist per NAS-NFS eingebunden.
    Alles funktioniert hier seit längerer Zeit sehr zuverlässig mit einem einfachen WD-4TB-NAS.

    Nach einiger Zeit „VDR-Nutzung“, geht die NAS-HDD in den Sleep Modus. Wenn ich nun das Aufzeichnungs-Menu öffnen möchte, dauert es ein kleine Weile (2 Sekunden), bis VDR dieses Menu anzeigt.

    Dadurch das diese Menu nicht sofort angezeigt wird, weiß man halt nicht, ob die (richtige) Taste gedrückt wurde oder nicht und drückt nochmal diese Keymacros-Taste für das Aufzeichnungs-Menu ....


    Könnte dieses „Problem“ daher kommen, wie das NFS-Videoverzeichnisses gemountet wird (Optionen...). Die NFS-HDD mounte ich mit folgendem Befehl (aus der fstab) ein:
    Code
    1. 192.168.119.222:/nfs/video /srv/vdr/video nfs rw,relatime,vers=3,soft,nolock,proto=tcp,timeo=600 0 0

    Kennt jemand dieses Problem?

    Hat jemand vielleicht einen Tipp? Liegt der Fehler vielleicht wo anders?

    Passiert das mit einer lokalen HDD auch, wenn diese im Sleep Modus ist?


    Gruß

    Uwe

  • Moin,

    das ist kein Fehler.

    Ich möchte auch nicht das der NAS in den Sleep-Modus geht solange der VDR dran hängt. Da es sonst beim Zugriff auf Aufnahmen es zu nervigen Verzögerungen kommt. Wenn der VDR allerdings abgeschaltet wird dann soll der NAS irgendwann sehr wohl in den Sleep-Modus gehen.

    Ich habe das so gelöst, dass per cronjob alle paar Minuten auf den NAS zugegriffen wird. Aufnahmen durchsuchen oder so. Dadurch wird der Sleep-Modus verhindert, dadurch das der NAS immer wieder kurz beschäftigt wird.

  • Hallo mamomoz,


    Danke für deine Info. Vielleicht hat jemand noch einen anderen Tipp?


    Gruß

    Uwe

  • Sämtliche Stromspar-Mechanismen abschalten?


    Dann würde die Platte allerdings dauernd rödeln...ob das nun gut ist für ne Platte ob sie 24/7 läuft oder in den Sleep-Modus geht liegt wohl ehr an dem eingesetztem Typ.


    Die Frage sollte also ehr lauten : Was kann / können deine eingebauten(n) Platte(n) ?


    Ich kenne das Problem ebenso mit den 2 Sekunden Wartezeit (es können auch 3 sein oder mehr, keine Ahnung), für mich ist es aber ehr "who cares" und die Family weiß auch Bescheid...


    Mamomoz's Idee könnte ich auch mal umsetzen. Wenn ich nicht viel zu faul wäre. Wegen 3 Sekunden ;)

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • Spielt da eventuell noch das extremenu-Plugin mit hinein? Sonst lesen soweit ich das im Kopf habe z.B. noch der skindesigner bzw. scraper2vdr Metadaten aus dem Aufnahmeverzeichnis, um Bildchen anzuzeigen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • kls Ich nutze den Skin: skinnopacity, ich werde mal den Standardskin testen...

    seahawk1986 Das extrecmenu-Plugin nutze ich nicht. Aber das skinnopacity Plugin sucht auch nach Bilder in dem Aufzeichnungsverzeichnis... wobei ich keine Bilder in dem Aufzeichnungsverzeichnis habe. ...

  • kls Die Wartezeit habe ich auch mit dem LARS-Skin.

  • Dann bleibt wohl nur noch, an verschiedenen Stellen Ausgaben einzubauen und zu schauen, wo genau eine längere Pause entsteht. Auf diese Weise müsste es möglich sein herauszufinden, wo die Zeit verbraucht wird.


    Klaus

  • Ich kann das gerne testen. :)

  • Hi,

    ich habe auch ein "ähnliches" Problem. Seitdem ich (beim VDR 2.2) mein 6TB Video Laufwerk gegen ein 12TB Laufwerk ersetzt habe, dauert das öffnen des Aufnahme Verzeichnisses einige Sekunden (beim ersten öffnen des Aufnahme Menüs am Tag). Vorher ging das sofort auf. Die Aufnahmen habe ich nur auf die neue Platte kopiert. Die Platte ist auch nicht im Schlaf Modus, da das Problem auch auftritt wenn gerade eine Aufnahme läuft. Allerdings verwende ich das extrecmenu Plugin.

    Ich weiß nicht ob das eine ähnlich Ursache hat und wollte das nur zum Erweitern der "Datenbasis" kundtun.


    Grundsätzlich würde ich mir wünschen, dass im Fall einer langsamen HDD (falls das die Ursache ist) , das Menü sofort aufgeht und eine "Bitte warten" anzeige erscheint bis die Daten bereitstehen. Aber wie gesagt, bis zu meinem HDD Tausch kannte ich so eine verzögerte Reaktion überhaupt nicht und hab auch noch keine Ursachenforschung betrieben, da bisher immer nur meine Frau betroffen war :)

    MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
    WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
    MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
    MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD

  • clausmuus Ich nehme mal an, dass sich die Anzahl der Aufnahmen durch den Plattenwechsel nicht gleichzeitig dramatisch vergrößert hat, oder? Wenn sich aber ausser der Platte nichts geändert hat (gleiche VDR-Version?), und es vorher schnell ging und jetzt langsam, was kann dann daran Schuld sein?


    Uwe Nur zur Sicherheit: ich gehe davon aus, dass *du* solche Ausgaben einbaust - nicht dass du darauf wartest, dass ich das tue ;-).


    Klaus

  • Hallo,

    dann gebe ich auch mal meinen Senf dazu .

    Es ist bei mir genau so wie bei den anderen, es dauert auch 2-3 Sekunden bis ich das Aufnahmemenu sich öffnet.

    Habe das allerdings nie als wirklich störend empfunden.

    Meine Aufnahmen liegen auf einem Freenas mit Raid5 und 12TB Größe.

    speed

  • kls Ich wüsste jetzt nicht, wie/wo man weitere Ausgaben einbauen kann, um herauszufinden, wo es hakt....

  • kls ,

    ja, Deine Annahmen sind richtig. Es hat sich lediglich die HDD Hardware für die Daten geändert. Alles andere ist identisch wie vorher. Und ich gehe auch einfach mal davon aus, dass die neue doppelt so große Platte nicht langsamer als die alte ist, sondern höchstens schneller. Ich habe also bisher keine Idee, wieso das öffnen des Aufnahme Menüs jetzt spürbar länger dauert.

    MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
    WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
    MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
    MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD