SkinflatPlus verhindert VDR Start bei SHD mit OPENGLOSD

  • Moin!


    Mein Lieblingsskin verweigert leider die Mitarbeit seitdem ich softhddevice/softhdcuvid mit OPENGLOSD verwende. Ist der Plugin aktiviert startet der VDR erst gar nicht, hab ich hier auch kurz beschrieben. Andere Skins (LCARS, EnigmaNG, Designer) laufen ohne zu mucken. Hab nur ich das Problem, bzw. hat das überhaupt irgendjemand am Laufen??


    Lars

    Asus H170 PRO GAMING, Intel Core i7-6700T, 16GB RAM, GeForce GTX 1050 2GB, Samsung SSD 860 EVO 1TB SSD + 3TB WD Red, Mystique SaTiX-S2 Dual, Archlinux -> VDR4Arch


    "Freunde sind Menschen, die dich mögen obwohl sie dich kennen"

  • Hallo,


    ich selbst nutze das OPENGLOSD nicht und kann dazu auch nicht wirklich etwas sagen. Ich wüsste auch nicht was der Skin hier extra unterstützen muss.

    Laut der Ankündigung von Louis damals soll auch jeder Skin funktionieren:

    softhddevice mit High Level OSD


    Wird denn ein Backtrace geschrieben der vielleicht etwas mehr aufschluss gibt?


    Grüße

    Maritn

  • Hab nur ich das Problem, bzw. hat das überhaupt irgendjemand am Laufen??

    Ich kann das Problem mit softhdcuvid nachvollziehen, wenn ich skinflatplus vor dem Ausgabeplugin laden lasse. Ich habe dem Plugin probehalber mal mit vdrctl die Priorität 99 gegeben (damit wird es als letztes geladen), dann startet der VDR klaglos.


    Der Skindesigner hat einen Fallback für den Fall, dass der osd-Provider beim Start kein TrueColor-OSD unterstützt: https://projects.vdr-developer…/tree/skindesigner.c#n112, so dass der VDR in dem Fall zumindest starten kann. Ich frage mich gerade, ob bei dem Skin durch das Initialisieren der Bibliotheken vor der TrueColorOSD-Abfrage den Start zufällig ausreichend lange verzögert wird, bis das Ausgabe-Plugin initialisiert wurde.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Ich hab das nie verstanden, wieso ein skin, der in meinen Augen für den Betrieb des VDR relativ unwichtig ist, den Start verhindert und damit Aufzeichnungen verhindert. Richtiger wäre es auf LCARS umzuschalten.


    vdr-User-# 755 to_h264 chk_r vdr-transcode

  • Moin moin,


    da die Kiste einfach hängen bleibt gibts leider kein Backtrace. Kann ich denn sonst irgendwas beisteuern,testen,...?


    Ich frage mich gerade, ob bei dem Skin durch das Initialisieren der Bibliotheken vor der TrueColorOSD-Abfrage den Start zufällig ausreichend lange verzögert wird, bis das Ausgabe-Plugin initialisiert wurde.

    Iss das evtl. schon die richtige Richtung...?

    Asus H170 PRO GAMING, Intel Core i7-6700T, 16GB RAM, GeForce GTX 1050 2GB, Samsung SSD 860 EVO 1TB SSD + 3TB WD Red, Mystique SaTiX-S2 Dual, Archlinux -> VDR4Arch


    "Freunde sind Menschen, die dich mögen obwohl sie dich kennen"

  • Kann ich denn sonst irgendwas beisteuern,testen,...?

    Reihenfolge der Plugins so geändert, dass skinflatplus als letztes geladen wird?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Reihenfolge der Plugins so geändert, dass skinflatplus als letztes geladen wird?

    Ja, dann fliegt der VDR bei Start ab :/

    Asus H170 PRO GAMING, Intel Core i7-6700T, 16GB RAM, GeForce GTX 1050 2GB, Samsung SSD 860 EVO 1TB SSD + 3TB WD Red, Mystique SaTiX-S2 Dual, Archlinux -> VDR4Arch


    "Freunde sind Menschen, die dich mögen obwohl sie dich kennen"

  • Von einem Segfault sollte man einen Backtrace einsammeln können. Der Logauszug ist zu sehr beschnitten um den Gesamtzusammenhang zu sehen, aber das sieht fast so aus, als würdest du softhddevice-openglosd detached starten lassen und skinflatplus stolpert dann eventuell darüber, dass es Dinge anzeigen will, während nur das Dummy-OSD zur Verfügung steht.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • als würdest du softhddevice-openglosd detached starten lassen

    Jepp so ist es!


    Code
    1. Thread 1 "vdr" received signal SIGSEGV, Segmentation fault.
    2. 0x00007fffddda67c3 in cFlatBaseRender::TopBarCreate() () from /usr/lib/vdr/plugins/libvdr-skinflatplus.so.2.4.0
    3. (gdb) bt full
    4. #0 0x00007fffddda67c3 in cFlatBaseRender::TopBarCreate() () at /usr/lib/vdr/plugins/libvdr-skinflatplus.so.2.4.0
    5. #1 0x00007fffddddae8f in cFlatDisplayMenu::cFlatDisplayMenu() () at /usr/lib/vdr/plugins/libvdr-skinflatplus.so.2.4.0
    6. #2 0x00007fffddd9d4fb in cImageCache::PreLoadImage() () at /usr/lib/vdr/plugins/libvdr-skinflatplus.so.2.4.0
    7. #3 0x00007fffddde6ab8 in cPluginFlat::Start() () at /usr/lib/vdr/plugins/libvdr-skinflatplus.so.2.4.0
    8. #4 0x0000555555673e14 in cPluginManager::StartPlugins() ()
    9. #5 0x00005555555f2831 in main ()

    Asus H170 PRO GAMING, Intel Core i7-6700T, 16GB RAM, GeForce GTX 1050 2GB, Samsung SSD 860 EVO 1TB SSD + 3TB WD Red, Mystique SaTiX-S2 Dual, Archlinux -> VDR4Arch


    "Freunde sind Menschen, die dich mögen obwohl sie dich kennen"

  • zwei Jahre später... und ich habe das gleiche Problem.


    Test 1:

    Starte ich erst skinflatplus und danach softhddevice (aktuelles git von lnj) mit openglosd und cuvid , startet vdr mit TV-Bild, hat jedoch kein OSD und ist unbedienbar. Der per ssh in einem Terminal gestartete Prozess lässt sich nicht beenden, ich muss vdr in einer zweiten Konsole killen.


    Test 2:

    Starte ich erst softhddevice (mit cuvid und openglosd) und danach skinflatplus, kommt weder Bild noch OSD.


    Test 3:

    Starte ich erst softhddevice (mit vdpau und openglosd) und danach skinflatplus, ist es wie bei Test 1.


    Mit deaktiviertem openglosd funktioniert der Skin einwandfrei.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!