Einschalten der Soundbar beim Start vom VDR verhindern

  • Hallo,


    ich brauche mal einen Denkanstoß für folgendes Problem.


    Mein neues Mainboard, vom VDR-Server aus der Signatur, hat nun leider nur noch einen HDMI-Ausgang und keinen separaten SPDIF-Ausgang mehr den ich mit meinem AV-Receiver verbinden könnte. Mein AV-Receiver unterstütz keine UHD-Auflösung, ich kann diesen also nicht direkt mit dem HDMI-Ausgang des Boards und die Soundbar über ARC mit dem TV verbinden. So hatte es mit meinem alten Board (was jetzt im Clienten gelandet ist) funktioniert. Deshalb habe ich mich für die Installation eines HDMI-Switches mit Audio-Extractor entschieden. Der Switch hat einen optischen und einen analogen Ausgang, ARC vom TV zur Soundbar funktioniert bei Verwendung des Switches leider nicht mehr. Ich habe deshalb nun den optischen Ausgang mit meinem AV-Receiver, und den Analogen über Chinch mit meiner Soundbar verbunden. Das funktioniert auch soweit allerdings mit dem Nachteil, dass meine Soundbar immer einschaltet sobald der VDR startet und ein Audiosignal anliegt. Das ist grundsätzlich ja recht angenehm aber nicht, wenn dieser Nachts oder niemand zuhause ist, für eine Aufnahme startet. :wow Grundsätzlich möchte ich bevorzugt aus der Soundbar den Ton haben, und den AV-Receiver nur optional einschalten !


    Meine Überlegungen/Versuche bisher:


    Den VDR auf einen Kanal starten auf dem nichts mehr gesendet wird (Obsolete) ? Habe ich gemacht, da der Bildschirm dabei aber auch schwarz bleibt erkennt man so nicht, ob der VDR eingeschaltet ist oder nicht.


    Den VDR mit Volume 0 starten ? Dann hätte ich ein Bild und müsste den Ton wieder aktivieren. Problem hier, meine One4All steuert über die Lautstärketasten die Soundbar nicht den VDR ( Alsa? ). Ich müsste hier also irgenwelche Tasten umbelegen um den Ton wieder aktivieren zu können.


    Wie könnte ich das Problem am elegantesten lösen, auch so, dass die Frau damit zurecht kommt ^^ ?



    Gruss


    Stefan

    Server: VDR 2.4.0 mit Ubuntu 18.04 x64 mit vaapidevice, Kernel 4.19.0 rc2, ASRock J4105M, 2 x 4096 MB DDR4-RAM, 2 x Technotrend S2-1600, 2 x DD Cine S2, Lirc-Serial mit One4All URC 7960
    Client: VDR 2.4.0 mit Ubuntu 18.04 x64 mit KODI+vnsiserver, Kernel 4.18.12, ASRock H81M, Intel i3-4150, NVIDIA GPU GeForce GT 610 (GF119), 2 x 2048 MB DDR2-RAM, 1 x Technotrend S2-1600, SilverStone Milo ML03, ASRock Smart Remote CIR mit Logitech Harmony 650, Beamer 120'' FullHD-3D

  • Kann man die Soundbar so einstellen, daß sie nicht aus dem Standby aufwacht, wenn Ton anliegt?

    Kann man die ausschalten und über die One4All mit anschalten?


    Alternativ: per Script dem vdr nach dem Start ein Mute schicken. Dann per Script prüfen, ob der TV auch an ist (HDMI, ping, irgendwas) und ein Un-Mute schicken. Weiß nicht, ob das funktioniert. Ich brainstorme.


    Christian

  • wenn dun gescheiten AVT hast: den einfach immer nehmen - funktioniert seit Jahren großartig!

    CKone: yavdr-ansible/18.04 LTS/2.4.0/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.0/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.0 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD Red WD30EFRX 3TB in SW Raid5

  • Hi,


    nein die Soundbar kann man nicht einstellen, das wäre ja sonst zu einfach. ;) Ausschalten kann ich sie zwar, solange Ton anliegt geht sie aber immer wieder an. Ich kann den Ton an der Soundbar dann nur muten oder auf 0 runter drehen. Aber das muss ich ja manuell machen, das geht ja nicht irgenwie automatisiert.


    Mit einem Script den VDR muten ist eigentlich garnicht nötig, weil ich unter Einstellungen/Sonstiges die Möglichkeit habe die Startlautstärke vorzugeben. Da könnte ich ja 0 einstellen. Dann habe ich aber das oben genannte Problem, nämlich den Ton wieder komfortabel und Frauentauglich einzuschalten.


    wenn dun gescheiten AVT hast: den einfach immer nehmen - funktioniert seit Jahren großartig!

    Was ist ein AVT ? Meinst du AV-Receiver ?

    Server: VDR 2.4.0 mit Ubuntu 18.04 x64 mit vaapidevice, Kernel 4.19.0 rc2, ASRock J4105M, 2 x 4096 MB DDR4-RAM, 2 x Technotrend S2-1600, 2 x DD Cine S2, Lirc-Serial mit One4All URC 7960
    Client: VDR 2.4.0 mit Ubuntu 18.04 x64 mit KODI+vnsiserver, Kernel 4.18.12, ASRock H81M, Intel i3-4150, NVIDIA GPU GeForce GT 610 (GF119), 2 x 2048 MB DDR2-RAM, 1 x Technotrend S2-1600, SilverStone Milo ML03, ASRock Smart Remote CIR mit Logitech Harmony 650, Beamer 120'' FullHD-3D

  • ja, fingertrouble: AVR

    CKone: yavdr-ansible/18.04 LTS/2.4.0/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.0/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.0 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD Red WD30EFRX 3TB in SW Raid5

  • Ja das könnte ich machen, der AVR ist ein Yamaha RX-V 2067, aber hinsichtlich Stromverbrauch und zum gucken von Nachrichten/Reportagen fand ich das immer wie mit Kanonen auf Spatzen zu schiessen. Eigentlich reicht mir dazu der Ton der Soundbar .


    Die Idee von hopsi , über HDMI zu prüfen ob der TV an ist finde ich gut. Geht das irgendwie ? Dann könnte ich davon abhängig ja den VDR muten/unmuten.

    Server: VDR 2.4.0 mit Ubuntu 18.04 x64 mit vaapidevice, Kernel 4.19.0 rc2, ASRock J4105M, 2 x 4096 MB DDR4-RAM, 2 x Technotrend S2-1600, 2 x DD Cine S2, Lirc-Serial mit One4All URC 7960
    Client: VDR 2.4.0 mit Ubuntu 18.04 x64 mit KODI+vnsiserver, Kernel 4.18.12, ASRock H81M, Intel i3-4150, NVIDIA GPU GeForce GT 610 (GF119), 2 x 2048 MB DDR2-RAM, 1 x Technotrend S2-1600, SilverStone Milo ML03, ASRock Smart Remote CIR mit Logitech Harmony 650, Beamer 120'' FullHD-3D

  • Den VDR auf einen Kanal starten auf dem nichts mehr gesendet wird (Obsolete)

    nimm doch einen Hinweistafel Sender ohne Ton. Davon gibt es jede Menge auf Astra und Hotbird

    Ich habe gerade mal durch gezappt und bin dabei über Astra auf "SES 75" gekommen. Der hat nur ein großes HD+ Zeichen s/w --> https://en.kingofsat.net/find.php?question=ses+75 und ist stumm

  • Unter xrandr und mit


    Code
    1. cat /sys/class/drm/card0/*HDMI*/status

    wird mir der TV immer als connected angezeigt egal ob ich ihn bei laufendem VDR Ein- oder Ausschalte.


    Ich starte den VDR allerdings auch mittels Kernelparameter mit einer edid.bin. Keine Ahnung ob das auch irgendwie relevant ist.

    Server: VDR 2.4.0 mit Ubuntu 18.04 x64 mit vaapidevice, Kernel 4.19.0 rc2, ASRock J4105M, 2 x 4096 MB DDR4-RAM, 2 x Technotrend S2-1600, 2 x DD Cine S2, Lirc-Serial mit One4All URC 7960
    Client: VDR 2.4.0 mit Ubuntu 18.04 x64 mit KODI+vnsiserver, Kernel 4.18.12, ASRock H81M, Intel i3-4150, NVIDIA GPU GeForce GT 610 (GF119), 2 x 2048 MB DDR2-RAM, 1 x Technotrend S2-1600, SilverStone Milo ML03, ASRock Smart Remote CIR mit Logitech Harmony 650, Beamer 120'' FullHD-3D

  • nimm doch einen Hinweistafel Sender ohne Ton. Davon gibt es jede Menge auf Astra und Hotbird

    Ich habe gerade mal durch gezappt und bin dabei über Astra auf "SES 75" gekommen. Der hat nur ein großes HD+ Zeichen s/w --> https://en.kingofsat.net/find.php?question=ses+75 und ist stumm

    Ja das ist auch nicht schlecht.


    Trotzdem interessiert mich jetzt noch die "Luxusvariante" über eine HDMI-Erkennung, ist sowas generell möglich ?


    Aber danke für den Tip !:) So richte ich das mal fix ein, der Aufwand ist ja gering.

    Server: VDR 2.4.0 mit Ubuntu 18.04 x64 mit vaapidevice, Kernel 4.19.0 rc2, ASRock J4105M, 2 x 4096 MB DDR4-RAM, 2 x Technotrend S2-1600, 2 x DD Cine S2, Lirc-Serial mit One4All URC 7960
    Client: VDR 2.4.0 mit Ubuntu 18.04 x64 mit KODI+vnsiserver, Kernel 4.18.12, ASRock H81M, Intel i3-4150, NVIDIA GPU GeForce GT 610 (GF119), 2 x 2048 MB DDR2-RAM, 1 x Technotrend S2-1600, SilverStone Milo ML03, ASRock Smart Remote CIR mit Logitech Harmony 650, Beamer 120'' FullHD-3D

  • Man kann über den i2c-Kanal des HDMI eine Abfrage auf den HDCP Chip machen.


    Folgendes Tool macht das:

    https://github.com/beralt/istvup


    oder per Shell Skript mit folgendem Kommando:

    i2cdump -y 3 0x3a


    Das Argument 3 ist dabei der i2c Bus, der sich je nach HDMI Port ändert. Wenn keine Antwort kommt, ist der TV aus.


    Gruss, Xcoder

    VDR: Zotac ZBOX EN860, 16GB RAM, 2 TB HDD, Debian Stretch, vdr-2.2.0, softhddevice, permashift, satip

  • Ja das könnte ich machen, der AVR ist ein Yamaha RX-V 2067, aber hinsichtlich Stromverbrauch und zum gucken von Nachrichten/Reportagen fand ich das immer wie mit Kanonen auf Spatzen zu schiessen. Eigentlich reicht mir dazu der Ton der Soundbar .

    Den Zahn habe ich mir inzwischen gezogen. Ich wollte auch den AVR nicht nutzen für Nachrichten. Die Tonqualität auch bei den Nachrichten ist über den AVR (auch ein Yamaha bei mir) aber so viel besser als über den TV selbst, daß ich jetzt -auch wegen WAF- immer über den AVR gehe. Ich will ja nicht nach den Nachrichten beim Zappen irgendwas umschalten müssen.


    Die Soundbar kann dann ja weg. Und die läuft ja auch nicht ohne Strom.


    Zur Abfrage, ob TV an ist:

    Code
    1. vdr ~ # parse-edid < /sys/class/drm/card0/*HDMI*/edid 2>/dev/null| grep Identifier
    2. Identifier "LOEWE HDMI TV"
    3. vdr ~ # parse-edid < /sys/class/drm/card0/*HDMI*/edid 2>/dev/null| grep Identifier
    4. vdr ~ # parse-edid < /sys/class/drm/card0/*HDMI*/edid 2>/dev/null| grep Identifier
    5. Identifier "RX-V681"
    6. vdr ~ #

    Ich bekomme bei angeschaltetem Fernseher hinter dem (angeschalteten) AVR diesen als Identifier angezeigt. Schalte ich den TV aus, gibt es erst mal keinen Identifier und danach dann den AVR. Schalte ich dann den TV wieder an, kommt dann wieder der Loewe als Antwort.


    Kann man wahrscheinlich 'was draus basteln.


    Christian

  • mit i2cdump erhalte ich nur beim i2cbus 0 Werte, diese ändern sich aber nicht wenn ich den TV ausschalte. Das sieht dann so aus.


    i2cdump -y 0 0x3a

    Code
    1. 0 1 2 3 4 5 6 7 8 9 a b c d e f 0123456789abcdef00: 46 f2 9c 60 b7 00 00 00 4b 02 00 00 00 00 00 00 F??`?...K?......10: 49 5a f0 ba 3a 00 00 00 e9 8c 19 2a e4 f4 4d 68 IZ??:...???*??Mh20: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................30: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................40: 91 00 10 00 00 00 00 00 00 00 00 00 00 00 00 00 ?.?.............50: 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ?...............60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................80: 0a 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ?...............90: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................a0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................e0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................

    Wenn ich eine andere Busnummer 1-10 angebe sieht es immer so aus


    i2cdump -y 1 0x3a

    Code
    1. 0 1 2 3 4 5 6 7 8 9 a b c d e f 0123456789abcdef00: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXX10: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXX20: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXX30: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXX40: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXX50: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXX60: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXX70: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXX80: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXX90: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXXa0: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXXb0: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXXc0: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXXd0: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXXe0: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXXf0: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XXXXXXXXXXXXXXXX



    Das kleine Programm aus dem Git habe ich mal compiliert, wenn ich das so starte kommt dies

    Code
    1. ./istvup 1
    2. failed to get systemd unit: Unit xbmc.service not loaded.

    Die Ausgabe verwirrt mich etwas, da kann ich nix mit anfangen.


    [edit] was mich auch verwirrt ist: wenn ich hier in einem Post mehr als einen Code-Block einfüge, bleibt immer nur im letzten die Formatierung erhalten. In allen vorherigen sieht es dann aus wie in diesem Post ! =O Woran soll das liegen, ich verwende Firefox 62.0.3 unter Windows 10 ? [/edit]

    Server: VDR 2.4.0 mit Ubuntu 18.04 x64 mit vaapidevice, Kernel 4.19.0 rc2, ASRock J4105M, 2 x 4096 MB DDR4-RAM, 2 x Technotrend S2-1600, 2 x DD Cine S2, Lirc-Serial mit One4All URC 7960
    Client: VDR 2.4.0 mit Ubuntu 18.04 x64 mit KODI+vnsiserver, Kernel 4.18.12, ASRock H81M, Intel i3-4150, NVIDIA GPU GeForce GT 610 (GF119), 2 x 2048 MB DDR2-RAM, 1 x Technotrend S2-1600, SilverStone Milo ML03, ASRock Smart Remote CIR mit Logitech Harmony 650, Beamer 120'' FullHD-3D

  • Den AVR dauerhaft zu nutzen wäre für mich der letzte Lösungsweg. Ich schalte den bisher wirklich nur zu wenn ich mal einen Film in DD gucken möchte, oder für Musik. Der Sound des TV ist auch bei mir grottig, der geht überhaupt nicht, daher ja der Weg über die Soundbar. Ohne den HDMI-Switch war das auch kein Problem, da hatte ich die direkt per HDMI mit dem HDMI-1-Eingang am TV verbunden der ARC unterstützt. Hierbei ist die Soundbar dann immer mit dem TV automatisch An- und ausgegangen. Wenn der Switch aber in der HDMI-Kette ist, funktioniert ARC leider nicht mehr.


    wenn ich deinen Befehl bei mir eingebe bekomme ich diese Ausgabe

    Keine Ahnung was da falsch läuft. Als ich das Board neu hatte habe ich zwecks Modeline spielereien schon einmal probiert Werte über den i2c-Bus auszulesen. Das hat mit den Programmen die ich dafür im Netz gefunden hatte aber auch nicht funktioniert. Kann es sein das mir noch irgendein Treiber für den i2c-Bus fehlt den ich im Kernel für mein Board mit bauen muss ?

    Server: VDR 2.4.0 mit Ubuntu 18.04 x64 mit vaapidevice, Kernel 4.19.0 rc2, ASRock J4105M, 2 x 4096 MB DDR4-RAM, 2 x Technotrend S2-1600, 2 x DD Cine S2, Lirc-Serial mit One4All URC 7960
    Client: VDR 2.4.0 mit Ubuntu 18.04 x64 mit KODI+vnsiserver, Kernel 4.18.12, ASRock H81M, Intel i3-4150, NVIDIA GPU GeForce GT 610 (GF119), 2 x 2048 MB DDR2-RAM, 1 x Technotrend S2-1600, SilverStone Milo ML03, ASRock Smart Remote CIR mit Logitech Harmony 650, Beamer 120'' FullHD-3D

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Hollywood ()

  • Dann probier mal

    parse-edid < /sys/class/drm/card0/card0-HDMI-A-1/edid

    bzw.

    parse-edid < /sys/class/drm/card0/card0-HDMI-A-2/edid

    Die Variante mit '*' hat vermutlich bei mir nur deshalb funktioniert, weil da nur ein Ergebnis existiert. Bei Dir sind's 2.


    Christian

  • Wenn vaapidevice immer detached gestartet wird und wie z.B. bei yavdr per Skript genau dann attached wird, wenn der vdr nicht wegen einer Aufnahme gestartet wird, sollte doch bei timergesteuertem Einschalten kein Ton rausgehen?

    vdr-2.4.0
    softhddevice, chanman, cdda, dbus2vdr, dvd, dynamite, epgsearch, femon, filebrowser, graphlcd, graphtftng,
    menuorg, osdteletext, radio, recsearch, streamdev-server, vdrmanager, vnsiserver

    linux-3.13.0 M3N78-VM (Nvidia 8200) CIne CT-V7 DVB-C
    yavdr-0.6 als Basis mit vielen Änderungen

  • Am besten wäre wenn der VDR nur ein Bild und Ton liefert wenn er auch benutzt wird. Man könnte den VDR detached verwenden und nur bei Bedarf auf attached setzen. Man könnte auch einen VDR Server ohne Ausgabe im Hintergrund für die Aufnahmen betreiben und den VDR für die Bild und Tonausgabe nur bei bedarf starten und beenden.

  • Das funktioniert nun, allerdings ändert sich da bei mir absolut nix, egal ob TV an -oder aus, die gesamte Ausgabe ist immer identisch. Schade !


    Am besten wäre wenn der VDR nur ein Bild und Ton liefert wenn er auch benutzt wird. Man könnte den VDR detached verwenden und nur bei Bedarf auf attached setzen. Man könnte auch einen VDR Server ohne Ausgabe im Hintergrund für die Aufnahmen betreiben und den VDR für die Bild und Tonausgabe nur bei bedarf starten und beenden.

    Ich weis nicht obs Frauchen damit zurecht kommt. Wie erkennt sie denn hierbei, ob der VDR schon an und hochgefahren ist und das Frontend nur noch gestartet werden muss ? Ich könnte entsprechende Befehle auf die Fernbedienung legen, ich vermute aber das ist ihr zu umständlich und es gibt Ärger. :D Mein VDR steht auch nicht im selben Raum, man kann also auch nicht anhand irgendwelcher LED´s sehen ob der Rechner läuft.


    Wenn vaapidevice immer detached gestartet wird und wie z.B. bei yavdr per Skript genau dann attached wird, wenn der vdr nicht wegen einer Aufnahme gestartet wird, sollte doch bei timergesteuertem Einschalten kein Ton rausgehen?

    Hier habe ich zwar das selbe Problem mit der Erkennung ob der VDR schon läuft wie bei der Idee von dile, aber hier besteht das Problem ja nur, wenn der VDR automatisch für eine Aufnahme gestartet wurde und genau zu diesem Zeitpunkt dann jemand TV gucken möchte. Das könnte ich vielleicht noch verkraften, da das nicht so oft vorkommen dürfte.


    Wie kann ich denn erkennen/abfragen ob der VDR manuell oder wegen einer Aufnahme hochgefahren wurde ?

    Server: VDR 2.4.0 mit Ubuntu 18.04 x64 mit vaapidevice, Kernel 4.19.0 rc2, ASRock J4105M, 2 x 4096 MB DDR4-RAM, 2 x Technotrend S2-1600, 2 x DD Cine S2, Lirc-Serial mit One4All URC 7960
    Client: VDR 2.4.0 mit Ubuntu 18.04 x64 mit KODI+vnsiserver, Kernel 4.18.12, ASRock H81M, Intel i3-4150, NVIDIA GPU GeForce GT 610 (GF119), 2 x 2048 MB DDR2-RAM, 1 x Technotrend S2-1600, SilverStone Milo ML03, ASRock Smart Remote CIR mit Logitech Harmony 650, Beamer 120'' FullHD-3D

  • mit i2cdump erhalte ich nur beim i2cbus 0 Werte, diese ändern sich aber nicht wenn ich den TV ausschalte. Das sieht dann so aus.


    i2cdump -y 0 0x3a

    Das kleine Programm aus dem Git habe ich mal compiliert, wenn ich das so starte kommt dies

    Code
    1. ./istvup 1
    2. failed to get systemd unit: Unit xbmc.service not loaded.


    Irgendwas kommt da ja schon mal. Ich dachte das die Adresse 0x34 Standard ist. Auf 0x50 wäre die EDID. Die kommt aber auch bei ausgeschaltetem TV oder Monitor. Mach mal ein i2cdetect -l


    Das sollte dir am System vorhandenen i2c Buse anzeigen. Der NVIDIA Treiber macht normalerweise für jeden Port 1 Bus (für DisplayPort gleich 2). Das i2c_dev Kernelmodul sollte ja geladen sein (lsmod | grep i2c_dev).


    Das istvup ist irgendwie für das Zusammenspiel mit XBMC/KODI gedacht. Dass müsste man dann wohl auf deine Gegebenheiten anpasse. Das Tool ist auch nur als Idee gedacht.

    VDR: Zotac ZBOX EN860, 16GB RAM, 2 TB HDD, Debian Stretch, vdr-2.2.0, softhddevice, permashift, satip

  • Auf meinen Vorschlag mit ping bist Du noch nicht eingegangen. Der TV hängt doch bestimmt am Netz. Kannst Du nicht ganz trivial per ping oder offenem Port am TV abfragen, ob der läuft?

    Den VDR dann detached starten und das Ausgabeplugin nur attachen, wenn der TV an ist. Wenn der TV wieder aus ist, dann wieder detachen.


    Christian

  • Xcoder  

    Du hast Recht ! Mit Adresse 0x50 kommt die EDID die ich beim Starten mittels Kernelparameter lade, damit auch bei ausgeschaltetem TV die Auflösungen passen. Hier äußerte ich ja weiter oben schonmal den Verdacht, dass ich deshalb evtl. nicht die Möglichkeit habe zu erkennen ob der TV eingeschaltet ist, weil ich ja über die EDID vorgaukele das er es ist. Keine Ahnung ob ich da richtig liege.


    NVidia habe ich in diesem System nicht mehr installiert, läuft alles über die integrierte Intel-GPU.


    Mit istvup hatte ich mich noch nicht weiter beschäftigt, nur compiliert. Aber so wie ich das jetzt verstehe brauche ich mich damit auch nicht weiter beschäftigen, da dieser Ansatz bei mir nicht funktioniert oder ?

    Server: VDR 2.4.0 mit Ubuntu 18.04 x64 mit vaapidevice, Kernel 4.19.0 rc2, ASRock J4105M, 2 x 4096 MB DDR4-RAM, 2 x Technotrend S2-1600, 2 x DD Cine S2, Lirc-Serial mit One4All URC 7960
    Client: VDR 2.4.0 mit Ubuntu 18.04 x64 mit KODI+vnsiserver, Kernel 4.18.12, ASRock H81M, Intel i3-4150, NVIDIA GPU GeForce GT 610 (GF119), 2 x 2048 MB DDR2-RAM, 1 x Technotrend S2-1600, SilverStone Milo ML03, ASRock Smart Remote CIR mit Logitech Harmony 650, Beamer 120'' FullHD-3D