Digital Devices DVBCT V6.1 tut mal wieder nicht

  • Hallo,


    leider funktioniert meine ddbridge Karte mal wieder nicht mehr (schon einige Wochen).

    Den Restart-Trick mit 10 Minuten stromlos habe ich schon durchgeführt.


    Evtl. wissen die Experten mehr?


    Grüße


    modinfo ddbridge


    filename: /lib/modules/4.18.0-0.bpo.1-amd64/kernel/drivers/media/pci/ddbridge/ddbridge.ko

    version: 0.9.33-integrated

    license: GPL

    author: Ralph and Marcus Metzler, Metzler Brothers Systementwicklung GbR

    description: Digital Devices PCIe Bridge

    srcversion: B046D4F9F52D0CDB7D03766

    alias: pci:v0000DD01d00000329sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000328sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000323sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000322sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000321sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000320sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000220sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000210sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000203sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000201sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000013sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000012sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000011sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000009sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000008sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000007sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000006sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000005sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000003sv0000DD01sd*bc*sc*i*

    alias: pci:v0000DD01d00000002sv0000DD01sd*bc*sc*i*

    depends: dvb-core

    retpoline: Y

    intree: Y

    name: ddbridge

    vermagic: 4.18.0-0.bpo.1-amd64 SMP mod_unload modversions

    parm: fmode:frontend emulation mode (int)

    parm: fmode_sat:set frontend emulation mode sat (int)

    parm: old_quattro:old quattro LNB input order (int)

    parm: adapter_nr:DVB adapter numbers (array of short)

    parm: adapter_alloc:0-one adapter per io, 1-one per tab with io, 2-one per tab, 3-one for all (int)

    parm: ci_bitrate: Bitrate in KHz for output to CI. (int)

    parm: ts_loop:TS in/out test loop on port ts_loop (int)

    parm: xo2_speed:default transfer speed for xo2 based duoflex, 0=55,1=75,2=90,3=104 MBit/s, default=2, use attribute to change for individual cards (int)

    parm: alt_dma:use alternative DMA buffer handling (int)

    parm: no_init:do not initialize most devices (int)

    parm: stv0910_single:use stv0910 cards as single demods (int)

    parm: dma_buf_num:Number of DMA buffers, possible values: 8-32 (int)

    parm: dma_buf_size:DMA buffer size as multiple of 128*47, possible values: 1-43 (int)

    parm: dummy_tuner:attach dummy tuner to port 0 on Octopus V3 or Octopus Mini cards (int)

    parm: msi:Control MSI interrupts: 0-disable (default), 1-enable (int)



    dmesg


    [ 2.131879] ddbridge: Digital Devices PCIE bridge driver 0.9.33-integrated, Copyright (C) 2010-17 Digital Devices GmbH

    [ 2.131899] sd 0:0:0:0: Attached scsi generic sg0 type 0

    [ 2.132007] ddbridge 0000:02:00.0: detected Digital Devices DVBCT V6.1 DVB adapter

    [ 2.132494] sd 1:0:0:0: Attached scsi generic sg1 type 0

    [ 2.132697] ddbridge 0000:02:00.0: HW 0001000d REGMAP 00010004

    [ 2.132759] sd 2:0:0:0: Attached scsi generic sg2 type 0

    [ 2.135128] ddbridge 0000:02:00.0: Port 0: Link 0, Link Port 0 (TAB 1): DUAL DVB-C/T

    [ 2.138469] ddbridge 0000:02:00.0: Port 1: Link 0, Link Port 1 (TAB 2): NO MODULE

    [ 2.140637] ddbridge 0000:02:00.0: Port 2: Link 0, Link Port 2 (TAB 3): NO MODULE

    [ 2.140752] dvbdev: DVB: registering new adapter (DDBridge)

    [ 2.140753] dvbdev: DVB: registering new adapter (DDBridge)

    [ 2.140847] dvbdev: dvb_register_device: DVB: register adapter0/demux0 @ minor: 0 (0x00)

    [ 2.140866] dvbdev: dvb_register_device: DVB: register adapter0/dvr0 @ minor: 1 (0x01)

    [ 2.140881] dvbdev: dvb_register_device: DVB: register adapter0/net0 @ minor: 2 (0x02)

    ...

    [ 2.460663] tda18212 1-0060: NXP TDA18212HN/M successfully identified

    [ 2.460675] ddbridge 0000:02:00.0: DVB: registering adapter 0 frontend 0 (ST STV0367 DDB DVB-C/T)...

    [ 2.460768] dvbdev: dvb_register_device: DVB: register adapter0/frontend0 @ minor: 3 (0x03)

    [ 2.460908] dvbdev: dvb_register_device: DVB: register adapter1/demux0 @ minor: 4 (0x04)

    [ 2.460979] dvbdev: dvb_register_device: DVB: register adapter1/dvr0 @ minor: 5 (0x05)

    [ 2.461048] dvbdev: dvb_register_device: DVB: register adapter1/net0 @ minor: 6 (0x06)

    [ 2.461584] i2c i2c-1: Found ST STV0367 DDB DVB-C/T with ChipID 60 at adr 1E

    [ 2.756474] ddbridge 0000:02:00.0: tda18212 ping failed, expect problems

    [ 2.756598] stv0367_readreg: i2c read error ([1e] f001: 00)

    [ 2.756731] stv0367_writeregs: i2c write error! ([1e] f001: 00)

    [ 2.758411] stv0367_readreg: i2c read error ([1e] f001: 00)

    [ 2.758451] stv0367_writeregs: i2c write error! ([1e] f001: 80)

    [ 2.758485] stv0367_readreg: i2c read error ([1e] f001: 00)

    [ 2.758504] stv0367_writeregs: i2c write error! ([1e] f001: 00)

    [ 2.758529] tda18212: probe of 1-0063 failed with error -5

    [ 2.758537] ddbridge 0000:02:00.0: TDA18212 tuner not found. Device is not fully operational.

    [ 2.758543] ddbridge 0000:02:00.0: tuner attach failed!

    [ 2.759235] ddbridge 0000:02:00.0: port_attach on port 0 failed

    [ 2.759243] ddbridge 0000:02:00.0: All connected ports failed to initialise!

    [ 2.759248] ddbridge 0000:02:00.0: fail3

    [ 2.759267] ddbridge 0000:02:00.0: fail2

    [ 2.759370] ddbridge 0000:02:00.0: fail1

    [ 2.759391] ddbridge 0000:02:00.0: fail0

    [ 2.759395] ddbridge 0000:02:00.0: fail

    [ 2.759559] ddbridge: probe of 0000:02:00.0 failed with error -1

  • Keiner eine Idee?

    Hier geht es wohl schief:


    [ 2.756474] ddbridge 0000:02:00.0: tda18212 ping failed, expect problems

    [ 2.756598] stv0367_readreg: i2c read error ([1e] f001: 00)

    [ 2.756731] stv0367_writeregs: i2c write error! ([1e] f001: 00)

    [ 2.758411] stv0367_readreg: i2c read error ([1e] f001: 00)

    [ 2.758451] stv0367_writeregs: i2c write error! ([1e] f001: 80)

    [ 2.758485] stv0367_readreg: i2c read error ([1e] f001: 00)

    [ 2.758504] stv0367_writeregs: i2c write error! ([1e] f001: 00)

    [ 2.758529] tda18212: probe of 1-0063 failed with error -5

    [ 2.758537] ddbridge 0000:02:00.0: TDA18212 tuner not found. Device is not fully operational.

  • Sieht nach einem Defekt aus. Würde mal bei DD direkt anfragen.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Den Parameter "msi=0" an das ddbridge-Modul übergeben?

    (Datei ddbridge.conf in /etc/modprobe.d mit Inhalt "options ddbridge msi=0")

    --
    hdvdr: Intel(R) Xeon(R) CPU W3520, 12 GB Ram, Grafik nvidia GeForce GT 430, nvidia-396
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und 2xDVB-C/T Tunern, TT-3200 (SAA7146) mit 1xDVB-S2 + FB,
    System btrfs, apt-btrfs-snapper,+5x1TB Raid5 XFS, yavdr0.6-frodo, Kernel 4.15.0-38-generic

    mit DD-S2+C+SAA7146-Support, epgd/tvm/tvsp, vdradmin-am, vdrmanager

  • Danke fuer den tipp, aber es wird eher schlechter:


    2.129385] dvbdev: DVB: registering new adapter (DDBridge)

    [ 2.130872] usbcore: registered new interface driver radio-ma901

    [ 2.134594] hidraw: raw HID events driver (C) Jiri Kosina

    [ 2.135128] cxd2099 1-0040: No CXD2099AR detected at 0x40

    [ 2.135136] cxd2099: probe of 1-0040 failed with error -5

    [ 2.135138] ddbridge 0000:02:00.0: CXD2099AR attach failed

    [ 2.135186] ddbridge 0000:02:00.0: port_attach on port 0 failed

    [ 2.135233] ddbridge 0000:02:00.0: All connected ports failed to initialise!

    [ 2.135282] ddbridge 0000:02:00.0: fail3

    [ 2.135333] ddbridge 0000:02:00.0: fail2

    [ 2.135423] ddbridge 0000:02:00.0: fail1

    [ 2.135476] ddbridge 0000:02:00.0: fail0

    [ 2.135519] ddbridge 0000:02:00.0: fail

    [ 2.135662] ddbridge: probe of 0000:02:00.0 failed with error -1

  • Klingt als müßten Sie mal die Karte einschicken und testen lassen ...

    Nur zur Sicherheit: Floppy-Kabel (Stromversorgung) angesteckt?

    --
    hdvdr: Intel(R) Xeon(R) CPU W3520, 12 GB Ram, Grafik nvidia GeForce GT 430, nvidia-396
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und 2xDVB-C/T Tunern, TT-3200 (SAA7146) mit 1xDVB-S2 + FB,
    System btrfs, apt-btrfs-snapper,+5x1TB Raid5 XFS, yavdr0.6-frodo, Kernel 4.15.0-38-generic

    mit DD-S2+C+SAA7146-Support, epgd/tvm/tvsp, vdradmin-am, vdrmanager

  • Frag einfach bei DD an, die werden schon wissen, ob die Karte defekt ist oder was zu tun ist.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB