10 Bit Farbe an NVIDIA Karte unter Linux

  • Das wären die FlatPanelProperties in der xorg.conf, oder?

    Okay, das werde ich bei Gelegenheit nochmal probieren.

    Muss jetzt erstmal weg! 8)

  • So, ich hatte jetzt wieder etwas Zeit zum probieren.

    Ich habe mal nacheinander in die xorg.conf folgende beiden Optionen "Colorspace" und "FlatPanelProperties" in der Section "Device" getestet:

    Die Option "FlatPanelProperties" bringt keine für mich sichtbare Verbesserung des Bandings in dunklen Bereichen.

    Dagegen bringt die Option "Colorspace" doch schon eine sichtbare Verbesserung.



    Mein Denon AVR-X4500H zeigt nun beim HDMI-Signal folgendes: ---> 1080p50Hz YCbCr 4:4:4 8bit

    Also schaltet der Nvidia-HDMI-Ausgang auf YCbCr um, allerdings geht eben nur YCbCr 4:4:4 und kein 4:2:2


    seahawk1986

    Danke für den Tipp mit dem "Colorspace".

    Das werde ich erstmal vorläufig drin lassen. Ist ja besser als gar nichts! ;)

  • Hier sieht man schon, dass der Odroid über Coreelec-KODI das TV-Signal mit 12bit-Farbtiefe überträgt. Ist schon einiges mehr als die 8bit der GT1030!

    Ja, das kann durchaus einen Unterschied machen, wenn man zwei nahe beieinander liegende Farben aus Rec.709 mit 8 oder 12 Bit pro Farbkanal umrechnet (und wie man dabei rundet).


    Danke für den Tipp mit dem "Colorspace".

    Das werde ich erstmal vorläufig drin lassen. Ist ja besser als gar nichts!

    Schau auch mal, ob die Einstellung im Ausgabeplugin dazu passt (da kann man zwischen vollem Farbraum und dem beschränkten Farbraum - Stichwort Studio Levels - umstellen).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Schau auch mal, ob die Einstellung im Ausgabeplugin dazu passt (da kann man zwischen vollem Farbraum und dem beschränkten Farbraum - Stichwort Studio Levels - umstellen).



    VDR -> softhddevice -> Benutze Studio Levels -> Nein -> Bild ist für mich i.O. (so ist es schon immer eingestellt)

    VDR -> softhddevice -> Benutze Studio Levels -> Ja -----> Bild wird heller, verwaschener


    Zitat aus den Nvidia Config Optionen für den Farbraum, damit wäre die Einstellung richtig.

    Allerdings habe ich diese Einstellung schon immer so, auch wenn RGB ausgegeben wird.

    Code
    1. Option "ColorRange" "string"
    2. ...
    3. Possible arguments:
    4. - "Full": sets color range to full range. By default, full color range is set when the color space is RGB.
    5. - "Limited": sets color range to limited range. YCbCr444 supports only limited color range. Consequently, limited range is selected by the driver when color space is set to YCbCr444, and can not be changed.
    6. If the ColorRange option is not specified, or is incorrectly specified, then an appropriate default value is selected based on the selected color space.
    7. ...



    Die gleichen Einstellungen gibt es ja auch noch bei KODI von yaVDR (bei Coreelec-KODI gibt es diese Einstellung nicht).:

    KODI -> System -> Anzeige -> Begrenzten Farbraum (16-235) verwenden -> Ein -> Bild wird heller, verwaschener

    KODI -> System -> Anzeige -> Begrenzten Farbraum (16-235) verwenden -> Aus -> Bild ist für mich i.O. (so ist es eingestellt)


    Doch hier ist das Verhalten genau umgekehrt, denn Benutze Studio Level = Nein bedeutet doch dasgleiche wie Begrenzten Farbraum verwenden = Ein

    Oder sehe ich das falsch?

    Oder liegt das daran, dass KODI ja ein eigenes ffmpeg für die Ausgabe benutzt?

  • Doch hier ist das Verhalten genau umgekehrt, denn Benutze Studio Level = Nein bedeutet doch dasgleiche wie Begrenzten Farbraum verwenden = Ein

    Oder sehe ich das falsch?

    Studio-Levels ein bedeutet, dass man den begrenzen Farbraum nutzt. Und wenn man RGB oder einem anderen umfangreicheren Farbraum ausgibt, wirken die Farben ausgewaschener.


    Wichtig ist nur, dass die Einstellungen im Software, X-Server und ggf. Mapping durch das Ausgabegerät zusammen passen,

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Studio-Levels ein bedeutet, dass man den begrenzen Farbraum nutzt. ...

    Ach so, das hatte ich genau andersrum gedacht. Dann stimmt ja alles.

    Wieder was gelernt! ;)