[Sat>IP] [Fritz!Box] Nicht alle Sender liefern ein Bild

  • Hallo zusammen,


    folgende Konfiguration habe ich hier am Laufen:

    • yaVDR 0.6.2
    • Sat>IP Plugin
    • Fritz!Box und Fritz!Repeater als Sat>IP Server

    Viele Sender (sowohl öffentlich rechtliche als auch Private), liefern ein Bild und das ganze funktioniert in Summe echt gut. Allerdings gibt es einige Sender, die nicht funktionieren wollen (z.B. arte HD oder ProSieben Maxx).


    Im Anhang findet ihr den relevanten syslog-Ausschnitt mit aktivierter Debug Tracing Funktion für das Sat>IP Plugin.


    Ein ähnliches Problem gab es hier schon einmal: vdr-plugin-satip nicht alle Sender haben ein Bild (Kathrein ExIP 414/E)


    Dort scheint eine Lösung für DVB-S(2), nicht DVB-C gefunden worden zu sein.


    Weiß jemand Rat? :)


    Beste Grüße
    Nils

    Dateien

    1. VDR: Zotac ION ITX A Atom 330 GeForce 9400,Fritz!Box DVB-C und Fritz!Repeater DVB-C Sat>IP Server, yavdr 0.6: Produktiveinsatz Wohnzimmer

    2. VDR: Asus E45M1-M PRO, Terratec Cinergy C PCI, Ubuntu 18.04: Medien-Server inkl. emby

  • Hast du mal geschaut ob du mit einer anderen DVB Karte die Sender sehen kannst? Vielleicht sind die in einer "Randfrequenz, die die Fritzbox nicht sehen kann oder das Kabel ist nicht gut genug...

    VDR- Server: Gigabyte Brix 3150 - (2x Sunteck DVB-C) - jessey - Aufnahme und Streaming-Server (12Watt unter Last)
    Client Wohnzimmer: DQ77KB - i3 - Logitech z-5500 - Blaupunkt 39" TV - Openelec (Streaming)
    Client Büro: Asus AT3N7A-I , yaVDR0.6.1 (Streaming + Cutting) - 19" TFT
    Test Client1: Raspberry Pi & openelec

  • 13:44:37 (..) >>> SETUP (..)

    13:44:37 (..) <<< 200 OK


    13:44:37 (..) >>> PLAY (..)

    13:44:37 (..) <<< 500 Internal Server Error


    (..)


    13:44:37 (..) >>> SETUP (..)

    13:44:37 (..) <<< 200 OK


    13:44:37 (..) <<< PLAY (..)

    13:44:37 (..) <<< 500 Internal Server Error





    Das Satip Plugin lässt dem Server hier extrem wenig Zeit, die Kommandos auszuführen. Setup und Play in der gleichen Sekunde.

    Vielleicht ist die Fritzbox nicht so schnell. Vielleicht versucht die Fritz bereits bei SETUP zu tunen, dann wäre sie noch nicht damit fertig.

    btw: nirgendwo steht in der Spec, wann exakt ein SATIP Server tuned, bei Setup oder bei Play.

  • I'd try the following tricks:

    - add all necessary channels.conf entries for your cable channels as the standard doesn't support VDR's auto: I couldn't spot at least the coderate and inversion

    - limit available devices to one - now you've banging the server with two simultaneous clients

    - enable PlayPids (0x2) quirk - you're getting errors with PLAY commands and there have been servers (old Fritz!Box hardware) that can't handle addpids/delpids commands correctly and always requires a full pid list. Also the ForceLock (0x4) quirk has been required with those ones as well.

  • Hi zusammen,


    danke für die Kommentare!


    Ich habe sowohl eine Fritz.Box 6490 als auch einen Fritz.Repeater DVB-C - ich habe die Anzahl der Streams auf jeweils einen mithilfe der satip.conf limitiert und somit insgesamt zwei funktionierende DVB-C Tuner (bei den meisten Sendern zumindest ;) ). Aber gut zu wissen, dass mit FritzOS 7 mehr möglich sind! Dann habe ich ja bald sechs funktionierende Tuner! :-o

    Code
    1. --server 192.168.178.23|DVBC-1|FritzRepeater;192.168.178.1|DVBC-1|FritzBox


    Über eine klassische DVB-C Karte sind alle Sender empfangbar, habe sicherheitshalber auch noch einen neuen Sendersuchlauf gemacht.


    rofafor : Many thanks for the hints! I did a complete channel scan with a classical dvb-c tuner. With the following channels.conf (just an excerpt) and the classical dvb-c tuner I receive all channels (including arte HD etc.). Do I need to add something?


    Unfortunately, the problem still exists when limiting satip to one device (-d 1).


    How do I enable/disable these quirks?


    Beste Grüße

    Nils

    1. VDR: Zotac ION ITX A Atom 330 GeForce 9400,Fritz!Box DVB-C und Fritz!Repeater DVB-C Sat>IP Server, yavdr 0.6: Produktiveinsatz Wohnzimmer

    2. VDR: Asus E45M1-M PRO, Terratec Cinergy C PCI, Ubuntu 18.04: Medien-Server inkl. emby

  • Just rename your devices as "fritzdvbc" and the both quirks should be enabled automatically. You can verify this in logs at the startup.

    Code
    1. -d 1 -s 192.168.178.1|DVBC-1|fritzdvbc

    or you can define those in the command-line as stated in README:

    Code
    1. -d 1 -s 192.168.178.1|DVBC-1|FritzBox:0x6

    Your channels.conf entries defines only modulation (M), but you'd need to define also inversion (I) if you want to fully comply with SAT>IP specification. VDR is interpreting a missing value as "AUTO", which isn't supported in the specs.

  • If in doubt, configure pls Inversion setting to 'OFF' -> 'I0'.


    It's a quite safe bet, until the cable network or the hardware driver aren't completly screwed up.

  • Guys, it works! Thank you so much! :)


    The solution wasn't where I expected it to be. The last channel scan at the fritzbox web interface was done a few months ago. I wanted to double check and tried to stream arte HD via the rtsp:// link from the web interface, it didn't work. After a new channel scan all channels are working now (via rtsp:// link and via Sat>IP plugin). I wasn't aware, that I needed a working channel configuration at the Sat>IP server.


    Sorry for haven't checked that earlier X/

    1. VDR: Zotac ION ITX A Atom 330 GeForce 9400,Fritz!Box DVB-C und Fritz!Repeater DVB-C Sat>IP Server, yavdr 0.6: Produktiveinsatz Wohnzimmer

    2. VDR: Asus E45M1-M PRO, Terratec Cinergy C PCI, Ubuntu 18.04: Medien-Server inkl. emby

  • Voll der "Denglische" Thread ;)


    Magst Du versuchen deine Lösung mal mit deutschen Worten zu verfassen?

    Ich kann mit vorstellen dass andere Nutzer in ähnliche Probleme laufen werden und dann eine Lösung suchen und nicht ganz so fit in Englisch sind.


    Google hilft zwar, aber die Übersetzungen sind teils Müll...

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • Gerne aber auch noch einmal direkt hier in deutsch:


    Das Problem war am Ende, dass die Fritz.Box den Kanal selber nicht in der Senderliste hatte. Nach einem neuen Sendersuchlauf im Webinterface der Fritz.Box lief es dann.


    Um konform zum Sat>IP Standard zu sein, habe ich noch die channels.conf angepasst und die Inversion auf "off" gesetzt (bspw. ...I0M256...).


    Und noch ein bisschen Off-Topic: deepl.com (Kölner Unternehmen) bietet einen sehr guten deutsch-englisch Übersetzer: Klick!


    Schöne Grüße

    Nils

    1. VDR: Zotac ION ITX A Atom 330 GeForce 9400,Fritz!Box DVB-C und Fritz!Repeater DVB-C Sat>IP Server, yavdr 0.6: Produktiveinsatz Wohnzimmer

    2. VDR: Asus E45M1-M PRO, Terratec Cinergy C PCI, Ubuntu 18.04: Medien-Server inkl. emby