vaapidevice Plugin und ffmpeg

  • Hi,


    in der README zum vaapidevice Plugin steht als Voraussetzung die ffmpeg Version 3.2. Damit lässt sich das Plugin aber nicht kompilieren, da die libav Eigenschaft hw_device_ctx verwendet wird, und diese erst ab der Version 3.3 existiert. Die README müsste also mal angepasst werden.


    Da ich Debian verwende, und hier in der stable Version lediglich die Version 3.2 zur Verfügung steht, würde ich gerne wissen, ob mir jemand sagen kann, ob auf das hw_device_ctx verzichtet werden kann, und ob jemand einen Patch dafür hat, bzw. mal schauen kann, ob sich die Abhängigkeit leicht entfernen lässt?


    Claus

    MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
    WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
    MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
    MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD