Anzeigeeinstellungen - kann man die resetten?

  • Hallo,


    ich verzweifle hier gerade, ich bin wahrscheinlich einer der Wenigen, der noch einen Röhrenfernseher besitzt und diesen mittels vga2scart an den vdr gestöpselt hat.

    Das hat bisher auch immer gut funktioniert, jetzt habe ich eine andere Grafikkarte eingebaut und der Ärger ging los.


    Ich bekomme es einfach nicht mehr hin mittels der Anzeigeeinstellungen vom yavdr Webfrontend dem Fernseher ein vernünftiges Bild zu entlocken, ich bekomme immer nur Doppelbilder mit Streifen, manchmal ist der Bildschirm auch dreigeteilt.


    Die /etc/X11/xorg.yavdr.conf habe ich jetzt schon mehrfach gelöscht, tntnet und openbox neu gestartet, es funktioniert nicht.

    Ich habe auch eine zweite frische yavdr-Installation gemacht, um auszuschließen, daß es am Fernseher, Grafikkarte oder sonstwas liegt, da funktioniert es einwandfrei.

    Irgendwo scheine ich was verstellt zu haben, nur wo?

    Ich habe mal einen Screenshot angehängt, was ein wenig seltsam ist, nach dem Speichern steht immer VGA2SCART_16_9 in der "Frequenz Voreinstellung", das war vorher nicht so.

    Die syslog und Xorg.x.log zeigen keine Auffälligkeiten.


    Meine Frage, wo werden die Einstellungen zu den Bildschirmen von yavdr gespeichert?


    Ich fummele jetzt seit gestern rum und finde keine Lösung und das bei der Hitze.||;)


    Hülfää

    massi



  • Meine Frage, wo werden die Einstellungen zu den Bildschirmen von yavdr gespeichert?

    Die Konfiguration des X-Servers ist in der /etc/X11/xorg.conf.yavdr gespeichert. Die Datei wird aus den Templates in /usr/share/yavdr/templates/etc/X11/xorg.conf.yavdr/ und den Werten aus der /var/lib/yavdrdb.hdf erzeugt - zur Template-Syntax: http://www.clearsilver.net/docs/


    Das Webfrontend zieht seine Informationen aus der NVCtrl API, die vom nvidia-Treiber angeboten wird: https://github.com/yavdr/yavdr…/yavdrweb-ng/get_x11.ecpp


    VGA2Scart_16_9 sorgt effektiv dafür, dass bestimmte Frequenzen und eine bestimmte Modeline in die xorg.conf geschrieben wird: https://github.com/yavdr/yavdr….yavdr/0550_monitor0-body


    Wenn könnte man versuchen am Webfrontend vorbei die Konfiguration des X-Servers anzupassen, aber wenn die neue Karte die Frequenzen nicht liefern kann, brauchst du entweder die alte Hardware oder einen anderen Weg um das Signal an den TV zu bringen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke für Deine Antwort!

    Zitat



    aber wenn die neue Karte die Frequenzen nicht liefern kann,


    Wie ich schrieb, die neue Karte liefert die Frequenzen, eine frische yavdr Installation mit frodo ppa liefert ein einwandfreies Bild.

    Nur mit meiner Produktivinstallation nicht mehr, das ist ja das Seltsame.


    Vielleicht noch als Ergänzung, die Karte läuft im Dual Head Betrieb und am zweiten Ausgang ist ein analoger Monitor für graphtftng angeschlossen, wenn ich primären und sekundären Monitor in den Anzeigeeinstellungen vertausche, habe ich das graphtftng Bild astrein auf dem Fernseher und auf dem Monitor ein einwandfreies Fernsehbild, tausche ich zurück, habe ich zwar auf dem Monitor das korrekte graphtftng Bild aber kein vernünftiges Fernsehbild.


    Vielleicht sollte ich mal verschiedene yavdr Komponenten neu installieren, nur welche?