[gelöst] [yavdr-ansible] ppas werden nicht gefunden ...

  • Hallo!


    Ich habe mir auf dem u.a. System auf einer eigenen Partition ubuntu18 Server installiert und Updates gemacht (apt-get update & dist-upgrade).

    Nach einem Reboot habe ich mir so das Playbook geladen und gestartet:


    Code
    1. git clone https://github.com/yavdr/yavdr-ansible
    2. cd yavdr-ansible
    3. sudo ./install-yavdr.sh

    Bei der Installation kommen dann Fehler, dass die ppas nicht gefunden werden.

    Habe dann das Skript noch zweimal gestartet, hat aber nichts geholfen.


    Leider habe ich erst jetzt gesehen, dass die obigen Befehle für ubuntu 16 sind.


    Wie komme ich an das Playbook für ubuntu18?

    Wie bekomme ich das „halb-abgearbeitete“ Playbook wieder sauber entfernt?


    Danke schon jetzt für eure Hilfe!

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Auf der Seite https://github.com/yavdr/yavdr-ansible kannst Du den Branch "bionic" auswählen.

    Dort steht dann in der readme ganz unten, welche Befehle notwendig sind für Ubuntu 18.


    Code
    1. sudo apt-get install git
    2. git clone https://github.com/yavdr/yavdr-ansible
    3. cd yavdr-ansible
    4. git checkout bionic
    5. sudo -H ./install-yavdr.sh

  • Vielen Dank für die rasche Antwort!

    Die Möglichkeit des Branch-Wechsel habe ich in der Mobilversion von github übersehen.

    Werde ich gleich ausprobieren.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Leider kommen damit die gleichen Fehler wieder - siehe Anhang.


    Werde wohl die Partition formatieren u nochmal von vorne beginnen mit der Server Installation.

  • Es sollte genügen, wenn du die Einträge für ppa:yavdr/main aus der Konfiguration von apt entfernst, also /etc/apt/sources.list.d/ppa_yavdr_main_bionic.list (oder meinetwegen auch alle Dateien in /etc/apt/sources.list.d/) entfernst.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke für deine Antwort!


    Ich hatte aber vorher schon neu installiert (Ubuntu geht ja in ca. 15 Minuten) und trotz einer Fehlermeldung von ansible (bzgl. nvidia) habe ich nach Reboot ein Bild, aber keinen Ton :wow

    Zugegeben: ich habe manuell eine Zeile für ZDF in der channels.conf erfasst - viell. habe ich mich dabei vertippt.


    Fakten zu Ubuntu18 und yavdr-ansible sind:

    • die Startzeit vom Reboot bis zum Bild ist super schnell < 1 Minute :tup
    • die Fernbedienung (CIR) funktioniert ootb :tup
      aber seit Umstellen auf den Skin osd2web (via OSD) geht die Fernbedienung nicht mehr :wand
    • suspend to ram per systemctl suspend funktioniert und das noch super schnell (< 10 s!)
      allerdings gibts nach Aufwachen (auch sauschnell) "buntes Schneegestöber" - die Konsole geht aber


    Ich muss mich wohl noch gaaaaanz viel mit dem neuen System beschäftigen (Ton, SuspendToRAM, DVBAP!, oscar, skindesigner, epgd&co, etc.);

    der WAF bleibt aber in der Zwischenzeit durch Dualboot mit yaVDR 0.6 (trotz einiger Problemchen dort) gottseidank erhalten!


    seahawk1986 : Kannst du schon bauchgefühlsmässig abschätzen, wann es einen ertsen Wurf von yaVDR 0.7 (auf Ubuntu18+ansible-Basis) geben wird?

    Wie kann man dich/euch dabei am besten unterstützen (wenn man kein großer C++ Programmierer ist)?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Ich hatte aber vorher schon neu installiert (Ubuntu geht ja in ca. 15 Minuten) und trotz einer Fehlermeldung von ansible (bzgl. nvidia) habe ich nach Reboot ein Bild, aber keinen Ton

    Weißt du eventuell noch, was in der Fehlermeldung stand? Ggf. muss man den installer noch ein zweites Mal aufrufen, wenn vor dem Reboot der nvidia-Treiber nicht erfolgreich geladen werden konnte, damit die automatische Erkennung des 50Hz-Modul klappt.


    Zum Ton: du kannst im VDR-OSD das pulsecontrol-Plugin nutzen, um die Audioausgabe zu konfigurieren. Normalerweise genügt es unter "verschiebe Wiedergabe" den gewünschten Ausgang zu wählen.

    die Startzeit vom Reboot bis zum Bild ist super schnell < 1 Minute

    Zeig mal die Ausgabe von systemd-analyze blame und systemd-analyze critical-chain, vermutlich kann man mit einer statischen IPv4-Addresse und deaktivertem DHCP für IPv6 noch einiges rausholen.

    aber seit Umstellen auf den Skin osd2web (via OSD) geht die Fernbedienung nicht mehr

    Damit trittst du die Kontrolle an osd2web ab - das bietet auf Port 4444 das Webinterface an und nachdem man sich ein Theme ausgesucht hat, gibt es unten links ein Knöpfchen, mit denen man eine Ferbedienung einblenden und das OSD aufrufen und steuern kann.


    Wenn man das nicht über osd2web zurücksetzen will, kann man man den VDR mit systemctl stop vdr stoppen, dann in der /var/lib/vdr/setup.confden Wert OSDSkin = lcars setzenund startet den VDR wieder mit systemctl start vdr starten.

    Oder man nimmt dbus2vdr, während der VDR läuft: vdr-dbus-send /Skin skin.SetSkin string:'lcars'

    allerdings gibts nach Aufwachen (auch sauschnell) "buntes Schneegestöber" - die Konsole geht aber

    Standby habe ich noch nicht ausprobiert und Skripte, die den VDR vor dem Standby stoppen oder die DVB-Treiber neu laden lassen, gibt es noch nicht - die müsste noch jemand erarbeiten.

    Wie kann man dich/euch dabei am besten unterstützen (wenn man kein großer C++ Programmierer ist)?

    Ich bin kein großer C++ Programmierer, nach Möglichkeit bleibe ich bei Shell-Skripten und Python - halt überall da, wo man um die Geschwindigkeitsvorteile von C++ herum kommt ...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke für deine ausführliche Antwort!


    Hier die Fehlermeldungen - leider nur als Bilder.


    Die restlichen Punkte kann ich frühestens morgen probieren, falls ich mal an den TV rankomme...

  • Hier die Fehlermeldungen - leider nur als Bilder.

    Man könnte ja auch eine SSH-Verbindung nutzen ;)

    Aber das sieht in der Tat so aus, als ob der nvidia-Treiber vor dem Reboot nicht funktionieren will.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Nein kann ich nicht, weil Dualboot:

    Entweder Ubuntu18 ODER yaVDR 0.6 - leider.


    Werd ich dann mal probieren, wenn die Mädls nicht Fußball schauen.


    Edit:

    Ach du meinst wg den Bildern :wand Da hab ich zu spät dran gedacht beim Installieren; wollte unbedingt schnell rebooten u schauen obs geht ^^

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Dein Tipp mit dem dbus2vdr-Befehl hat einwandfrei geklappt.

    Auch der Ton ist jetzt da, wie du beschrieben hast. Vielen Dank schon mal dafür!!!

    Zeig mal die Ausgabe von systemd-analyze blame und systemd-analyze critical-chain, vermutlich kann man mit einer statischen IPv4-Addresse und deaktivertem DHCP für IPv6 noch einiges rausholen.

    Update:

    Ich habe auf einer Extrapartition (/dev/sda4) mein /srv-Verzeichnis vom yaVDR 0.6 mit Aufnahmen und Filmen liegen.

    Ubuntu18+ansible (/dev/sda6) hat offenbar ein eigenes srv-Verzeichnis angelegt.

    Wie kann ich das alte Verzeichnis im neuen Ubuntu statt dem dortigen einbinden?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von davie2000 () aus folgendem Grund: /srv