yaVDR wacht nach "Suspend to Ram" nicht mehr auf ...

  • Hallo!


    Seit dem letzten Update vor ein paar Tagen, mag unser yaVDR nicht mehr aus dem Ruhezustand aufwachen.


    Man sieht dann nur einen verpixelten schmalen Balken oben und drunter steht "CPU0 ..." und "CPU1 ...", ansonsten schwarzes Bild - siehe Foto im Anhang.

    Egal wie lange ich warte, mehr passiert nicht. Nur ein beherzter Druck auf die Reset-Taste erweckt den VDR wieder zum Leben.


    Im Syslog steht zwischen dem Beenden (suspend-to-ram) und dem neuerlichen Start nach Hardware-Reset-Taste einfach gar nichts; es gibt nur eine zeitliche Lücke:


    Hat jemand eine Idee, wie ich den Ruhezustand wieder zum Laufen bekomme?

    Braucht ihr noch weitere Log-Auszüge? Wenn ja: früher oder später?


    Vielen Dank schon jetzt für eure Hilfe!

  • Braucht ihr noch weitere Log-Auszüge? Wenn ja: früher oder später?

    Früher - idealerweise ab dem Zeitpunkt, an dem der Standby vom VDR-Shutdownhook eingeleitet wurde.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hier der gewünschte Auszug kurz vor dem shutdown bis zum Einfrieren. Ich kann da leider nichts Auffälliges entdecken.

    Ich hatte im webif mehrmals die Abschaltmethode umgestellt und am Ende wieder zurück auf "suspend to ram" - daher die "debug: parsing"-Einträge.


    https://pastebin.com/NZh6Ds4B


    Danke für deine Unterstützung!

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Habe jetzt beim Ausschalten ein mal einen segfault im syslog gehabt:

    May 30 22:02:14 myVDR kernel: [117681.249247] device 1 TS buf[31485]: segfault at a ip 00007f788fbf07d9 sp 00007f77ffaae9c0 error 4 in libc-2.19.so[7f788fb72000+1be000]6-07]Kann das mit dem Nicht-mehr-aufwachen zusammenhängen?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Habe erst jetzt festgestellt, dass offenbar seit 27.03.2018 keine Änderung der/var/cache/vdr/acpiwakeup.time.old mehr erfolgt ist:


    Code
    1. Jun 2 19:25:27 myVDR vdr-frontend[2048]: acip-wakeup.time.old hatte Wert: Tue Mar 27 18:08:00 2018
    2. Jun 2 19:25:27 myVDR vdr-frontend[2048]: vergleiche mit jetzt: Sat Jun 2 17:25:27 2018

    Heißt das, dass suspend-to-ram damals das letzte Mal erfolgreich gelaufen ist?

    Die Datei gehört übrigens dem User vdr und kann von ihm geändert werden: -rw-r--r-- 1 vdr vdr 20 Apr 9 13:44 acpiwakeup.time.old

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Ich bin jetzt nach Anleitung "DebuggingKernelSuspend" vorgegangen und kann jetzt tatsächlich im Output von dmesg eine "Magic number" mit "hash matches" finden:

    Code
    1. [ 0.658856] Magic number: 6:813:227
    2. [ 0.658899] acpi PNP0200:00: hash matches
    3. [ 0.658954] rtc_cmos 00:05: setting system clock to 2018-06-05 12:12:51 UTC (1528200771)


    lspci liefert leider nichts, was ich damit in Verbindung bringen würde:


    Das einzige Gerät "PNP0200" das ich finde ist der Ordner /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:01/PNP0200:00 mit folgendem Inhalt:

    Code
    1. ls -l
    2. insgesamt 0
    3. -r--r--r-- 1 root root 4096 Jun 5 14:24 hid
    4. -r--r--r-- 1 root root 4096 Jun 5 14:24 modalias
    5. -r--r--r-- 1 root root 4096 Jun 5 14:24 path
    6. lrwxrwxrwx 1 root root 0 Jun 5 14:24 physical_node -> ../../../../../pnp0/00:04
    7. drwxr-xr-x 2 root root 0 Jun 5 14:19 power
    8. lrwxrwxrwx 1 root root 0 Jun 5 14:24 subsystem -> ../../../../../../bus/acpi
    9. -rw-r--r-- 1 root root 4096 Jun 5 14:12 uevent

    Der Symlink vom "physical_node" zeigt auf /sys/devices/pnp0/00:04 mit folgendem Inhalt

    Code
    1. ls -l
    2. insgesamt 0
    3. lrwxrwxrwx 1 root root 0 Jun 5 14:27 firmware_node -> ../../LNXSYSTM:00/device:00/PNP0A08:00/device:01/PNP0200:00
    4. -r--r--r-- 1 root root 4096 Jun 5 14:13 id
    5. -r--r--r-- 1 root root 4096 Jun 5 14:27 options
    6. drwxr-xr-x 2 root root 0 Jun 5 14:19 power
    7. -rw-r--r-- 1 root root 4096 Jun 5 14:27 resources
    8. lrwxrwxrwx 1 root root 0 Jun 5 14:27 subsystem -> ../../../bus/pnp
    9. -rw-r--r-- 1 root root 4096 Jun 5 14:12 uevent


    Um welches Gerät handelt es sich jetzt konkret?

    Und wie finde ich dann heraus, warum genau dieses nicht mehr aufwachen mag?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Ich hatte mal - nach Umstieg auf Kernel 4.10 - ein ähnliches Problem, glaub sogar hier gepostet, find' ich aber selbst nicht mehr.

    Yavdr siehe Signatur. Das Problem war in der /usr/share/vdr/shutdown-hooks die Datei S90.acpiwakeup.

    Und zwar wird immer noch geprüft, ob /proc/acpi/wakeup für Kernel <6.2.23 (!)

    oder /sys/class/rtc/rtc0/wakealarm für neuere Kernel verwendet werden soll.

    Das funktionierte bisher, aber mittlerweile ist /proc/acpi/wakeup wieder vorhanden und auch beschreibbar, aber ohne Effekt.

    Wenn ich nicht viel ändern will, brauche ich nur die Reihenfolge der Abfragen im Script S90.acpiwakeup zu ändern,

    und zwar so daß

    die beiden Abfragen jeweils vertauscht werden, wie hier ersichtlich :)

    Das sollte natürlich getemplated werden, um auch ein Update zu überleben, bei dem mal wieder yavdr-essentials neu installiert werden muß.

    --
    hdvdr: Intel(R) Xeon(R) CPU W3520, 12 GB Ram, Grafik nvidia GeForce GT 430, nvidia-396
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und 2xDVB-C/T Tunern, TT-3200 (SAA7146) mit 1xDVB-S2 + FB,
    System btrfs, apt-btrfs-snapper,+5x1TB Raid5 XFS, yavdr0.6-frodo, Kernel 4.15.0-38-generic

    mit DD-S2+C+SAA7146-Support, epgd/tvm/tvsp, vdradmin-am, vdrmanager

  • Danke für deine ausführliche Antwort!

    Das wär aber dann ein grober Schnitzer, der sicherlich mehreren yaVDR-Nutzern aufgefallen wäre, oder?

    Kernel müsste übrigens 3.13 sein. Hab da nie bewusst was gemacht, außer apt-get update & dist-upgrade.


    Aber ich werds mal probieren, verzweifelt wie ich bin.


    Update:

    Bei mir wird hier auf Version 2.6.2 abgefragt und mein Kernel > 2.6.3 daher sollte ja eh „wakealarm“ verwendet werden, oder?


    Update2:

    Jetzt hab ichs geschnallt, sorry.


    Update3:

    Ausprobiert (Gte und Lte vertauscht) und jetzt kommt beim Ausschalten: „ACPI not installed - Shutdown abgebrochen“

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von davie2000 ()

  • Hmm, ja, mit 3.13 (uname -a gibt Auskunft) gab es das Problem noch nicht, da "wakealarm" nicht mehr und noch nicht wieder schreibbar war :)

    Schade, daß der Hund woanders begraben liegen muß ...

    --
    hdvdr: Intel(R) Xeon(R) CPU W3520, 12 GB Ram, Grafik nvidia GeForce GT 430, nvidia-396
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und 2xDVB-C/T Tunern, TT-3200 (SAA7146) mit 1xDVB-S2 + FB,
    System btrfs, apt-btrfs-snapper,+5x1TB Raid5 XFS, yavdr0.6-frodo, Kernel 4.15.0-38-generic

    mit DD-S2+C+SAA7146-Support, epgd/tvm/tvsp, vdradmin-am, vdrmanager

  • Habe deinen Tipp mit WOL (aus anderem Thread) ausprobiert, aber mein yaVDR scheint überhaupt nicht auf WOL zu reagieren - habe ich wohl noch nie eingerichtet, weil nie gebraucht.

    Wäre aber auch blöd, wenn ich den yaVDR nach dem Einschlafen (suspend-to-ram) nur mehr per WOL wecken könnte - WAF!


    Wenn es stimmt, dass S3 seit 27.3.18 nicht mehr funktioniert (siehe #5), dann tippe auf ein Kernelupdate; der Nvidia-Treiber (384) wurde nämlich erst kürzlich aktualisiert, als S3 schon nicht mehr funktionierte.

    Hat niemand eine Idee woran suspend-to-ram (plötzlich) scheitert?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Habe jetzt sogar Die Kernel-Boot-Option „reboot“ mit allen möglichen Einstellungen (bios,acpi,...) ausprobiert, aber der PC friert beim Aufwachen sofort ein. ☹️

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Moment ... wenn WOL, dann gleich S5, also herunterfahren. Im Bios sollte es eine Einstellung für WOL geben, die sicherstellt, daß die Netzwerkkarte (geht aber nur mit onboard-Karten oder wenn eigene Standby-Versorgung) aus dem Standby-Strom versorgt wird.

    Als Richtlinie sollte auch bei abgeschaltetem Rechner die LED beim Netzwerkanschluß leuchten, so vorhanden.

    --
    hdvdr: Intel(R) Xeon(R) CPU W3520, 12 GB Ram, Grafik nvidia GeForce GT 430, nvidia-396
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und 2xDVB-C/T Tunern, TT-3200 (SAA7146) mit 1xDVB-S2 + FB,
    System btrfs, apt-btrfs-snapper,+5x1TB Raid5 XFS, yavdr0.6-frodo, Kernel 4.15.0-38-generic

    mit DD-S2+C+SAA7146-Support, epgd/tvm/tvsp, vdradmin-am, vdrmanager

  • Hab leider im Bios nichts zu WOL finden können.

    Die LED von LAN-Anschluß leuchtet bei ausgeschaltetem PC.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Die Option heißt Power On by PCI-E/PCI, da die Onboard-NIC eigentlich eine PCI-E/PCI Karte ist.


    Solltest du ein Mainboard mit aktueller Intel-NIC haben, würde ich das hier im Hinterkopf behalten, falls die Box Sekunden nach

    dem Shutdown automatisch wieder aufwacht.


    Eventuell ist aber auch (zusätzlich) WOL nicht sauber konfiguriert. Dazu muss auf der NIC das MagicPacket eingetragen werden.


    Code
    1. root@yavdr:~# ethtool eth0 | grep Wake-on
    2. Supports Wake-on: pumbg
    3. Wake-on: g

    So sollte das aussehen, wobei du natürlich eth0 durch den Devicenames deines NIC ersetzen musst.


    Setzen kannst du das via ethtool -s eth0 wol g und einen reboot überlebt es, wenn du eine udev-rule dafür bastelst:

    Code
    1. /etc/udev/rules.d/99-wol.rules:
    2. ACTION=="add", SUBSYSTEM=="net", NAME=="eth*", RUN+="/usr/bin/ethtool -s $name wol g"


    Cheers,

    Ole

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von OleS ()

  • Bzgl. suspend-to-ram: war es nicht immer notwendig, diverse Kernelmodule (nvidia, ddbridge, usw.) vor dem STR manuell zu ent- und beim start wieder zu laden?


    Da muss die Datei /etc/yavdr/force-reload-modules.list existieren, bzw. angelegt werden. Anschließend die betroffenen Module mit Namen rein und testen.


    Cheers,

    Ole

  • Danke, Ole, für deine Antworten!


    Jetzt wo du es sagst: ich hatte das schon mal benötigt, war dann aber nicht mehr notwendig - siehe Thread.


    "Damals" stand "dvb-core" in der Datei, werde ich gleich mal ausprobieren ...

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Habs jetzt mit „dvbcore“ und „nvidia“ bzw beidem probiert - keine Änderung.


    Ich glaube auch nicht, dass es damit zu tun hat, weil das Einfrieren viel zu schnell passiert.

    Das Freeze-Bild (siehe oben) kommt fast unmittelbar (< 1 s) nach dem Einschalten.


    Noch jemand einen Tipp? biiiiiiitttte 😰


    Update:

    Habe gelesen, dass mancheiner (Lars *zwinker*) wohl yaVDR mit S5 betreibt.

    S4 (od S5) wäre mir ja sogar noch lieber, aber ich fürchte, dass dafür erstmal S3 sauber laufen muss.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von davie2000 ()

  • Bin jetzt sogar zurück auf den nvidia Treiber 304(.135) und habe bei „reload-modules“ „nvidia“ u „dvb-core“ eingetragen.

    Immerhin steht jetzt beim Ausschalten am Schluss was von „suspend mem“ im syslog. Aber beim Auswachen friert er wieder ein 😭


    (Btw: WOL funzt jetzt. Danke Ole, es war die „PCI“-Option)


    Habe mal kurz mit yaVDR 0.5 getestet (Dualboot) u dort klappt das Aufwachen aus S3 problemlos u ohne reload modules/services????

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von davie2000 ()

  • Hmm. Bei mir kommt nach "CPU..." die dmesg-Meldung über ACPI-S3 Wakeup und dann USB:

    Jun 8 07:11:40 hdvdr kernel: [32792.560230] CPU3 is up

    Jun 8 07:11:40 hdvdr kernel: [32792.562841] ACPI: Waking up from system sleep state S3

    Jun 8 07:11:40 hdvdr kernel: [32792.602433] usb usb3: root hub lost power or was reset

    Jun 8 07:11:40 hdvdr kernel: [32792.602442] usb usb4: root hub lost power or was reset


    Ich würde mal eventuell verbundene externe USB-Geräte abhängen, wenn möglich ...


    Wie sieht dmesg bei Version 0.5 aus?

    --
    hdvdr: Intel(R) Xeon(R) CPU W3520, 12 GB Ram, Grafik nvidia GeForce GT 430, nvidia-396
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und 2xDVB-C/T Tunern, TT-3200 (SAA7146) mit 1xDVB-S2 + FB,
    System btrfs, apt-btrfs-snapper,+5x1TB Raid5 XFS, yavdr0.6-frodo, Kernel 4.15.0-38-generic

    mit DD-S2+C+SAA7146-Support, epgd/tvm/tvsp, vdradmin-am, vdrmanager

  • Hmmmm ... danke für den Hinweis! Das habe ich offenbar übersehen. Schaut bei mir (dmesg) ganz anders aus.

    Das einzige USB-Gerät, das bewusst angesteckt ist, benötige ich um Sender hell zu kriegen.

    Aber natürlich werde ich ausprobieren, ob der S3 ohne USB-Gerät dann funktioniert.


    Update:

    Hatte neben dem Kartenleser auch noch eine USB-Tastatur dran. Habe beides abgezogen und einen Reboot durchgeführt.

    Dann den VDR ca 5 Minuten laufen lassen und dann in S3 versetzt. Dann ca. 2 Minuten gewartet und aufgeweckt. Aber friert er leider sofort wieder ein.

    Daran liegts also auch nicht. :wand

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von davie2000 ()