werden die Gentoo ebuilds noch gepflegt?

  • Würde mich auch interessieren. vdr-2.4.0 ist jetzt schon eine ganze Weile raus. Im vdr-devel ist aber sogar noch die 2.3.1 maskiert. Ein Ebuild für die 2.4.0 konnte ich in den großen weiten Welten des Internets überhaupt nicht finden. Der Status der meisten Plugins ist wenig positiv.

    Ich würde gern mal die 2.4.0 ausprobieren. Das Problem an der Sache ist, dass ich die 2.3.2 auch nur mit irgendwelchen Patches zum Laufen bekommen hab. Und bei mir muss zwingend vdr-sc und vdr-vnsi laufen. Die 2.3.2 funktioniert momentan ziemlich problemlos. Wenn ich mit der 2.4.0 meine aktuelle Config versau, streikt die Familie. :)

  • Ehrlich gemeinte Frage aber nutzt Gentoo denn überhaupt noch jemand?

    Ja, doch, ich.

    andere Distros sind in dessen Fußstapfen getreten.

    Welche?


    Ich finde dieses Konzept immer noch gut. Wenn ich z.B. TinkerOS und Gentoo vergleiche sind grosse Geschwindigkeitsvorteile auf Seiten von Gentoo. Mit wenigen Einstellungen läuft das selbe OS auf einem Server, Schlepptop oder einem kleinen ARM Bastelboard. Ich find's gut.


    Gruss zille

  • Hier läuft auch gentoo auf dem Xen-Server inclusive aller domUs sowie auf 2 vdr-clients (einer virtualisiert, einer auf echter Hardware).


    Die ebuilds der vdr-Serie habe ich allerdings nie genutzt und baue vdr und plugins neben dem portage-tree per Hand.


    Wenn ich die Probleme mit Updates einzelner Pakete bei vielen paketbasierten Distributionen (die nicht auf vdr spezialisiert sind) hier lese, habe ich nicht das Gefühl, daß sich gentoo überlebt hat. Das Konzept hat durchaus seine Berechtigung.


    Christian

  • *meld*

    Nutze es auf meinem PC, Notebook, HTPC und meiner ARM-Nas.


    Gerade auf der ARM-Nas wäre die notwendige Systemanpassung (Kernelpatch + Device Tree) mit anderen Distros wesentlich schwieriger.

  • Me too ... alle meine Rechner laufen mit Gentoo und die VDRs mit 2.4. Wenn ich mal Zeit hätte ....

  • Ich nutze schon ewig gentoo für alle Kisten hier und denke nicht daran umzusteigen.


    #gentoo-vdr ist auch seit Monaten tot. CvH hat recht - zzam hatte sich schon ewig nicht mehr um die vdr-skripte und ebuilds gekümmert und hdbrummy hat alleine offenbar keine Lust mehr gehabt. Das ein oder andere ebuild kam von Dritten, aber richtigen maintainer-Nachwuchs gab es nie.


    Also umsteigen auf handgebauten vanilla-vdr.


    VG michaelb

    Gentoo seit 0.26 :thumbup: - http://www.brakemeier.de

    :prost2

  • Jaein,


    zzam ist seit Jahren inactiv,

    idl0r hat in seinem It'ler Job genug zu tun,

    ich hab mich seit ca. 1Jahr (kann auch schon länger sein) mehr und mehr in die reale Welt zurückgezogen.

    Ich habe einfach mehr Spass daran mich mit meinen Freunden zu treffen, Motorrad zu fahren, Platten zu sammeln und zu hören,

    an meinem Röhren Amps zu basteln und diese weiter zu entwickeln, usw....

    Jaja, der analoge Kram nimmt auch 'ne Menge Zeit in Anspruch!

    Es gab bisher keinen Grund meine bestehende VDR Umgebung (xen vdr 24/7, frontend vdr Pi) anzufassen.

    Der Kram läuft und läuft und läuft....


    Wie auch immer, bestehende Änderungen um main tree zwingen mich da wieder activ zu werden.

    (Ehe das VDR Project von der Geschäftsleitung auf gentoo.org für tot erkärt wird...)

    Dadurch das EAPI 4,5 deprecated ist, hat sich da ein bisschen Arbeit aufgetan.


    Der Plan meinerseits sieht so aus:

    - vdr-plugin-2.eclass anpassen, das ist fast durch, braucht halt noch 'ne review von einigen Developern auf der gentoo-dev ML

    Da kommt jetzt EAPI=7 support hinzu.
    - Als nächstes müssen alle Plugins die noch mit EAPI 4,5 versehen sind angefasst werden und am besten gleich auf EAPI 7 hochgezogen werden.


    - Danach kommt der eapi 4,5 support aus der vdr-plugin-2.eclass raus.

    Note: Alle user die in ihrem local tree plugins mit diesen eapi's haben, sollten diese local anpassen.

    https://dev.gentoo.org/~mgorny…mate-guide-to-eapi-7.html

    Wenn eapi 4,5 raus ist werden diese nicht mehr compilieren!


    Plugins die ich anfassen, die nicht ohne grossen aufwand compiliern, die tot seit Jahren sind von Seiten der Entwickler,

    wo es keine Project pages mehr gibt, werde ich maskieren und aus dem Tree entfernen.

    Keine Angst, zu jedem dieser Plugins gibt es dann einen Bug auf bugs.gentoo.org, ihr habt dann ca 4 Wochen zeit Euer begründetes Veto einzulegen.

    Ein Paar plugins werden auch einfach unter den Hammer kommen. Ganz ehrlich, wer von euch braucht denn ein vdr-joystic oder vdr-wapd plugin
    oder irgendwelche spiele plugins.

    Der VDR und seine Plugins sollte das machen wofür er von KLS enwickelt wurde. Aufzeichnen und wiedergeben.

    Ich halte es da mit Klaus, "Keep it simple", den ganzen schnick schnack braucht man doch wirklich nicht.


    Als letztes kommt dann endlich der vdr-2.4 in bearbeitung, sorry leider an letzter Stelle

    Der macht auch 'ne Menge Arbeit, bzw der VDR weniger, eher der anhängende Extpatch-ng, der den support für einige Plugins gibt.

    Das ist ein Haufen Arbeit da alle patches wieder unter einen Hut zu bringen, gerade durch die major changes im core vdr.

    Auch da werde ich den Rotstift ansetzen, nur noch die patches die von plugins benötigt werden, werden in diesen aufgenommen.

    Patches die das menu "schöner" machen, braucht doch wirklich kein Mensch.

    Mir ist das zb. egal ob das Menu bei 9 aufhört und dann die weiteren menu punkte nicht mehr nummeriert sind, (Vielleicht hat das KLS auch schon gefixt)


    Sorry, bitte habt dafür Verständis, das der VDR nicht mehr an Punkt 1 bei mir steht und

    das sich mein Leben ein bisschen vom VDR weg entwickelt hat.


    Danke erstmal


    Cheers :prost2


    /bin/joerg


    P.S ich fürchte wenn ich damit durch bin, ist gcc-7 im tree etabliert und dann geht der ganz Kram wieder von vorne los.... :wand

  • Ketzer! :)
    Sorry, aber da hast du dir den schlechtesten Artikel ausgesucht der im Netz zu finden ist.

    Dramatisierung aka Bildzeitungsreport hilft hier keinem weiter.


    Zum Thema: Ja, ich nutze Gentoo seit vielen Jahren (ab anfang 2006), und würde es auch mit VDR gerne noch viele weitere Jahre nutzen.
    Aber schön zu hören das hd_brummy noch Mut hat - danke! :)


    Nette Grüße