[vdr-epgfixer-0.3.1] kompiliert mit vdr-2.4.0 nicht

  • Hallo,


    ich bekomme beim kompilieren von epgfixer-0.3.1 die folgende Fehlermeldung:


    Code
    1. epgclone.c: In member function 'void cEpgClone::CloneEvent(cEvent*, cEvent*)':
    2. epgclone.c:50:18: error: 'Channels' was not declared in this scope
    3. channelID = Channels.GetByNumber(dest_num)->GetChannelID();
    4. ^~~~~~~~
    5. epgclone.c:50:18: note: suggested alternative: 'cChannels'
    6. channelID = Channels.GetByNumber(dest_num)->GetChannelID();
    7. ^~~~~~~~
    8. cChannels
    9. make: *** [Makefile:78: epgclone.o] Error 1

    finde habe hier im Forum keinen entsprechenden Patch der das behebt.

    Gruß Marco


    HW: TT6400-S2
    SW: Fedora 34, kernel-5.13.6-300.fc34.x86_64, vdr-2.4.6-7.fc34.x86_64


    Fedora34 x86_64 Gnome Desktop 40.0 Ausgabe über das vdr-softhddevice plugin

    ViewSonic VX3276 HDMI-1 <------------> HDMI NVidia Geforce-gt-1030

    ViewSonic VX3276 HDMI-2 <------------> HDMI Technotrend S2-6400


  • Die aktuelle Git-Version baut gegen den VDR 2.4.0: https://projects.vdr-developer…/vdr-plugin-epgfixer.git/

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Die aktuelle Git-Version baut gegen den VDR 2.4.0: https://projects.vdr-developer…/vdr-plugin-epgfixer.git/

    oh, Danke das hatte ich übersehen, funktioniert nun :thumbup:

    Gruß Marco


    HW: TT6400-S2
    SW: Fedora 34, kernel-5.13.6-300.fc34.x86_64, vdr-2.4.6-7.fc34.x86_64


    Fedora34 x86_64 Gnome Desktop 40.0 Ausgabe über das vdr-softhddevice plugin

    ViewSonic VX3276 HDMI-1 <------------> HDMI NVidia Geforce-gt-1030

    ViewSonic VX3276 HDMI-2 <------------> HDMI Technotrend S2-6400