Shady Kiss - Position in Fortschrittsbalken fehlt

  • Hi,


    nach langem suchen haben wir endlich ein Skin gefunden, das allen gerecht wird. Nur haben wir damit ein komisches Problem: Wenn eine Aufnahme abgespielt wird, wird der Fortschrittsbalken unten wie erwartet angezeigt. Schnittmarken, Zeiten, alles da. Nur die Position nicht. Wir wissen also nie, wo genau wir aktuell sind - außer die Position befindet sich exakt auf einer Schnittmarke. Diese ist dann eingefärbt.

    VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5

  • Hallo,


    wird der Fortschrittsbalken unten wie erwartet angezeigt. Schnittmarken, Zeiten, alles da. Nur die Position nicht.

    offengestanden verstehe ich nicht, was du meinst. Wird vom Fortschrittsbalken nur der Hintergrund angezeigt, aber der farbige Balken nicht?


    Normalerweise sollte das je nach Thema so aussehen: replay_KISS.png

  • So wie auf deinem Bild wäre es Korrekt. Bei mir fehlt die farbige Unterlegung, die die Position anzeigt.

    VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5

  • Auf welcher Hardware läuft das?

    Fehlen sonst im Skin noch irgendwelche graphischen Elemente?

    Tritt das bei allen Farbthemes auf?

    Was sagt

    Code
    1. find /tmp/skindesigner/svg/shady_KISS -name replayProgress.svg

    ?

    Gibt es im Log irgendwelche Meldungen vom skindesigner, wenn du dieses Menü aufrufst?

  • Das läuft auf der HW VDR1 in meiner Signatur. Werde gleich noch die Grafikkarte ergänzen, die fehlt.


    Code
    1. root@vdr:~# find /tmp/skindesigner/svg/shady_KISS -name replayProgress.svg
    2. find: "/tmp/skindesigner/svg/shady_KISS": Datei oder Verzeichnis nicht gefunden

    Während eine Aufnahme abgespielt wird und der Balken (nicht) angezeigt wird:

    Code
    1. Apr 13 16:30:58 vdr vdr: [2828] animator thread thread started (pid=1305, tid=2828, prio=high)
    2. Apr 13 16:30:59 vdr vdr: [1305] [xine..put] OSD bandwidth: 10667850 bytes/s (83342 kbit/s)
    3. Apr 13 16:31:00 vdr vdr: [1305] [xine..put] OSD bandwidth: 1052468 bytes/s (8222 kbit/s)
    4. Apr 13 16:31:02 vdr vdr: [1305] [xine..put] OSD bandwidth: 1003650 bytes/s (7841 kbit/s)
    5. Apr 13 16:31:03 vdr vdr: [1305] [xine..put] OSD bandwidth: 792578 bytes/s (6192 kbit/s)
    6. Apr 13 16:31:04 vdr vdr: [1305] [xine..put] OSD bandwidth: 1066432 bytes/s (8331 kbit/s)
    7. Apr 13 16:31:04 vdr vdr: [2830] detacher thread thread started (pid=1305, tid=2830, prio=high)
    8. Apr 13 16:31:05 vdr vdr: [1305] [xine..put] OSD bandwidth: 570038 bytes/s (4453 kbit/s)
    9. Apr 13 16:31:07 vdr vdr: [1305] [xine..put] OSD bandwidth: 740868 bytes/s (5788 kbit/s)
    10. Apr 13 16:31:08 vdr vdr: [1305] [xine..put] OSD bandwidth: 370434 bytes/s (2894 kbit/s)

    Bilder

    VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5

  • Code
    1. root@vdr:~# find /tmp/skindesigner/svg/shady_KISS -name replayProgress.svg
    2. find: "/tmp/skindesigner/svg/shady_KISS": Datei oder Verzeichnis nicht gefunden


    yaVDR legt die aus den svg-templates erzeugten Graphiken wohl unter einem anderen Pfad ab...


    Aber nachdem ich jetzt weiß, dass du zur Ausgabe xineliboutput benutzt, vermute ich das Problem sowieso eher im Zusammenhang damit. Du könntest ja mal testweise mit softhddevice ausgeben.


    btw: der schmale horizontale schwarze Balken zwischen den Schnittmarken wird auch nicht angezeigt?

  • Nein, der schmale Balken wird auch nicht angezeigt. Nur, wenn der Fortschritt eine Schnittmarke trifft.


    Mit Softhddevice war was... Ich meine, das war uns zu häufig abgestürzt. Aber ich kann ja zumindest mal testen.

    VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5

  • Also, diverse Probleme mit dem Softhddevice. Ruckelndes Bild, kein Ton zum Beispiel. Der Balken wird aber auch dort nicht angezeigt.

    VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5

  • Ich wollte dich nicht zu einem Wechsel zu softhddevice überreden. Es ging nur darum, zu testen, ob das Problem bei dir auch damit auftritt.


    Fährst du irgendeine 'krumme' Auflösung?


    Würdest du bitte deine setup.conf des vdr posten.


    Würdest du bitte diese displayreplay.xml gegen die unter /usr/share/vdr/plugins/skindesigner/skins/shady_KISS/xmlfiles/ (ich hoffe der Pfad passt für yaVDR) austauschen und damit testen.

  • VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5

  • Bitte nochmal runterladen, habe umgestellt und die Datei ausgetauscht. Weil ich noch so viel anderes Zeug gesehen habe dachte ich, es werden einfach alle settings für jedes Skin gespeichert. Das XML file hat übrigens keine Änderung gebracht, Pfad stimmt.

    VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5

  • Kein Stress. Jup, bei Shady ist alles paletti.

    VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5

  • Auch mit den Einstellungen aus deiner setup.conf kann ich den Fehler hier nicht reproduzieren, was es für mich schwierig macht, die Ursache zu finden.


    Falls du noch Lust zu einem weiteren Test hast, schiebe diese displayreplay.xml wieder nach /usr/share/vdr/plugins/skindesigner/skins/shady_KISS/xmlfiles/ und diese replayProgress.svg nach /usr/share/vdr/plugins/skindesigner/skins/shady_KISS/skinparts/. Dann kurz in den Einstellungen zu einem anderen Skin wechseln und danach wieder shady_KISS einstellen.

  • Klar, aber erst heute Abend. Ich gebe dir dann Bescheid.

    VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5

  • Kann das am Grafiktreiber oder an irgendeiner Lib liegen? Oder an Speicher? Irgendwas war doch da mal.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Kann das am Grafiktreiber oder an irgendeiner Lib liegen? Oder an Speicher? Irgendwas war doch da mal.

    Genau kann ich das nicht sagen. Fakt ist ja allerdings, dass nur dieses Skin genau dieses Problem hat.

    Auf der anderen Seite verhält sich Softhddevice so merkwürdig, dass ich den Treiber nicht ausschließen möchte. Allerdings ist die Wiedergabe aller möglichen Inhalte mit xineliboutput einwandfrei. Also... Keine Ahnung.

    VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5

  • ... bei den Einstellungen des KISS unter Aufzeichnungen 'Helle Schnittbalken in der Wiedergabeprogressbar' auf 'Nein' stellen!

    Du meinst wirklich Kiss und nicht shady_kiss?

    VDR1: Silverstone SST-LC14S-M, M3N78, AMD Athlon64 5600+, 2G Ram, 2x SATELCO EasyWatch PCI DVB-C, NVIDIA GT218 [GeForce 210] (rev a2), YaVDR 0.6.1
    VDR2: Antec Mini-ITX Case "ISK300-65", AT3IONT-I Deluxe, 2GRam, 32G SSD, Atric Einschalter, YaVDR 0.6.1
    VDR4: Antec Fusion Remote, GA-M68MT-D3, EN210 Silent/DI/512MD2 LP, SATELCO EasyWatch PCI DVB-C, YavDR 0.5