[vdr-2.3.9] "corrupted size vs. prev_size" on restart

  • Hi,

    es gibt noch einen neuen Effect, wenn man ueber das Menu einen Restart macht oder auf der console den VDR mit CTRL-C beendet kommt.


    corrupted size vs. prev_size

    Aborted (core dumped)


    kommt das vielleicht aus der glibc "malloc_printerr (check_action, "corrupted size vs. prev_size", P, AV);"


    CU

    9000h


    vdr-2.3.9 satip softhddevice/vaapidevice

    Es ist eagl in wlehcer Reiehnfogle die Bchustebaen in Woeretrn vokrmomen. Huapstache der estre und leztte Bchustbae sitmmen.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von 9000H ()

  • Ist das jetzt ganz neu in der 2.3.9 aufgetreten, oder auch schon in früheren Versionen?


    Auf den ersten Blick würde ich sagen, dass da das vaapidevice-Plugin was durcheinanderbringt.

    Mir ist nicht klar, wozu es cSoftRemote braucht. Eine eigent Funktionalität hat es ja offensichtlich nicht,sondern ruft in jedem Fall cRemote::Put() auf.


    rofafor : What is the purpose of cSoftRemote in vaapidevice?


    Klaus

  • Ich verwende hier auf einem VDR auch softhddevice und dort tritt das aber nicht auf.

    Mir fällt jetzt auch keine Änderung in der 2.3.9 ein, die so ein Problem triggern könnte.


    Klaus

  • Hi,

    vielleicht hängt es mit der Reihenfolge der Plugins zusammen.

    Code
    1. so gibt es den crash
    2. vdr -Pfemon -P"satip -d2 -s 192.168.178.129:554|DVBS2-4,DVBT2-2|minisatip" -P"vaapidevice -d :0.0 -v va-api -a pulse -c softvol -w alsa-driver-broken"
    3. so gibt es keinen crash
    4. vdr -Pfemon -P"vaapidevice -d :0.0 -v va-api -a pulse -c softvol -w alsa-driver-broken " -P"satip -d2 -s 192.168.178.129:554|DVBS2-4,DVBT2-2|minisatip"

    CU

    9000h

    Es ist eagl in wlehcer Reiehnfogle die Bchustebaen in Woeretrn vokrmomen. Huapstache der estre und leztte Bchustbae sitmmen.

  • Da ich das mit meiner Version von softhddevice (vdr-plugin-softhddevice-vpp_support_logging von 2017-04-02) nicht nachvollziehen kann (egal in welcher Reihenfolge ich die Plugins lade), habe ich mir jetzt mal die aktuelle Version von vaapidevice geholt (von

    https://github.com/rofafor/vdr-plugin-vaapidevice). Beim Übersetzen bekomme ich die Meldung


    video.c:47:2: warning: #warning "libva is too old - please, upgrade!" [-Wcpp]


    und wenn ich es mit


    -P 'vaapidevice -v va-api -g 920x520+1000+560 -a hdmi:CARD=PCH,DEV=0,AES0=0x04 -p hdmi:CARD=PCH,DEV=0,AES0=0x06'

    lade (das sind Parameter, die ich für softhddevice verwendet habe), wird das Log mit Meldungen der Form


    buchstäblich *geflutet*


    Mache ich was falsch?

    Gelten die Parameter von softhddevice nicht mehr für vaapidevice?

    Warum ist libva schon wieder zu alt? (openSUSE 42.2!)


    Da vaapidevice anscheinend deutlich schlanker ist als softhddevice (und auch beim Übersetzen nicht so dermaßen viele Warnungen bringt wie softhddevice ;-) würde ich schon gerne darauf umsteigen. Allerdings habe ich damals mit viel Mühe meinen VDR mit softhddevice zum Laufen gebracht und würde nur umsteigen, wenn das als "drop in replacement" geht...


    Fazit: ich kann den Fehler hier nicht nachvollziehen und daher leider auch nicht debuggen.


    Klaus

  • Warum ist libva schon wieder zu alt? (openSUSE 42.2!)

    Die Paketversionen in OpenSuse Leap 42.2 sind im besten Fall auf dem Stand von Ende 2016 und seit Ende Januar 2018 ist das Release ungepflegt: https://de.opensuse.org/Produktlebensdauer - aktuell wäre OpenSuse Leap 42.3


    Wenn man die kurze Lebensdauer von OpenSuse Leap nicht mag, könnte man überlegen Debian zu nehmen, da kann man für x86-kompatible CPUs bis zu 5 Jahre auf einer gepflegten "stabilen" Version sitzen (wenn man mit den vorhandenen Versionsständen zu frieden ist) oder mit Debian testing relativ unproblematisch Paketversions-Updates mitnehmen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Warum ist libva schon wieder zu alt? (openSUSE 42.2!)

    Auch mit openSUSE 42.3 ist die libva zu alt. Hier hilft das Einbinden eines entsprechenden Repositories, um auf libva 2.0 zu wechseln.

    Ggf. über yast2 die entsprechenden Pakete installieren - ich meine mich an einen Namenswechsel zu erinnern:

    1.7.x vaapi-intel-driver

    2.0.x intel-vaapi-driver


    Stefan

    Code
    1. zypper ar -f http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_Leap_42.2 X11:Xorg
    2. zypper ref
    3. zypper dup
  • kls schrieb:

    Gelten die Parameter von softhddevice nicht mehr für vaapidevice?

    Warum ist libva schon wieder zu alt? (openSUSE 42.2!)

    Welche Version von libva ist denn bei openSUSE 42.2 dabei? Was sagt das Kommando "vainfo"? Obwohl die Entwickler von vaapidevice ja eine libva >=2.0.0 empfehlen, funktionert es bei mir auf Mint 18.3 auch mit der veralteten libva 1.7.0, so lange ich im OSD die ColorBalance ausschalte (ansonsten hab ich Streifen im Bild).


    Die Parameter dürften sich eigentlich nicht groß geändert haben. Ich würde aber trotzdem mal probieren, das "-v va-api" wegzulassen (braucht man definitiv nicht) und beim "-a" mal etwas "einfacheres , etwa nur "-a hw:0,0", zu probieren.

    VDR 1: Linux Mint 18.1 mit VDR 2.2.0 und Ausgabe auf X11 (Radeon HD6450) via softhddevice/vdpau. DVB-Karte: DVBSky T9580V3
    VDR 2: Ausgabe auf X11 (Intel i5 Kaby Lake) via softhddevice/vaapi, sonst wie VDR 1

  • Und da sich bei Beitrag mit dem von 447377 überschnitten hat: Klar, wenn du auf einfache Weise die libva updaten kannst, ist das natürlich ideal. Für Mint habe ich leider noch keinen "offiziellen" Weg gefunden, bei dem ich mir wirklich sicher bin, dass es sich nicht auf andere Software in der Distribution auswirkt und ich nicht die Update-Fähigkeit des Systems riskiere.

    VDR 1: Linux Mint 18.1 mit VDR 2.2.0 und Ausgabe auf X11 (Radeon HD6450) via softhddevice/vdpau. DVB-Karte: DVBSky T9580V3
    VDR 2: Ausgabe auf X11 (Intel i5 Kaby Lake) via softhddevice/vaapi, sonst wie VDR 1