Arte EPG verhindert Suchtimeraufnahmen

  • Seit vielleicht einem Jahr kann ich bei arte per Suchtimer keine Aufnahmen mehr machen. Am Tag vor der Aufnahme sind alle Suchtimer noch korrekt in den Timern eingetragen und sobald der Tag da ist, sind die Timereinträge verschwunden.

    Jetzt ist mir gestern auf androVDR aufgefallen, daß es am aktuellen Tag einen EPG-Eintrag gibt, der den ganzen Tag umfaßt (von 6:00 bis 00:00 Uhr, wenn ich mich recht erinnere)

    Auf dem Smartphone (AndroVDR) werden die nachfolgenden EPG-Einträge dennoch vollständig angezeigt - im Gegensatz zu meinem VDR, wo deshalb keine Timer für die anstehenden Sendungen eingetragen werden.

    Was nun?

    Scheinbar bin ich der einzige, dem das so geht, denn ich habe nichts dazu gefunden im Forum und dachte bisher so lange zu warten, bis ich den nächsten VDR auf der neusten LTS (16.04) aufsetzte. Da sich da aber nichts zu bewegen scheint, jetzt also meine Frage, ob jemand eine Idee hat, was ich tun kann, daß meine Nachrichten auf arte wieder zuverlässig aufgezeichnet werden.

  • Jetzt ist mir gestern auf androVDR aufgefallen, daß es am aktuellen Tag einen EPG-Eintrag gibt, der den ganzen Tag umfaßt (von 6:00 bis 00:00 Uhr, wenn ich mich recht erinnere)

    Das kann ich bestätigen.

    Ich sehe aktuell einen EPG-Eintrag Namens "ARTE", von heute, der 6:00 bis 6:00 geht als oberstes im OSD.


    Auch morgen gibt es so einen Eintrag, der ist (noch ?) richtig eingereiht.

    Die nächste Sendung beginnt erst um 6:25, d.h. es ist eine Lücke im EPG.


    Merkwürdig, die Einträge scheinen wirklich 24 Stunden lang zu sein und überlappen sich deswegen mit dem anderen Programm.

    Ist das überhaupt zulässig, dass sich EPG-Einträge überlappen?


    Mein VDR ist aber auch nicht mehr aktuell, vielleicht ist es inzwischen schon gefixt.

    Gruss
    SHF


    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von SHF () aus folgendem Grund: Zeilenumbruch

  • genau, ein Eintrag auf französisch (von 6:00 bis 6:00)

    Kann man den vielleicht mit einem crontab-Skript rauslöschen?

    Da ich auf Parallelinstallationen an einem neuen VDR bastele (scheitere allerdings an shutdown und Tastaturbedienung), wo das gleiche Problem mit arte auftritt, bezweifle ich, daß es am VDR liegt.

  • Also bei mir sieht der EPG auf dem Kanal


    arte;ARD:10743:HC56M2S0:S19.2E:22000:401=2:402=deu@3,403=mis@3,407=mul@3,408=fra@3:404:0:28724:1:1051:0


    momentan so aus:


    Einen Eintrag, der ab 6:00 Uhr 24 Stunden läuft sehe ich hier nicht (auch nicht in der epg.data).


    Ist das bei euch der "reine" EPG, wie er vom Satelliten kommt, oder bezieht ihr den auch (noch) von woanders?


    Klaus

  • Noop, keine anderen Quellen - und in epg.data:

    das wäre jetzt peinlich gewesen! Allerdings sehe ich noch SD-Fernsehen. Weiß nicht ob HD und SD die gleichen EPG-Daten haben.

  • Wir sehen auf jeden Fall den gleichen Sender (SID=28724).


    Da der Text in dem fraglichen Event anscheinend Spanisch ist, habe ich mal die bevorzugte EPG-Sprache auf Spanisch gesetzt. Hat aber auch nichts geändert. Auch Catalan hat nichts gebracht. Ich habe keine Idee, wo dieser Event bei dir herkommt.


    Klaus

  • ... mal wieder spät geworden, daher nur in kurz.


    Gegen Abend ~20:00 war der Eintrag von heute (Di) bei mir auch nicht mehr vorhanden. Aber einer am Mittwoch 6:00, der gestern noch nicht vorhanden war.


    Jetzt aktuell ist der Eintrag vom Dienstag wieder da und steht ganz vorne im EPG.


    Ich wollte nur noch die beiden Einträge anhängen und während ich das jetzt geschrieben habe ist der von Dienstag aus dem EPG verschwunden.

    Sehr mysteriös, wie kann den das passieren :schiel?


    Code
    1. e
    2. E 371 1520398800 86400 4F FF
    3. T ARTE
    4. D El canal de televisiðn cultural.
    5. G FF
    6. e


    Externes EPG hab ich natürlich auch nicht.


    EDIT:

    Kaum hatte ich mich abgemeldet war der Eintrag von Dienstag wieder da :motz4.

    Code
    1. c
    2. C S19.2E-1-1051-28724 arte
    3. E 370 1520312400 86400 4F 13
    4. T ARTE
    5. D El canal de televisiðn cultural.
    6. G FF
    7. e
    8. E 37359 1520384700 3300 4E 3
    9. T Tunesien - Stimmen der Revolution

    Gruss
    SHF


    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von SHF () aus folgendem Grund: Nachtrag

  • Habe auf Arte-SD (und nur da, nicht der HD-Sender) ähnliche Probleme:

    Hier die Ausgabe von epgd-showmerge für den Kanal


    Code
    1. channel S19.2E-1-1051-28724
    2. +--------+----------+---------+--------+--------+---------------------+----------+----------------------------+---------------------+
    3. | source | masterid | useid | updflg | delflg | starttime | duration | title | updsp |
    4. +--------+----------+---------+--------+--------+---------------------+----------+----------------------------+---------------------+
    5. | vdr | 1722241 | 1722241 | D | Y | 2018-03-07 06:00:00 | 1440 | ARTE | 2018-03-07 08:02:07 |
    6. | vdr | 1697931 | 1661474 | L | NULL | 2018-03-07 08:00:00 | 40 | Stadt Land Kunst | 2018-03-07 08:02:06 |
    7. | tvsp | 1661474 | 1697931 | C | NULL | 2018-03-07 08:00:00 | 40 | Stadt Land Kunst | 2018-03-07 06:28:47 |
    8. | tvm | 1660876 | 1660876 | I | NULL | 2018-03-07 08:00:01 | 40 | Stadt Land Kunst | 2018-03-06 09:08:53 |

    und der Eintrag in epg.data sieht

    Code
    1. C S19.2E-1-1051-28724 arte (S)
    2. E 371 1520398800 86400 4F FF
    3. T ARTE
    4. D [FSK 0] [EPG: DVB]||El canal de televisiðn cultural.
    5. G FF
    6. e

    so aus :)


    Also ist nicht tvsp oder tvm der "Schuldige", sondern der Eintrag rutscht über das Sender-EPG rein.

    Epgsearch und vdradmin-am haben Probleme damit, interessanterweise zeigt "live" ein ganz normales Programm.

    Auch epghttpd ignoriert den Eintrag.

    --
    hdvdr: Intel(R) Xeon(R) CPU W3520, 12 GB Ram, Grafik nvidia GeForce GT 430, nvidia-396
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und 2xDVB-C/T Tunern, TT-3200 (SAA7146) mit 1xDVB-S2 + FB,
    System btrfs, apt-btrfs-snapper,+5x1TB Raid5 XFS, yavdr0.6-frodo, Kernel 4.15.0-38-generic

    mit DD-S2+C+SAA7146-Support, epgd/tvm/tvsp, vdradmin-am, vdrmanager

  • interessanterweise zeigt "live" ein ganz normales Programm.

    genau das, ich kann auch in "live" meinen Suchtimer für "Arte Journal" testen und die fehlenden Timer erscheinen, sind aber eben nicht aktiv.

    Bei einem Suchtimerupdate hingegen, findet "live" sie nicht an den Tagen, wo die vermaledeiten 24 Stunden-Einträge schon drin sind.

  • Bei dem Ausschnitt aus der Datenbank wurde der Eintrag ja als gelöscht markiert. Daher erscheint auch nichts im EPG. Bei mir (auch mit epg2vdr unterwegs) konnte ich das noch nicht feststellen, hab allerdings auch nur selten Timer auf arte. Ansonsten sieht im Live alles gut aus.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Das Problem tritt bei epgSearch auf, was ich im Falle von ARTE gerne nehme, weil sich da schon mal was verschiebt - hat die 10+Jahre vorher ja auch anstandslos funktioniert.

    Auf anderen Sendern bin ich noch nicht auf derartige Probleme gestoßen.

  • Bei dem Ausschnitt aus der Datenbank wurde der Eintrag ja als gelöscht markiert.

    Wer mach das als gelöscht markieren?

    Der VDR tut das doch nicht.?


    der Eintrag rutscht über das Sender-EPG rein.

    Definitiv, ich hab kein externes EPG.



    Dass der fragliche Eintrag nicht sinnvoll ist, steht für mich ausser Frage.

    Zu erkennen und beseitigen wären solche Einträge auch recht gut.


    Die Frage ist für mich aber, ob diese Art überlappender Einträge zulässig ist oder nicht.

    Möglich sind die ja leider, aber wohl nicht gebräuchlich.

    Danach müsste man entscheiden, wo und was man was dagegen unternimmt.

    Gruss
    SHF


  • Da der fragliche Event anscheinend nur sporadisch kommt und ich ihn bisher nicht beobachten konnte, habe ich das einfach mal dadurch simuliert, dass ich in eit.c bei einer bestimmten Event-ID die Duration auf 86400 geändert habe. Der Event wird im Schedules-Menü richtig angezeigt, und auch alle folgenden Events sind vorhanden. Die Sortierung der Events erfolgt auch ausschließlich nach der Startzeit, die Duration geht da nicht mit ein.


    Somit kann ich wohl ein Fehlverhalten im Core-VDR ausschließen.


    Klaus

  • Ich habe auch etwas getestet und denke inzwischen, dass es nichts mit diesem Event zu tun hat.


    Gestern Abend hatte ich testweise Suchtimer auf die Kurzfilme im Nachtprogramm erstellt und die Sendungen einwandfrei aufgenommen.

    Beim Start der Aufnahmen waren die beiden komischen Events im EPG zu sehen (ob am Ende weiss ich nicht :sleep).


    Prinzipiell scheint also auch EPGsearch mit diesen Events klar zu kommen.


    Dann habe ich noch einen Suchtimer erstellt, der das ARTE Journal am Mittag aufnehmen sollte.

    Gestern Abend wurden die Timer für heute und morgen usw. auch erstellt.

    Aufgezeichnet wurde aber nichts und das obwohl ich die Sendung davor mit einem "per Hand" gesetzten Timer aufgenommen habe, was auch einwandfrei geklappt hat.

    Aktuell fehlt auch schon der Timer für Morgen, der Gestern noch da war.


    Den Fehler des Themenstarters kann ich also 100% bestätigen.


    Ich werde mich dann durch die Logfile wühlen, vielleicht findet sich da was.

    Gruss
    SHF


  • Was ich nicht verstehe, ist, daß epgSearch einen Unterschied macht, wenn es den Suchtimer nur testen soll, denn dann findet es die Sendung ja - beim Timer selbstständig erstellen scheitert es dann aber.

    Fühlt sich für mich so an, als wenn es bei der Übernahme der Daten für den Timer über den 24 Stunden Event stolpert

  • Nach dem ich es zunächst nichts gesehen hatte, hab ich es heute gefunden, denke ich.


    Bis kurz vor fünf kam bei jedem Suchlauf das gleiche:




    Dann aber das:

    Danach war der Timer weg und wurde nicht mehr erwähnt.

    Ich nehme an EPGSearch hat den gelöscht bzw. den VDR ihn mittels SVDRP löschen lassen?


    Irgendwas muss also da im EPG passiert sein.


    Ich verstehe aber die Meldungen noch nicht ganz.

    Ich habe fast immer nur "timer 1" bis auf bei dem Durchlauf, wo er den Arte-Timer gelöscht hat. Was hat das zu bedeuten?


    Die Meldungen "set to event" zwischen den Suchläufen kommen laut PID vom VDR selber.

    Meine Vermutung ist, dass da das EPG nur noch aus diesem ominösen 6:00 Uhr Event besteht.

    Was ich aber nicht verstehe ist, warum EPGSearch:

    1.) Den Timer löscht. Gut, es könnte sein, dass irgendwie annimmt, dass die Sendung schon aufgezeichnet wurde, aber:

    2.) Warum wird der Timer nicht wieder erstellt, wenn das EPG wieder in Ordnung ist?

    Gruss
    SHF


  • Die "timer 1" Meldungen kannst du ignorieren. epgsearch erstellt für den Vergleich Timer-Objekte, der vdr loggt jedes Erstellen, auch wenn sie hinterher gar nicht benutzt werden.


    Lars

  • Die "timer 1" Meldungen kannst du ignorieren. epgsearch erstellt für den Vergleich Timer-Objekte, der vdr loggt jedes Erstellen, auch wenn sie hinterher gar nicht benutzt werden.

    Ok verstehe, dann sind das nicht mal echte Timer.


    Da wäre es natürlich schön, wenn man die Meldungen in diesem Fall gezielt unterdrücken könnte. Das würde mit den Syslog um geschätzt die Hälfte verkleinern.


    Schuß ins blaue: läuft da eine EPG-Aktualisierung über irgendwelche spanischen Kanäle die einen Arte-Eintrag mitschicken?

    Wie soll ich das angestellt haben?

    Mein Kanal-Eintrag sieht wie folgt aus und ich hab sonst keinerlei externe EPG-Geschichten oder sonst was am laufen.

    Code: channels.conf
    1. arte;ARD:10744:HC56M2S0:S19.2E:22000:401=2:402=deu@3,403=mis@3,407=mul@3,408=fra@3:404:0:28724:1:1051:0



    Der Timer von Freitag hat auch nicht aufgezeichnet, auch der wurde gelöscht.

    Wieder das gleiche Verhalten:

    Timerevent ändert sich. Oder ändert es nur den Namen?

    Dann wird der Timer von EPGsearch gelöscht.


    Merkwürdigerweise wird der Timer beim "conflict check" noch berücksichtigt, beim "timer update" erscheint die "timer 1" Meldung aber nicht mehr.



    Die Eventänderungen treten auch bei per Hand programmierten Timern auf.

    Der Timer hat aber einwandfrei aufgezeichnet.


    Trotzdem läuft da irgendwas im EPG schief. Bei praktisch jedem Scan muss es da Änderungen geben.

    Gruss
    SHF


    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von SHF () aus folgendem Grund: Dieser $#@%§# Editor versemmelt immer meine Zeilenumbrüche im Code