ngene-Treiber: Unterstützung für (fast) alle DuoFlex-Module, kleinere Verbesserungen

  • Servus zusammen,


    habe ein Stück "alte" ngene-Hardware (L4M/DD Cine S2 V5.5) in die Finger bekommen und hab' mal den Treiber ein bisschen frisiert:


    • Es werden jetzt so ziemlich alle derzeit erhältlichen DuoFlex-Module erkannt und unterstützt (an den Expansion-Connector der v5.5 angeschlossen), inkl. aller DuoFlex CT2/C2T2/C2T2I und der DuoFlex S2 V4. Ausnahme: Die DuoFlex Twin-CI Adapter.
    • Der Treiber beschwert sich nicht mehr, wenn kein CI-Flex angeschlossen ist.
    • Der Treiber schreibt seinen Kram jetzt anständig mit PCI Port Angaben ins Kernel Log (dev_*() logging vs. printk())
    • Diverse Mini-Verbesserungen


    Sofern noch Leute mit derartiger Hardware unterwegs sind (cineS2v5.5, Mystique SaTiX S2, DD DuoFlex PCIe Bridge mit zwei Ports) - mir fallen hier mehr oder weniger spontan DaGo   Grillbert   Grumpy ein - wärs toll, wenn v.a. die erweiterte Hardware-Unterstützung mal getestet werden könnte. Speziell die Unterstützung für die S2 V4 wäre spannend (derzeit noch ungetestet), der Betrieb an den alten mini-Bridges am ersten Port wäre aber auch interessant. Die Changes möchte ich gerne in mainline unterbringen, sprich, auf linux-media posten.


    Branch: mediatree/master-ngene

    Commits: mediatree/master-ddb-cxd2099 -> mediatree/master-ngene

    Anleitung/Compile-Howto: Compile using media_build


    Bitte anstatt "mediatree/master-ddbridge" dann "mediatree/master-ngene" auschecken und damit dann media_build befüttern (prinzipiell dasselbe Vorgehen wie schon bei den ddbridge-Tests ;))


    EDIT: Ich habe noch einen use-after-free Kernel-OOPS gefixt (verursacht durch das Cleanup des TDA18212 Tuner I2C Clients), der beim Entladen der Module aufgetreten ist, wenn ein CXD2099 am Expansion Port angeklemmt ist.


    Viele Grüße,

    nst

    Server: Gigabyte P35-DS4, Intel Core2Duo E6850, 4GB DDR2-RAM (Headless), Gentoo Linux x86_64 / Kernel 4.16.7 / DD CineCTv6+DuoFlex C/T/T2+DuoFlex C/C2/T/T2 w/Kernel Stock Drivers / TVHeadend-GIT-3356759d8

    HTPC: ASRock J5005-ITX (Intel Pentium Silver J5005, 1.5GHz), 8GB SO-DDR4, Intel UHD Graphics 605 in Antec Fusion Remote Black+SoundGraph iMON LCD ( 0038 ), Kodi v18 Leia
    SW: Kodi Krypton+Leia auf allerlei Gerätchen (HTPC: VAAPI+HD-Audio+LCDproc addon / Ubuntu Bionic 18.04 (x86_64), RPi2, NVIDIA Shield Android TV, Wetek Play 1@LibreELEC/NAND, Tablets, Smartphones, Win/Mac/Linux Desktops)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von nst ()

  • Zur Zeit komme ich leider nicht dazu das zu testen.
    Mein YaVDR ist gerade etwas zerschossen aber läuft... (ich kann kein update machen - irgendwas ist strubbelig)
    Ich werde wohl demnächst mal alles neu aufsetzen müssen - vielleicht auf meiner spare-SSD und auf MLD-basis. Im Rahmen dessen kann ich das dann testen.
    Wäre natürlich ein Traum wenn es läuft - dann habe ich endlich meine 4 Tuner aktiv und die neue Karte geht in Richtung Ebay...

    [Cine S2 V6.5 + DuoFlex V4] zur Zeit wieder ngene basierte Cine S2 / Apollo-Lake Celeron (Asrock J3355M), ATRIC Einschalter, MLD 5.4 testing

  • Der Support für die zusätzliche Hardware wurde heute in linux-media merged, siehe Treiber der Cine-CTv6/DDBridge/CI in den Kernel integrieren


    Grillbert Wenn Du immernoch Dein DuoFlex S2 V4 testen magst (das wäre hochinteressant), dann bitte einfach den üblichen/bekannten media_build Vorgang anwerfen, aber beim Checkout von den Kernel Sourcen den Basis-Branch "mediatree/master" verwenden. Und, Hint: Das Flachbandkabel an der V5.5 mit der Farbmarkierung LINKS aufstecken - ich war mir da anfangs nicht sicher :-)

    Server: Gigabyte P35-DS4, Intel Core2Duo E6850, 4GB DDR2-RAM (Headless), Gentoo Linux x86_64 / Kernel 4.16.7 / DD CineCTv6+DuoFlex C/T/T2+DuoFlex C/C2/T/T2 w/Kernel Stock Drivers / TVHeadend-GIT-3356759d8

    HTPC: ASRock J5005-ITX (Intel Pentium Silver J5005, 1.5GHz), 8GB SO-DDR4, Intel UHD Graphics 605 in Antec Fusion Remote Black+SoundGraph iMON LCD ( 0038 ), Kodi v18 Leia
    SW: Kodi Krypton+Leia auf allerlei Gerätchen (HTPC: VAAPI+HD-Audio+LCDproc addon / Ubuntu Bionic 18.04 (x86_64), RPi2, NVIDIA Shield Android TV, Wetek Play 1@LibreELEC/NAND, Tablets, Smartphones, Win/Mac/Linux Desktops)

  • Hallo nst,


    würde den Treiber auch gerne mal mit meiner CineS2 v5.5 testen. Lasse den VDR jedoch in einem LXC Container unter Proxmox laufen, sodass ich nicht einfach so einen neuen Kernel installieren kann, da Proxmox seinen eigenen Kernel mitbringt.


    Gibt es noch eine andere Möglichkeit den Treiber zu installieren? Der master-ngene Branch ist ja nicht mehr verfügbar....


    Grüße,

    Alex

    Server: Supermicro X9SAE, Intel Xeon E3-1245v2, ESXi 6.5

    VDR VM: Ubuntu 16.04 LTS, 2x DD Cine S2, VDR 2.3.8

  • Die ganzen Changes wurden im Upstream bereits akzeptiert und merged, und sind für das 4.17er Kernel Merge Window queued. Du kannst einfach aus dem upstream master Branch (per media_build) compilen:

    Code
    1. # git clone --branch buildall https://github.com/herrnst/media_build.git
    2. # git clone --branch mediatree/master https://github.com/herrnst/dddvb-linux-kernel.git
    3. # cd media_build
    4. # ./build_all.sh ../dddvb-linux-kernel/
    5. (als root)
    6. # make install ; depmod -a
    7. # reboot

    Server: Gigabyte P35-DS4, Intel Core2Duo E6850, 4GB DDR2-RAM (Headless), Gentoo Linux x86_64 / Kernel 4.16.7 / DD CineCTv6+DuoFlex C/T/T2+DuoFlex C/C2/T/T2 w/Kernel Stock Drivers / TVHeadend-GIT-3356759d8

    HTPC: ASRock J5005-ITX (Intel Pentium Silver J5005, 1.5GHz), 8GB SO-DDR4, Intel UHD Graphics 605 in Antec Fusion Remote Black+SoundGraph iMON LCD ( 0038 ), Kodi v18 Leia
    SW: Kodi Krypton+Leia auf allerlei Gerätchen (HTPC: VAAPI+HD-Audio+LCDproc addon / Ubuntu Bionic 18.04 (x86_64), RPi2, NVIDIA Shield Android TV, Wetek Play 1@LibreELEC/NAND, Tablets, Smartphones, Win/Mac/Linux Desktops)

  • Habe es getestet, aber funktioniert bei mir leider nicht. Habe es mit zwei Kernel versucht:


    Code
    1. Linux proxmox 4.13.16-1-pve #1 SMP PVE 4.13.16-45 (Wed, 28 Mar 2018 15:47:11 +0200) x86_64 GNU/Linux

    Code
    1. Linux proxmox 4.15.10-1-pve #1 SMP PVE 4.15.10-4 (Wed, 28 Mar 2018 15:47:48 +0200) x86_64 GNU/Linux


    Bekomme aber bei beiden Versuchen im Log ein:

    Code
    1. [ 18.640682] dvb_core: disagrees about version of symbol vb2_vmalloc_memops
    2. [ 18.640683] dvb_core: Unknown symbol vb2_vmalloc_memops (err -22)

    Ich vermute mal, das geht hört auch dazu:

    Grüße

    Server: Supermicro X9SAE, Intel Xeon E3-1245v2, ESXi 6.5

    VDR VM: Ubuntu 16.04 LTS, 2x DD Cine S2, VDR 2.3.8

  • Was sagt denn "modinfo dvb-core", "modinfo videbuf2-vmalloc", "modinfo ngene", "modinfo ddbridge", "modinfo media", und im Vergleich modinfo eines anderen Modules, das derzeit geladen ist (eins aus lsmod), nachdem Du den media_tree mit media_build durchcompiled und installiert hast? Das riecht alles ein bisschen nach fehlenden oder falschen Headern zum Kernel...

    Server: Gigabyte P35-DS4, Intel Core2Duo E6850, 4GB DDR2-RAM (Headless), Gentoo Linux x86_64 / Kernel 4.16.7 / DD CineCTv6+DuoFlex C/T/T2+DuoFlex C/C2/T/T2 w/Kernel Stock Drivers / TVHeadend-GIT-3356759d8

    HTPC: ASRock J5005-ITX (Intel Pentium Silver J5005, 1.5GHz), 8GB SO-DDR4, Intel UHD Graphics 605 in Antec Fusion Remote Black+SoundGraph iMON LCD ( 0038 ), Kodi v18 Leia
    SW: Kodi Krypton+Leia auf allerlei Gerätchen (HTPC: VAAPI+HD-Audio+LCDproc addon / Ubuntu Bionic 18.04 (x86_64), RPi2, NVIDIA Shield Android TV, Wetek Play 1@LibreELEC/NAND, Tablets, Smartphones, Win/Mac/Linux Desktops)

  • habe drei DD Cine S2 V5.5 und ein DuoFlex-CI ( Single-Slot) an der "ersten" Cine S2.

    Mit dieser Kombi und einer ACL+O4A konnte ich gelegentlich eine passende Smartcard nutzen, allerdings mit regelmäßigem Pixelbrei.

    Habe die Karte gerade wieder zur Verfügung und bin auf den anderen Thread gestoßen.

    Edit:

    CI-Unterstützung für CineS2, Mystique SaTiX-S2 Dual usw.

    /edit

    Von da an geht es um Probleme, welche mit meiner (sehr ähnlichen) HW-Kombi ebenfalls auftreten: Regelmäßige Aussetzer mit Pixelbrei.


    Nach meinem Verständnis sollte die Anleitung aus Post #5

    ngene-Treiber: Unterstützung für (fast) alle DuoFlex-Module, kleinere Verbesserungen die derzeit aktuellsten Treiber für die CinS2 V5.5 installieren, und damit die Probleme lösen.

    Ich konnte die Treiber nach kleinem Hindernis (musste vorher noch "libproc-processtable-perl" installieren, da es eine Fehlermeldung aus einem perl-script gab) übersetzen und installieren. Allerdings wird nun nach einem reboot das CI überhaupt nicht mehr erkannt.

    Auch ein Ziehen und Neu-Stecken des CAMs führt zu keinerlei Reaktionen im syslog.


    Die modinfos:



    das wäre wohl richtiger:

    und mein VDR:

    Wie gesagt, vorher lief es "im Prinzip", aber möglicherweise mit einem HWE-Kernel 4.13,;könnte sein, dass ich den versehentlich vor her obigen Installation entfernt hatte (Mitternacht ist offenbar doch kein guter Zeitpunkt für solche Dinge )

    Ich bin für jegliche Hinweise dankbar.

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

    Dieser Beitrag wurde bereits 4 Mal editiert, zuletzt von vdrjoe () aus folgendem Grund: nachfolgende eigene Posts in diesen Post integriert Problem genauer beschrieben

  • was ich vergessen habe:

    es steckt auch noch eine Cine C2/T2 V7 mit im System, welche nun die ersten DVB adapter_0 und adapter_1 devices liefert:

    alerdings störte die mit den alten Treibern nicht.

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

  • in /dev/dvb/adapter? findet sich ebenfalls kein CI oder CAM


    Habe eben nochmal geschaut, der Stecker zur Spannungsversorgung des CI steckt, ein Umstecken auf eine andere Cine S2 ändert auch nichts.

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

  • sehe gerade:

    ich habe ein aktuell nicht mehr erhältliches Flex-CI (single-Slot) , kein Duoflex-CI

    Zitat
    • Es werden jetzt so ziemlich alle derzeit erhältlichen DuoFlex-Module erkannt und unterstützt (an den Expansion-Connector der v5.5 angeschlossen), inkl. aller DuoFlex CT2/C2T2/C2T2I und der DuoFlex S2 V4. Ausnahme: Die DuoFlex Twin-CI Adapter.


    also sollte der hier beschriebene Treiber passen, oder? (habe ja kein DuoFlex Twin-CI, sonder ein Flex-CI (Artikel-Nr: 092003) (single Slot)


    ein

    Code
    1. lsmod | grep cxd
    2. cxd2099 20480 0

    zeigt offenbar, das das Flex-CI gefunden wird, aber nicht genutzt.


    edit:


    Die cine C2/T2 V7 (ddbridge) hatte ich zwischenzeitlich entfernt, das hat aber auch nicht geholfen

    das sagt DDCI-Inf im syslog:

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von vdrjoe () aus folgendem Grund: erweitert

  • Jasmin sagt im Readme zum DDCI2-Plugin:

    Zitat
    Code
    1. Pitfalls
    2. --------
    3. If you see this messages in syslog: DDCI-Inf: no DD CI adapter found
    4. and/or DDCI-Err (ddci2.cpp,110): Couldn't open /dev/dvb/adapterX/ciY with mode 0x800: Device or resource busy
    5. then you might forget to remove the redirect assignment in the driver.

    Das "in the driver" bezieht sich auf den hier beschreibenen Treiber, in meinem Fall den ngene, richtig?

    und das folgende

    Zitat
    Code
    1. This plugin obsolets the redirect method of the ddbridge kernel driver.
    2. The Kernel driver must not started with option "adapter_alloc=1|2|3"!

    redirect method <=> eine der Driver-Optionen "adapter_alloc=1" oder "..2" oder "..3" ??

    Ist also keine dieser Optionen gesetzt, wird auch die redirect methode nicht angewendet?

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

  • Okay, scheint eher ein Selbstgespräch zu sein ;)

    Das letzte Zitat bezieht sich auf den ddbridge Treiber, welche zwar ebenfalls geladen, aber nicht benutzt wird?

    wie auch


    Ich schweife mal kurz etwas ab:

    Ich besitze sowohl ein Flex-CI (single slot, cxd2099) wie auch ein DuoFlex-Dual CI (cxd_irgendetwas, ist zur Zeit nicht verbaut).

    Sind die zueinander bzw. zu meiner alten Cine S2 V5.5 und den Duoflex-PCI-Bridges kompatible?

    Sollte ich das Flex-CI gegen das DuoFlex-CI tauschen, damit der ddbridge Treiber überhaupt genutzt wird?


    Gesagt, getan. Da das DuoFlex Dual CI ja nicht vom ngene-Treiber unterstützt wird habe ich eine Mini-PCIe Bridge genommen, und daran das DuoFlex CI mit dem CAM angeschlosssen.

    Nun wird das CAM erkannt:

    Also mit der Octopus bridge und dem dort angestecktem Dual-Ci klappt alles, die ursprünglich vorhandenen regelmäßigen Bildfehler sind verschwunden.

    So weit, so gut.

    Warum das single-CI nicht direkt an der CineS2 V5.5 läuft weiß ich nicht. Die Variante, das Dual_CI direkt an der Cine S2 V5.5 anzuschliessen, brauche ich ja gar nicht erst auszuprobieren, laut Readme zu nsts-Treiber.

    Ob das Single-CI auch an der Octopus bridge läuft, kläre ich später.

    Danke für's Zuhören ;)

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

    Dieser Beitrag wurde bereits 5 Mal editiert, zuletzt von vdrjoe () aus folgendem Grund: Selbstgespräch mit neuen Erkenntnissen.

  • Okay, Danke für die Rückmeldung.


    Das heisst, das DDCI2-Plugin benötigt zwingend ddbridge, bzw. die zugehörige Hardware?

    Ein CI läuft also nicht direkt an einer alten Cine V5.5 angeschloßen?

    Das Duoflex-CI nicht wegen der Einschränkungen im Treiber, aber warum nicht ein Single Slot-CI?

    Oder habe ich die folgende Sätze nur völlig falsch interpretiert?

    Zitat
    • Es werden jetzt so ziemlich alle derzeit erhältlichen DuoFlex-Module erkannt und unterstützt (an den Expansion-Connector der v5.5 angeschlossen), inkl. aller DuoFlex CT2/C2T2/C2T2I und der DuoFlex S2 V4. Ausnahme: Die DuoFlex Twin-CI Adapter. => Flex-CI geht also??
    • Der Treiber beschwert sich nicht mehr, wenn kein CI-Flex angeschlossen ist. ==> wenn's denn angeschlossen ist, geht es dann per DDCI2-Plugin oder nicht?


    War da nicht etwas mit geänderter I2C-Adresse?

    Jörg

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

  • Hallo Jörg,

    ich nutze aktuell eine CineS2 v5.5 + Single CI.

    Ich hatte das Problem, dass der kleine weiße Halter am Stromanschluss des CI bei der Demontage verrutscht war und der Stecker beim neu anstecken keinen sauberen Kontakt hatte. Bin fast verzweifelt an dem Fehler. Mein CI wurde vorher nur sporadisch erkannt.

    ASRock J3455M | 8GB Ram | CineS2 v5.5 + CI | MLD5.4 Testing

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von Friedl ()

  • Danke für den Tipp,

    das war es leider auch nicht, obwohl auch bei meinem Single CI das weiße Halter sehr weit nach vorn verschoben war, also durch das Abziehen bedingt,


    Habe nun das Single CI (mit cxd2099 Chip) an die Octopus-bridge gehängt, geht auch nicht:

    Das ist ein Ausschnitt aus dmesg:

    Das CI wird also "im Prinzip" erkannt, aber: CXD2099AR attach failed


    CI defekt?

    oder Treiber (fehlender Parameter?)?

    ASUS H87-PRO (Intel G3220+4GB RAM), 3x PCI-E CineS2 Dual DBS2 Ver. 5.5,
    64bit Ubuntu 16.04.4 LTS-Server, VDR 2.3.8 (mit DDCI2+streamdevserver+vompserver+vnsiserver)
    Diskless-Clienten: 4x Raspberry-Pi als Vomp-client in HD, 2x Fire TV (Stick und Box) mit Kodi per VNSI
    DVB-S-Radio per streamdev + externremux + ffmpeg + mpd auf Internetradios (mit Reciva-Barracuda-Chipsatz)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von vdrjoe ()

  • Ich habe bei den Modulen keine speziellen Parameter angegeben, damit das CI erkannt wird.

    Ich nutze aktuell noch den in nst's git mitgelieferten Kernel 4.16.0-rc4 (vom 9. März), da media_build bei mir nicht funktionierte. Die config habe ich vom MLD-Kernel übernommen.


    Vielleicht kann der Support von Digital Devices weiterhelfen, damit hatte ich bisher nur gute Erfahrungen.

  • Du hast leider Deinen Kernellog-Auszug um möglicherweise wichtige Teile erleichtert, daher Raterunde: Wenn Du jetzt was Aktuelles aus media_tree per media_build installiert hast, kommt bei Dir wohl der cxd2099 Treiber aus staging aufgrund Prioritäten ins Gehege (zumindest sieht Dein Kernellog-Fragment etwas danach aus). Ergo:

    Code
    1. ### Backup machen!
    2. # rm -rf /lib/modules/<kver>/kernel/drivers/staging/media/
    3. # depmod -a
    4. # reboot

    Und dann schau mal, ob Du caX/secX Devicenodes findest.

    Server: Gigabyte P35-DS4, Intel Core2Duo E6850, 4GB DDR2-RAM (Headless), Gentoo Linux x86_64 / Kernel 4.16.7 / DD CineCTv6+DuoFlex C/T/T2+DuoFlex C/C2/T/T2 w/Kernel Stock Drivers / TVHeadend-GIT-3356759d8

    HTPC: ASRock J5005-ITX (Intel Pentium Silver J5005, 1.5GHz), 8GB SO-DDR4, Intel UHD Graphics 605 in Antec Fusion Remote Black+SoundGraph iMON LCD ( 0038 ), Kodi v18 Leia
    SW: Kodi Krypton+Leia auf allerlei Gerätchen (HTPC: VAAPI+HD-Audio+LCDproc addon / Ubuntu Bionic 18.04 (x86_64), RPi2, NVIDIA Shield Android TV, Wetek Play 1@LibreELEC/NAND, Tablets, Smartphones, Win/Mac/Linux Desktops)