[ERLEDIGT nicht GELÖST] nvram läuft nicht

  • Moin Zusammen,


    ich habe nach 2 Jahren Laufzeit Probleme mit meiner „easyVDR 2.0 Installation“ bekommen.

    Nun ist easyVDR 3.0 installiert und die nvram-wakeup.conf aus der alten 2.0 übernommen.

    Leider läuft nvram nicht.

    Den Fehler kann ich nicht eingrenzen und die Pfade „/usr/bin/easyvdr/vdrshutdown“ (easyVDR) und „/usr/bin/easyvdr/easyvdrshutdown.sh“ (ab easyVDR 4.0) existieren bei mir nicht.


    Danke und Gruß

    Florian

    Primär-VDR


    easyVDR 3.5, Gigabyte GA-MA78GM-S2H , Brisbane Athlon 64 X2 5000+, 2 GB, SSD Force LS 60GB, HDD Seagate Barracuda 2 TB, Digital Devices Cine S2, NVIDIA GeForce GT 520, 7"TFT graphTFT, 'c@rstenpresser.de' KarateLight, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)


    Sekundär-VDR


    easyVDR 0.6, ASRock ALiveNF6G-GLAN, Brisbane Athlon X2 BE-2400, 2 GB, Seagate Barracuda 1 TB, Nexus-S rev2.3a, TT-Budget S-1500 PCI, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)

  • Hi, aktuell ist die 3.5...

    Nvram benutzt niemand sonst mehr...

    Häng ein Log vom Start (easyinfo).MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Moin Zusammen,


    sorry, dass ich mich erst jetzt melde.

    Habe viel rum probiert und am Ende die Version 3.5 von easyVDR installiert.

    Bei der 3.0 war ich so weit, dass der VDR nicht mehr runter fährt da er die Aufwach-Zeit nicht ins BIOS schreiben kan.

    Nvram-wakeup could not set time


    Dann habe ich Die Kiste "schnell" neu aufgesetzt.

    Nun, mit der 3.5 habe ich aber exakt das selbe Problem.


    Die Einstellungen im BIOS habe ich nicht verändert und bis zur Neuinstallation von 3.0 hat nvram-wakeup einwandfrei gearbeitet.


    Hmmmm??? ||


    Danke und Gruß

    Florian

    Dateien

    • easyinfo.zip

      (88,81 kB, 18 Mal heruntergeladen, zuletzt: )

    Primär-VDR


    easyVDR 3.5, Gigabyte GA-MA78GM-S2H , Brisbane Athlon 64 X2 5000+, 2 GB, SSD Force LS 60GB, HDD Seagate Barracuda 2 TB, Digital Devices Cine S2, NVIDIA GeForce GT 520, 7"TFT graphTFT, 'c@rstenpresser.de' KarateLight, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)


    Sekundär-VDR


    easyVDR 0.6, ASRock ALiveNF6G-GLAN, Brisbane Athlon X2 BE-2400, 2 GB, Seagate Barracuda 1 TB, Nexus-S rev2.3a, TT-Budget S-1500 PCI, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von FlorianReinartz ()

  • Hi,

    Warum nutzt du nicht einfach acpi? Das sollte mit allen Boards gehen!

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • nvram war ganz früher mal nötig, aber diese Boards sollten eh nicht mehr im Einsatz sein...


    MfG,

    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Hallo Zusammen,

    hallo Stefan,


    in der Vergangenheit hat nvram immer super funktioniert.

    Da wir hier 10-12 Stromausfälle im Jahr haben bin ich mir so immer sicher gewesen, dass die Aufweckzeit erhalten bleibt.

    Allerdings ist das Bios eh so konfiguriert, dass der Rechner nach einem Stromausfall erst mal hoch fährt (On after Power back ... oder sinngemäß).


    Habe mich bisher nie mit der acpi wakeup Methode beschäftigt.

    Ist die ohne Feintunig und diverse Anpassungen in irgendwelchen conf-Dateien möglich?


    Danke und Gruß

    Florian

    Primär-VDR


    easyVDR 3.5, Gigabyte GA-MA78GM-S2H , Brisbane Athlon 64 X2 5000+, 2 GB, SSD Force LS 60GB, HDD Seagate Barracuda 2 TB, Digital Devices Cine S2, NVIDIA GeForce GT 520, 7"TFT graphTFT, 'c@rstenpresser.de' KarateLight, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)


    Sekundär-VDR


    easyVDR 0.6, ASRock ALiveNF6G-GLAN, Brisbane Athlon X2 BE-2400, 2 GB, Seagate Barracuda 1 TB, Nexus-S rev2.3a, TT-Budget S-1500 PCI, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)

  • Moin Zusammen,


    einfach nur im OSD die Wakeup-Methode auf ACPI zu stellen langt jedenfalls nicht...

    Er wacht nicht auf :-(


    Danke & Gruß

    Florian

    Primär-VDR


    easyVDR 3.5, Gigabyte GA-MA78GM-S2H , Brisbane Athlon 64 X2 5000+, 2 GB, SSD Force LS 60GB, HDD Seagate Barracuda 2 TB, Digital Devices Cine S2, NVIDIA GeForce GT 520, 7"TFT graphTFT, 'c@rstenpresser.de' KarateLight, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)


    Sekundär-VDR


    easyVDR 0.6, ASRock ALiveNF6G-GLAN, Brisbane Athlon X2 BE-2400, 2 GB, Seagate Barracuda 1 TB, Nexus-S rev2.3a, TT-Budget S-1500 PCI, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)

  • Welcher Kernel?

    Ist mir auch passiert mit yavdr0.6, da schreibt das Script, welches die Wakeup-Zeit schreibt, zuerst (für antike Kernel <2.6.22) noch nach /proc/acpi/wakeup und meint, wenn das klappt, seine Arbeit getan zu haben. Erst wenn das fehlschlägt, wird in /sys/class/rtc/rtc0/wakealarm geschrieben.

    Die Kernel ab 4.1x haben aber wieder /proc/acpi/wakeup mit anderer Funktion, und das Schreiben dahin liefert keinen Fehler zurück, bewirkt aber auch nix.

    Ich weiß nicht, wie der Ersatz fürs /usr/share/vdr/shutdown-hooks/S90.acpiwakeup bei Easyvdr heißt, würde dort aber nachsehen.

    --
    hdvdr: Intel(R) Xeon(R) CPU W3520, 12 GB Ram, Grafik nvidia GeForce GT 430, nvidia-396
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und 2xDVB-C/T Tunern, TT-3200 (SAA7146) mit 1xDVB-S2 + FB,
    System btrfs, apt-btrfs-snapper,+5x1TB Raid5 XFS, yavdr0.6-frodo, Kernel 4.15.0-38-generic

    mit DD-S2+C+SAA7146-Support, epgd/tvm/tvsp, vdradmin-am, vdrmanager

  • Hi,

    Also eigentlich funktioniert es genau so. Bei allen anderen EasyVDR3.5 Nutzern geht es (acpi-Wakeup). Daher denke ich sollte ein solcher Bug nicht drin sein.

    Kontrollier mal in der sysconfig nach umstellen auf acpi bei gestopptem Vdr (stopvdr).

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Laut Hersteller supported die Board A785GMH „ACPI 1.1 Compliance Wake Up Event“


    Evtl. mal im BIOS schauen. Evtl kann man da noch was zum wakeup enabled. Stichwort RTC.


    Viele Grüße

    schneisa

  • Zitat

    Nvram benutzt niemand sonst mehr...

    Doch ich :-) Und zwar mit EasVDR 3.0 32 Bit.Ich habe ein uraltes Board, bei dem mit ACPI-Wakeup nur die Urzeit berücksichtigt wird und der Rechner daher immer zur angegebenen Uhrzeit am nächsten Tag aufwacht (was ziemlich nervt). nvram-wakeup hingegen funktioniert, war aber ziemlich stressig, bis es lief. Aus dem Gedächtnis:

    • nvram-wakeup installieren und als Aufwach-Methode einstellen
    • script erstellen, das die Uhrzeit setzt
    • den notwendigen Reboot nach dem Setzen der Uhrzeit mit grub statt mit lilo hinbekommen
    • der Kernel hat jetzt ein Security-Feature aktiviert, das verhindern, daß nvram-wakeup die Uhrzeit setzen kann. Ich habe dann einen neuen Kernel kompiliert, der dieses Feature disabled.

    Details suche ich gerne raus, falls es noch jemand interessiert.


    Viele Grüße

    Herbert

  • Hallo Zusammen,

    hallo Herbert,


    das wäre super, versuche immernoch verzweifelt den VDR zum aufwachen zu bekommen.

    Noch nervoger ist, dass die Kiste nicht mehr runter fährt sobald ein Timer angelegt ist.

    Der Shutdown wird von nvram-wakeup unterbrochen da die aufwacht Zeit nicht gesetzt werden kann.


    Die Kiste fährt also weder hoch noch runter ...


    Wäre für jede Hilfe dankbar...


    Danke und Gruß

    Florian

    Primär-VDR


    easyVDR 3.5, Gigabyte GA-MA78GM-S2H , Brisbane Athlon 64 X2 5000+, 2 GB, SSD Force LS 60GB, HDD Seagate Barracuda 2 TB, Digital Devices Cine S2, NVIDIA GeForce GT 520, 7"TFT graphTFT, 'c@rstenpresser.de' KarateLight, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)


    Sekundär-VDR


    easyVDR 0.6, ASRock ALiveNF6G-GLAN, Brisbane Athlon X2 BE-2400, 2 GB, Seagate Barracuda 1 TB, Nexus-S rev2.3a, TT-Budget S-1500 PCI, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)

  • Kernel kompilieren ... hmmm

    Mal schauen...

    Wede mich mit Deinen Infos mal im easyVDR-Forum bei nem Kern-Entwickler melden.

    Vielleicht mag er helfen.


    Danke und Gruß

    Florian

    Primär-VDR


    easyVDR 3.5, Gigabyte GA-MA78GM-S2H , Brisbane Athlon 64 X2 5000+, 2 GB, SSD Force LS 60GB, HDD Seagate Barracuda 2 TB, Digital Devices Cine S2, NVIDIA GeForce GT 520, 7"TFT graphTFT, 'c@rstenpresser.de' KarateLight, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)


    Sekundär-VDR


    easyVDR 0.6, ASRock ALiveNF6G-GLAN, Brisbane Athlon X2 BE-2400, 2 GB, Seagate Barracuda 1 TB, Nexus-S rev2.3a, TT-Budget S-1500 PCI, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von FlorianReinartz ()

  • Hallo Florian,


    ich hoffe, ich bekomme das noch alles zusammen:

    • das paket nvram-wakeup muß installiert werden
    • im Einstellungsmenü des VDRs nvram-wakup als Wakeup-Methode einstellen
    • die Datei /etc/vdr/vdr-nvram-wakeup.conf entsprechend anpassen. Ich habe meine angehängt. Insbesondere die Zeile SPECIALSHUTDOWN="grub-reboot halt ; reboot" ist entscheidend.
    • Der EasyVDR-Kernel wurde mit CONFIG_STRICT_DEVMEM=y kompiliert, so daß nvram-wakeup die Aufwachzeit nicht schreiben konnte. Ich habe daher einen neuen Kernel kompiliert, bei dem diese Option nicht gesetzt ist. Keine Ahnung, ob das auch anders geht, ich weiß es nicht besser. Ich habe damals die Version 4.4.70 genommen, das war damals der neueste 4.4er. Dieser Kernel muß installiert werden.
    • Bei meinem Board muß nach dem Schreiben der Aufwachzeit noch einmal gebootet und danach der Rechner ausgeschaltet werden. Das geht über entsprechende GRUB-Einstellungen. In der Datei /etc/default/grub muß die Option GRUB_DEFAULT=saved gesetzt sein. Die Datei /etc/grub.d/40_custom muß angepaßt werden Ich habe sie ebenfalls angehängt. Der Befehl update-grub erstellt die neue grub.cfg-Datei mit den Änderungen.

    Ich denke, das war alles und hoffe, daß es hilft.


    Viele Grüße

    Herbert

  • Hallo Zusammen,


    vielen Dank für Eure Unterstützung.

    Schade, dass die Nutzung von NVRAM vom aktuellen Kernel nicht unterstützt wird.

    Da es eine Sicherheitslücke darstellt in diesen Bereich des BIOS zuzugreifen gehe ich nicht davon aus, dass sich diese Option in Zukunft wieder ergeben wird.


    Aus diesem Grund habe ich mir in der Bucht ein neues MB gekauft.

    Nun ist es ein Gigabyte GA-MA78GM-S2H und ACPI als WakeUp-Methode funktionieren tadellos und ohne Experimente, Anpassung von .conf-Dateien oder Kompillirungen des Kernels.


    Danke und Gruß

    Florian

    Primär-VDR


    easyVDR 3.5, Gigabyte GA-MA78GM-S2H , Brisbane Athlon 64 X2 5000+, 2 GB, SSD Force LS 60GB, HDD Seagate Barracuda 2 TB, Digital Devices Cine S2, NVIDIA GeForce GT 520, 7"TFT graphTFT, 'c@rstenpresser.de' KarateLight, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)


    Sekundär-VDR


    easyVDR 0.6, ASRock ALiveNF6G-GLAN, Brisbane Athlon X2 BE-2400, 2 GB, Seagate Barracuda 1 TB, Nexus-S rev2.3a, TT-Budget S-1500 PCI, atric IR-Einschalter Rev.5, Logitech Harmony 1100 (KLS 1.6)