yavdr ansible

  • Für die letzte Compiler Warnung aus epgsearch hätte ich auch noch einen Patch, damit baut das Plugin wieder ohne warnings durch.

    Ich habe deine Patches ins Paket eingebaut.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • seahawk1986 danke


    M-Reimer grundsätzlich hast du ja Recht, aber trotz Mail sind viele Projektseiten nur sehr wenig beachtet.

    Ich verwende für meinen VDR das yavdr experimental, das hat für mich einen aktuellen und stabilen Stand. Wenn ich mit einer Funktionen, die ich nutze, ein Problem habe, bekomme ich hier Hilfe oder baue die Lösung selbst und poste es. Die Patches, meine und die von anderen, sind alle im Repository von seahawk1986 gesammelt und ich hoffe auch, dass sie sich mal in einer Upstream Version wiederfinden.

    VDR
  • M-Reimer grundsätzlich hast du ja Recht, aber trotz Mail sind viele Projektseiten nur sehr wenig beachtet.

    Ich verwende für meinen VDR das yavdr experimental, das hat für mich einen aktuellen und stabilen Stand. Wenn ich mit einer Funktionen, die ich nutze, ein Problem habe, bekomme ich hier Hilfe oder baue die Lösung selbst und poste es. Die Patches, meine und die von anderen, sind alle im Repository von seahawk1986 gesammelt und ich hoffe auch, dass sie sich mal in einer Upstream Version wiederfinden.


    Aber es gibt mehr als nur eine Distribution.


    In dem Zusammenhang möchte ich nochmal an Neuorganisierung der VDR Plugins auf Github (vdr-projects.github.io) erinnern. Die "Einstiegshürde" um etwas sinnvolles beizutragen ist bei Github definitiv niedriger.


    Und dein Argument zieht übrigens nicht. Wenn ich mir das Log von epgsearch anschaue, dann ist da tatsächlich noch jemand aktiv:

    https://projects.vdr-developer…plugin-epgsearch.git/log/


    Für vdr4arch werde ich den Patch-Wust auf jeden Fall nicht zusammensuchen. Pull-Request oder kein Fix.

  • Hallo,


    Ich habe folgende Meldung im syslog:

    Code
    1. Apr 8 11:59:38 localhost systemd[1]: vdr-addon-lifeguard-ng.service: Service has a D-Bus service name specified, but is not of type dbus. Ignoring.
    2. Apr 8 11:59:41 localhost systemd[1]: Reloading.
    3. Apr 8 11:59:42 localhost systemd[1]: vdr-addon-lifeguard-ng.service: Service has a D-Bus service name specified, but is not of type dbus. Ignoring.
    4. Apr 8 11:59:42 localhost systemd[1]: Reloading.
    5. Apr 8 11:59:43 localhost systemd[1]: vdr-addon-lifeguard-ng.service: Service has a D-Bus service name specified, but is not of type dbus. Ignoring.

    Muss ich etwas dagegen unternehmen?


    MfG

  • Das ist nur eine Warnung - ich habe den Service-Typ im Git mal auf dbus umgestellt, ein neues Paket kommt demnächst.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo,

    heute habe ich ein neues Thema, zu dem ich sonst hier nur Beiträge gefunden habe, die mind. 3 Jahre alt sind.
    Der schnelle Rücklauf bei Aufnahmen funktioniert nicht mehr !
    wenn ich den schnellen Rücklauf starten will, bleibt der VDR 'stehen', nur noch ein Standbild, und keine Reaktion auf die FB.
    Es braucht auch mehrere Versuche auf der Konsole mit "sudo service vdr stop" - "sudo service vdr start" bis das Programm wieder läuft.

    Es ist egal, ob es eine HD Aufnahme ist oder nicht.

    Aus dem syslog werd' ich auch nicht recht schlau:

    Start der Wiedergabe:

    Ein paar mal vowärts Springen (1 min.), dann Taste "Rewind"


    Ich habe eine aktuelle yavdr ansible Installation (VDR 2.4.0)


    Andererseits, der schnelle Vorlauf geht ohne Probleme !!!


    Kennt das jemand ? Hat jemand das gleiche Problem ?

  • Hi,

    Du solltest noch erwähnen, dass du das xinelibout nutzt. Das nimmt sonst kaum noch jemand.

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Ich habe eine aktuelle yavdr ansible Installation (VDR 2.4.0)

    Und was für Hardware? Ich kann morgen mal versuchen das zu reproduzieren, bislang wird für vdr-sxfe nichts besonderes konfiguriert - das Plugin kommt notgedrungen zum Einsatz, wenn man yavdr-ansible in einer VM installiert, ansonsten ist das vdr-plugin-softhddevice-openglosd vermutlich weniger unproblematischer (softhddevice-vpp kann auf einigen Nvidia-GPUs Farbfehler verursachen).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo,

    die Hardware ist ein ASRock Intel Board, eine Cine S2 V7 und eine NVidia GT730.

    Ich habe jetzt mal das softhddevice (libvdr-softhddevice.so.2.4.0) aktiviert,

    damit funktioniert auch der schnelle Vor- und Rücklauf !!

    Allerdings hatte ich zweimal einen Neustart des VDR Programms beim Vorspulen,

    mein Eindruck war, das passiert, wenn man zu schnell auf die zweite Geschwindigkeit

    hochgeht.

    Was aber seltsam ist, dass die Farben beim Elchi-Skin (und auch bei anderen) jetzt total

    anders sind; ich finde kein Farbschema mehr, dass gut lesbar wäre

    Was würdet ihr für die GT730 empfehlen ?

    ciao

  • Was würdet ihr für die GT730 empfehlen ?

    Die GT730 hat mit dem vdr-plugin-softhddevice-vpp Probleme bei der OSD-Farbdarstellung, am besten das Paket vdr-plugin-softhddevice-openglosd installieren (das ersetzt das andere Paket).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Also zumindest mit einer GT1030 kann ich den Crash beim Rückwärtsspulen mit xineliboutput nicht reproduzieren. Die Konfigurationsdatei für xineliboutput sieht bei mir aktuell allerdings so aus:

    Code: /var/lib/vdr/.xine/config_xineliboutput
    1. .version:2
    2. audio.synchronization.av_sync_method:resample
    3. video.processing.ffmpeg_thread_count:2
    4. engine.buffers.audio_num_buffers:800
    5. engine.buffers.video_num_buffers:250
    6. engine.buffers.video_num_frames:50
    7. engine.performance.memcpy_method:kernel

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,

    Spulprobleme, dass der Vdr bei zu schnellem Spulen in SHdd (alte Version) abstürzt, hab ich in easyvdr 3.5 leider auch auf mehreren Rechnern. Manchmal kann man auch Spulen vorwärts nicht stoppen sondern muss erst zurückspulen und kann erst dann anhalten, tritt nur auf wenn länger als ein paar Minuten (2-3 ca) vorgespult wird.


    Ist also ein generelles Softhddevice Problem.


    Neuere habe ich noch nicht versucht.

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Hallo

    seahawk1986 :

    der Tip mit dem vdr-plugin-softhddevice-openglosd war gut, jetzt sieht der Elchi Skin wieder so aus wie er soll.

    Vor- und Rücklauf scheinen auch zu funktionieren, auch mit verschiedenen Geschwindigkeiten, zumindest bleibt
    VDR nicht mehr 'hängen'.


    Eine Frage noch, nur zu meinem Verständnis: ich dachte bisher, das softhddevice wäre nur für den Fall, dass die GPU
    kein HD unterstützt und das dann in Software emuliert (unter Einsatz von CPU Power), ist das ein Irrtum meinerseits ?


    ciao

  • softhddevice ist etwas anderes als das uralte softdevice - ersteres nutzt VDPAU, um mit nvidia-Karten hardwarebeschleunigt Videomaterial zu dekodieren, letztes macht das auf der CPU.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo,


    erstmal ein Riesendank an seahawk für das playbook, ich konnte das system ohne probleme aufsetzen.

    Allerdings habe ich ein Problem mit dem Systemstart, es dauert über eine Minute bis die DVB Devices erstellt werden:

    Hat einer ne Idee woran das liegen könnte?

  • Sieht man eventuell in der Ausgabe von dmesg, was da mit den Treibern für die DVB-Tuner passiert?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich sehe da nur Meldungen für eine DVB-Karte (TT-Budget S2-1600 PCI) im System - wenn das stimmt, warst du mit der Aktivierung der wait-for-dvb@.service etwas großzügig - dann solltest du die Instanzen von wait-for-dvb@.service, für die es keine Karten gibt, wieder deaktivieren: systemctl disable wait-for-dvb@{1..3}.service und dafür sorgen, dass nur für die nullten Adapter eine aktiv ist: systemctl enable wait-for-dvb@0.service

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)