yavdr ansible

  • Ich habe der Rolle vdr gerade zwei neue Tasks hinzugefügt, mit Hilfe derer man eine channels.conf ins System kopieren lassen kann, falls noch keine existiert:



    Für lokale Dateien kann man die Variable vdr_channels_conf definieren (z.B. in einer host_vars/localhost.yml), um eine auf dem Rechner vorhandene channels.conf ans Ziel kopieren zu lassen, also z.B.:

    Code: host_vars/localhost.yml
    1. vdr_channels_conf: /path/to/my/channels.conf

    Alternativ kann man die Variable vdr_channels_conf_url definieren (damit die einen Effekt hat, darf die Variable vdr_channels_conf nicht definiert sein), um die Kanalliste über HTTP(S) oder FTP zu laden:

    Code: host_vars/localhost.conf
    1. vdr_channels_conf_url: https://example.com/channels.conf

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke!


    Das ist ein weiteres, tolles Feature von ansible :)

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Hello,

    I lost the picture on TV after some changes. I see that vdr is working on imonlcd display. On TV I see only yavdr logo.


    [softhddev]CreateOsd: left 96, top 54, level 0, using OpenGL OSD support

    Mar 18 21:59:54 htpc vdr: [1235] [softhddev]detached - OpenGl Worker Thread not tried to start

    Mar 18 21:59:54 htpc vdr: [1235] [softhddev]OpenGl Thread not started successfully, using Dummy OSD

    Mar 18 21:59:54 htpc vdr: [1235] [softhddev]SetPlayMode: 0

    Mar 18 21:59:54 htpc vdr: [1235] [softhddev]SetVideoDisplayFormat: 1

    Mar 18 21:59:54 htpc vdr: [1235] [softhddev]GetSpuDecoder:


    How can I repaire this?


    BR.

  • What did you change?


    The softhddevice fronted seems to be detached, so i am wondering if the dbus2vdr plugin has been loaded by the vdr. Please post the complete log after a reboot (you can redirect the output into a file):

    journalctl -l -b

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,

    I have upgraded packages from your repo ppa:seahawk1986-hotmail/vdr-2.4.0. After that the dvbapi plugin was removed.

    So I have tried to install it fromother repo (from frodo) and I think there was to many changes.


    Log in attachment.

    BR.

  • Code: Log.txt
    1. mar 18 22:30:48 htpc bash[1122]: Failed to enable unit: Unit file yavdr-frontend.service does not exist.

    Are the packages python3-yavdrfrontend and yavdr-frontend-tools still installed?

    Code
    1. apt-cache policy python3-yavdrfrontend yavdr-frontend-tools

    I have upgraded packages from your repo ppa:seahawk1986-hotmail/vdr-2.4.0. After that the dvbapi plugin was removed.

    So I have tried to install it fromother repo (from frodo) and I think there was to many changes.

    I increased the abi version of the vdr package because some of the recent patches realeased for VDR 2.4.0 (ftp://ftp.tvdr.de/vdr/Developer/Patches/vdr-2.4/) changed header files - so all plugin packages need to be rebuilt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi seahawk1986,

    Thnk you again.

    The python3-yavdrfrontend was missing. After installation everything is ok.

    Is it possible to install dvbapi plugin from frodo repo? Or how can I build such package?


    Next question is if this is a good choice to by nvidia GT1030?


    BR.

  • Is it possible to install dvbapi plugin from frodo repo? Or how can I build such package?

    The package needs to be rebuilt using the header files from the most recent vdr-dev package - you can do this yourself like for every other debian package - get the package sources, satify the build-dependencies and rebuild the package - those steps are e.g. described in https://www.unixmen.com/apt-rebuilding-package-debian/


    Adding a PPA with an additional deb-src line is simple - just add the --enable-source Argument to the add-apt-repository command.

    Next question is if this is a good choice to by nvidia GT1030?

    It depends on what you are trying to do - this model works fine for typical SD and HD content (I bought one for german DVB-T2, which uses 8-Bit HEVC in Full-HD) , but for outputting UHD 10-Bit HEVC content without conversion to 8-Bit there are several hurdles to overcome (which are partially addressed by the softhdcuvid-Plugin, which is somewhat tricky to build) - the nvidia driver seems to limit 10-Bit output to using RGB instead of the more popular YUV color space which is used by most consumer televisions.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo an alle, meine Probleme mit Festplatte sind bisher nicht mehr aufgetaucht. Das System läuft seit Wochen ohne Probleme.


    Ich hab mir jetzt mal TVGuide installiert als EPG, kann ich mir das auf ne Taste binden?


    Und lohnt es sich auf VDR 2.4 zu wechseln?

    VDR 1:
    Mainboard: Foxconn 45GM
    Prozessor: Core2Duo E6600
    Grafik: Geforce 210 Low Profile (passiv)
    DVB-Karte: Skystar HD/SkyStar HD 2
    Festplatten: 60 GB SSD als Boot/ 1 TB HDD als sdb gemountet als /srv
    Distri: Yavdr 0.6
    zusätzliche Pakete: yaepghd, istreamdev, Filezilla Client
    ----------------------------------------------------------------------
    VDR 2:


    Raspberry PI 512 MB
    16 GB SD Karte
    MLD 4 als Streamdev Client am VDR 1 für Gäste


    ------------------------------------------------------------------------


    (Linux ist ein System das durch Schmerz, Frust und Leid erlernt werden muss, aber wenn es einmal läuft macht es tierisch viel Spaß)

  • Ich hab mir jetzt mal TVGuide installiert als EPG, kann ich mir das auf ne Taste binden?

    Ja, über die keymacros.conf (vgl. man 5 vdr, Abschnitt KEY_MACROS) - also z.B. um tvguide mit der Taste User9 zu starten:

    Code: /var/lib/vdr/keymacros.conf
    1. User9 @tvguide

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Und lohnt es sich auf VDR 2.4 zu wechseln?

    Bei yavdr-ansible hast du OOTB einen VDR 2.4.0. In den letzten Tagen hat Klaus etliche Patches zur Behebung von Fehlern und Unschönheiten bereitgestellt, die ich versuche zeitnah in die Pakete im PPA einzubauen. Wenn man Plugins nutzt, die nicht aus den PPAs stammen, muss man die halt neu bauen, wenn sie nicht mehr zur ABI-Version des VDR-Pakets passen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Vor allem müsst ihr aufpassen, dass ihr am Ende wieder zur ABI Version von Klaus zurückfindet.

    Es geht nicht um die "API-Version", die im vdr definiert ist, sondern um die ABI-Version des Debian-Pakets.


    Dort wird bei Änderungen an vdr-Header ein entsprechend virtuelles Paket als Abhängigkeit hinzugefügt, von dem auch die Plugin-Pakete abhängig sind, so dass man ein altes Plugin-Paket nicht zu einem neuen vdr-Paket installieren kann.

    Kommt dann der vdr 2.4.1, wird die ABI-Version dann sowieso wieder auf 2.4.1 (plus Distributions-Suffix) geändert.


    Das passiert auch, wenn sich Header im vdr durch weitere (externe) Patches ändern. Denn immer, wenn sich die Header ändern, müssen die Plugins neu übersetzt werden (ist eine Daumenregel, genauer genommen nur dann, wenn sich die ABI-Kompatibilität ändert, also z.B. Member in structs/Klassen verschieben bzw. mitten drin hinzukommen usw.).


    Lars.

  • Ich habs schon gesehen und einen Patch für glew von den Debianern übernommen - softhdcuvid hat damit gebaut (müsste demnächst veröffentlicht werden).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Falls noch jemand eine Rolle für den vdr-mounter gebrauchen kann.

    vdr-mounter_V1.tar.gz

    Die Version wurde von Murry  hier gepostet.

    Ich habe nur kleine Korrekturen vorgenommen und sie in die Rolle umgesetzt.

    Zum Abschluss muss der VDR neu gestartet werden, damit die neue Gruppenzugehörigkeit (plugdev) greift.


    Gruß

    Frank

    YaVDR-ansible , Case: HFX Classic, Mainboard: ASUS H97M-E, CPU: Intel Celeron CPU G1840T, GPU: GeForce GT 1030, DVB-S: Digital Devices Cine S2 V6

    YaVDR-ansible (24/7), Case: Akasa, Mainboard: NUC D34010WYB, DVB-S: Sundtek SkyTV Ultimate 6 2016/Q1, Miscellaneous: epgd, pihole (DoH)

    YaVDR-ansible (headless), System: HP 260 G2 DM, DVB-S: SkyTV Ultimate IV

  • Hallo seahawk1986 ,


    der Remotezugriff auf den VDR mit vdr-plugin-xineliboutput funktioniert nicht ootb.

    Könntest Du im Paket die Konfiguration des Parameters --remote ändern?

    Oder spricht etwas dagegen?

    Aktuell steht in der Datei 50-xineliboutput.conf:

    --remote=127.0.0.1:37890

    Dies sollte meines Erachtens aber

    --remote=:37890 heißen.

    An welcher Adresse gelauscht wird, kann man ja im Plugin über OSD einstellen.

    Setup.conf Parameter xineliboutput.Remote.LocalIP =


    Gruß

    Frank

    YaVDR-ansible , Case: HFX Classic, Mainboard: ASUS H97M-E, CPU: Intel Celeron CPU G1840T, GPU: GeForce GT 1030, DVB-S: Digital Devices Cine S2 V6

    YaVDR-ansible (24/7), Case: Akasa, Mainboard: NUC D34010WYB, DVB-S: Sundtek SkyTV Ultimate 6 2016/Q1, Miscellaneous: epgd, pihole (DoH)

    YaVDR-ansible (headless), System: HP 260 G2 DM, DVB-S: SkyTV Ultimate IV